DRM, Broken Drive, driver or windows problem? (rip/playback)

Discussion in 'AnyDVD HD (Blu-ray issues)' started by FlamingTP, Dec 9, 2017.

  1. FlamingTP

    FlamingTP New Member

    Okay, so I'm having trouble with DVD/blu-ray, playback and ripping and have done everything I can on my end without posting here. Anyway, on to the details (logs will be provided for a couple of examples):

    Software: I use AnyDVD HD and MPC for playback, and MakeMKV for ripping.
    My Drive is an LG HL-DT-ST BD-RE WH12LS38, firmware is latest 1.03 (problems occur on old firmware too), drivers are ancient windows default ones from 2006, there is no alternative or newer driver that I am aware of.
    Windows 10, fully updated
    AnyDVD HD version is 8.2.0.0

    For early reference I have attempted the following:
    -complete reinstalls of everything, including the OS.
    -Using the programs seperately without installing the others for testing
    -copying other, unprotected media using the drive.
    -available workarounds, such as canceling the rip before it crashes and manually copying the m2ts files directly off the drive
    -using other playback software such as VLC
    -attempting to rip to an SSD instead of a standard hard drive
    -I would try making an ISO and using mounting software but I cant even make the iso files unless its a DVD.
    -Disabling SLI (no clue if this has anything to do with how the programs work but I did that anyway.)
    -tried half a dozen other blu-rays, to see if I just had a couple of bad discs.

    Basic behavior:
    DVDs playback without issue most of the time, however sometimes they stop abruptly, and the drive stops reading the disc. Ripping through any method is flawless and causes no problems what-so-ever.
    Blu-ray playback for old blu-rays (the matrix/the crow) behaves like DVDs do, flawlessly or with the same issue as DVDs. Ripping however does not work. Newer blu-ray films encounter errors in ripping faster than old ones. (log files for two examples provided)

    Newer blu-rays have significantly faster stoppage with playback, and encounter ripping errors faster than old ones. stutter does not occur. playback/ripping cease completely and the drive stops reading the disc.

    Ripping causes serious issues with my computer when I attempt it on a disc that wont work. For example, attempting to abort locks the computer if ripping is able to start. Sometimes it doesn't start, and just freezes the program completely or crashes explorer entirely. I also suspect some conflict may be occurring between AnyDVD HD and MakeMKV although I have no idea why. For instance if I try to copy the disc without decrypting in makeMKV, anyDVD will start processing the disc even though it did so anyway when I put it in the drive.

    Sometimes anyDVD scans the disc, and then my computer ejects the disk asking me to insert one. this can happen multiple times before everything seems fine. and I can try again.

    my drive has no issues copying CDs or anything and copys anything I burn unrelated to movies without issue.

    Specific errors:
    Sector errors with AnyDVD when trying to rip via folder structure, trying to rip to ISO results in lockups and
    no error or the PC things there is no disc in the drive.

    MakeMKV gives me OS errors saying there is no disc in the drive or crashes when trying to verify m2ts files. however the file it locks up on is random every time. the same is true when just making a backup.

    As stated before the drive stops reading the disc immediately after an error occurs. however the drive is not overheating. not sure if this is important information but blu ray ripping speed while it is working, before it crashes is slower in drive spin speed than when ripping a DVD. (1.6x or 2x vs 8x or higher, all such settings are at their default values, I have not messed with this.)

    All DVDs or Blu-ray discs I have tried were purchased from the local store, in this case best buy or ordered on amazon. the logs I have provided were from copies purchased at the local stores.

    any advice on process of elimination here?
     

    Attached Files:

  2. FlamingTP

    FlamingTP New Member

    I decided to grab power DVD ultra to see if having licensed software fixes the issue, it doesn't. Trying to play a blu-ray (any blu-ray), it plays most if not all of the auto-play stuff fine, but as soon as it gets to the menu and I hit play it crashes, or plays for a couple seconds and dies. After this happens, anyDVD refuses to load and no player can recognize I have a drive. but explorer does. it wont open the disc though. After a few minutes the problem corrects itself and I can access the disc again, or explorer crashes and attempts to reload. Sometimes if I eject the disc the problem fixes itself faster.

    So I guess the question is, is this a serious driver problem or is it my drive? It cant be DRM, and I'm assuming it isn't windows itself, otherwise other people would be having the same sort of problem. I don't have any other drives to test my discs on, just the stand-alone players that always work.
     
  3. FlamingTP

    FlamingTP New Member

    Got an external from best buy, playback is fine, rips probably will be too, feel free to close this one. I suppose its possible it's a windows ten incompatibility too, but I have no way of being certain.
     
  4. James

    James Redfox Development Team Staff Member

    Before throwing the drive away, please test it with the lastest AnyDVD beta, as there was a driver regression problem.
     
  5. BrianG61UK

    BrianG61UK Well-Known Member

    What drivers?

    Optical drives normally don't need drivers.
    Windows normally just installs it's default optical drive stuff for them.
     
  6. James

    James Redfox Development Team Staff Member

    The AnyDVD driver, which does all the magic.
     
  7. BrianG61UK

    BrianG61UK Well-Known Member

    No, I was asking what "drivers are ancient windows default ones from 2006, there is no alternative or newer driver that I am aware of" refers to.