Downloaded Files contain no audio in properties

Discussion in 'AnyStream' started by Little Fox, Nov 22, 2020.

  1. Little Fox

    Little Fox Member

    Hello friends,

    I'm completely new here and first of all I congratulate the developers of AnyStream for this product. Secondly please excuse my bad English, which I'm still trying to improve. I'm using Win-10 and have bought a lifetime license for the version 1.0.6.1 64bit. The downloads are all fine and the videos are playing on VLC as well as on my QNAP-Media, which is connected to my TV. So far so good.

    I remember, however, from the advertise that it is also possible to convert these mp4 files into any other format if needed. I tried this and to my suprise after the conversion the audio-file is completely missing. Only the video is fine. Going furthermore into the properties of the mp4-file the audio properties are missing. The video properties are all there. This is a mystery for me, as the mp4-files when played on the VLC or on my QNAP-Multimedia all are playing with audio AND video.

    I also tried this on my old Win-7 PC and got the same results for all downloaded files.

    I mean I can live with mp4-files, but I still wonder where the mistake might be ?

    thank you for your answer and regards
     
  2. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    You remember wrong. Nowhere is it stated that anything downloaded with anystream can be converted to anything else. AnyStream is a downloader. It grabs the streams, puts them in an mp4 contaziner and that's all it does. Those property screenshots are from DBPowerAmp MUSIC converter. It's not built to handle VIDEO files.
     
  3. Little Fox

    Little Fox Member

    Well my fried please find attached the german advertise where is stated that the downloaded files also can be converted if needed
     
  4. Little Fox

    Little Fox Member

    And here it is in English - or do I understand this completely wrong ???
     
  5. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    It clearly states 'downloads as mp4'

    Note the phrase: 'and it can be converted with VIDEO EDITING SOFTWARE OF YOUR CHOICE into other formats such as mkv'.

    It does NOT state that AnyStream can be used to do the conversion

    DBPoweramp (which btw I use myself) isn't video editing software. That's an audio file converter.

    Video editing software is stuff like vso software's 'video converter ultimate', or stuff like Adobe premiere I think...

    Sent from my Pixel 3 XL using Tapatalk
     
  6. Little Fox

    Little Fox Member

    Thank you very much for your reply. I'm fully aware that anystream is not a converter and that I have to use another software for this purpose (e.g. the AVS-Video converter). However, the audio-file is missing once I try to make a conversion.
     
  7. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Then that's a problem for that conversion software you used. Not an AnyStream one. If the downloaded file plays give in like VLC (thus with audio), then AnyStream did it's job. If the conversion tools output file then lacks audio, they messed up.

    Note: if you just want to go from mp4 to mkv, an excellent free tool is MakeMKV(TOOLBOX GUI). No recoding involved, just straight up demuxes the mp4 container and remuxes into mkv.

    Sent from my Pixel 3 XL using Tapatalk
     
  8. Little Fox

    Little Fox Member

    ok friends and tku vm for your help. We leave it there for the moment and tomorrow I will try the MakeMKV program just for testing purposes, beause originally i intended to convert into TS with the AVS-Video Converter. Personally i doubt that it will work, because my belly tells me that if i rightclick on windows to the mp4-file, choose audio properties and there are 0kb audio properties I wonder how the MakeMKV program can manage it. But I will try of course and will keep you posted about the results. By the way did anyone already try to convert the mp4-file into another format ??
     
  9. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    MakeMKVtoolnixGUI works just fine. Used it myself to update audio language tags before a fix was implemented for that bug at the time.

    Sent from my Pixel 3 XL using Tapatalk
     
  10. Mollenoh

    Mollenoh Well-Known Member

    Don't you mean MKVToolNix ? MakeMKV is as far as I know only for converting discs (DVD or Blu-ray) to MKV files.
     
  11. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Right that's the one, MKVtoolnixGUI. (I need the gui version cause I'm not an expert at cli)

    Sent from my Pixel 3 XL using Tapatalk
     
  12. Kamala

    Kamala Well-Known Member

    it's not converting them. MKV is a container file. ;P
     
  13. Mollenoh

    Mollenoh Well-Known Member

    Even the developer himself disagrees with you:
     
  14. Little Fox

    Little Fox Member

    Ok friends, in the meanwhile I tried a conversion with the VLC-Media player into TS (just for testing purposes) and it worked well. So the problem is with the AVS-Video converter software, which for some reason does not identify the audio track of the mp4-file. However, I can also live comfortably with mp4.

    So thank you for your help and have a good day