Divergent (dvd) / Handbrake / 4Kb

Discussion in 'AnyDVD HD (DVD issues)' started by Pveatherfall, Apr 22, 2016.

  1. Pveatherfall

    Pveatherfall Member

    Hey guys! I love anydvd and have had very few problems. This is the first disc in a while that's given me trouble. New disc right out of the box for the original Divergent movie. AnyDVD seems to read it just fine and after scanning, Handbrake pops up with the options and can find the title like normal. The issue is when going to create the file, it runs for about 10 seconds, creating a 4kb file and then saying it is done.

    I'm running 7.6.9.5 and I've attached the log file since that always makes life easier, but to speed things up, I did a mini copy/paste. I've tried this disc on another machine and got the same issue. I looked at the complaints others had, but I'm not having issues with multiple playlists or of skipping between scenes or even of 10 minutes worth of a black screen. I did double check and have turned on CSS Mastering Errors as someone had mentioned that in a previous post, but it didn't change my outcome. Opinions?

    Summary for drive D: (AnyDVD 7.6.9.5, BDPHash.bin 16-03-25)
    MATSHITA DVD-RAM UJ8HC 1.00 14110700
    Drive (Hardware) Region: 1

    Current profile: DVD-ROM
    Media is a DVD.
    Booktype: dvd-rom (version 1), Layers: 2 (opposite)
    Size of first Layer: 2084960 sectors (4072 MBytes)
    Total size: 4169920 sectors (8144 MBytes)

    Video DVD (or CD) label: Divergent
    Media is CSS protected!
    Media is locked to region(s): 1!
    Video Standard: NTSC

    Using local database!
    Found & removed structural copy protection!
    Found & removed invalid cell pieces!
    Found & removed bogus title set(s)!
    Found & removed invalid VOBUs!
    RCE protection not found.
    UDF filesystem patched!
    Patched DVD volume label!
    Autorun not found on Video DVD.
    Removed CSS copy protection!
    Found & removed 39 potential bad sector protections!
    Emulating RPC-2 drive with region 1!
     

    Attached Files:

  2. DrinkLyeAndDie

    DrinkLyeAndDie Retired Moderator

    Try this: In Handbrake go to Tools > Options > Advanced > under DVD Reading check the "Disable LibDVDNav. (libdvdread will be used instead)" checkbox.

    Does it fix the problem?
     
    nebostrangla likes this.
  3. Pveatherfall

    Pveatherfall Member

    Wow that totally did it. I've never had to use that option before. I get the science behind it. I was looking all through AnyDVD trying to figure if I had a setting wrong. Thanks! I learned something new. You are totally awesome!
     
  4. DrinkLyeAndDie

    DrinkLyeAndDie Retired Moderator

    Glad it solved your problem. :)

    The root of the problem is actually with LibDVDNav as is used by default in Handbrake. This issue has occurred with a number of DVD releases including Red 2, Ender's Game, Hunger Games: Catching Fire, and Monty Python's Holy Grail. There are likely more problematic discs, as well.
     
  5. Clams

    Clams Well-Known Member

    Drinky, Am I correct that it was you who first discovered this "quirk" and subsequent fix?
    I know I've seen it work about 10 times now for different titles vs Handbrake.
    -W
     
  6. DrXenos

    DrXenos Well-Known Member

    Just make sure you change the setting back when you're done. libdvdread (which is used when you disable libdvdnav) can't handle angles (if you care).

    DrX
     
  7. mmdavis

    mmdavis Well-Known Member

    Yes it was, over two years ago when Red2 came out.
     
  8. DrinkLyeAndDie

    DrinkLyeAndDie Retired Moderator

    I found the fix and source of the problem but I didn't initially discover the issue. Someone reported the issue with Red 2 when using Handbrake and thought it was an AnyDVD problem. I decided to take a look at it. Some simple tests, a hunch, and voila. Success. It's annoying but the solution is insanely easy. :)

    Reference: https://forum.redfox.bz/threads/solution-red-2-anydvd-handbrake-and-reported-css-issues.58960/
     
  9. DrinkLyeAndDie

    DrinkLyeAndDie Retired Moderator

    Interesting. I didn't know this about LibDVDRead vs LibDVDNav. Thanks for sharing that information.
     
  10. SpiderPig

    SpiderPig Member

    I have just had the same problem with Bloodfather. Switching to disable LibDVDNav in Handbrake did not fix the 4 kb output file issue on this DVD. Anyone have another suggestion?
     
  11. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Either way, conversion issues are NEVER an AnyDVD issue. Even if it fails at 4kb. AnyDVD doesn't convert at all. You can try ripping with AnyDVD to HDD first and use that. If the rip succeeds, then AnyDVD did it's job and it's still a handbrake issue.

    Sent from my Nexus 6P with Tapatalk.