Resolved Disc is not seen, but works in a player: Lost Colony: The Legend of Roanoke (2007)

Discussion in 'AnyDVD HD (DVD issues)' started by ClicketyClack, Jan 24, 2023.

Tags:
Thread Status:
Not open for further replies.
  1. ClicketyClack

    ClicketyClack Active Member

    UPDATE: This worked with a Samsung Portable BD Writer Model SE-506

    I was going to simply delete this post, but maybe it would be helpful to someone else who is also stuck with their disc not being recognized. My normal LG player is a fullsize in a Vantec USB case, so I don't know why one would work and not another.

    I just received a DVD of Lost Colony The Legend of Roanoke (2007). The case and the DVD are pristine and obviously legitimate.

    The disc works in my Playstation, but my computer will not recognize the disc, indicating that the disc is not inserted.

    My Windows 11 Pro won't see that the disc is inserted and I've tried with and without AnyDVD, MakeMKV and CloneDVD2.
     
    Last edited: Jan 24, 2023
  2. coopervid

    coopervid Moderator

    I guess your drive's laser has died. Try any other data or movie DVD.
     
  3. ClicketyClack

    ClicketyClack Active Member

    Thank you! I just posted an update. The drive continues to work as expected with any other disc, just not this Roanoke one. (I just now tested it again.) I'm glad that I never throw away and computer stuff, this Samsung portable saved the day once I cleaned off all the dust!
     
Thread Status:
Not open for further replies.