Delay loading optical disc - Win7 64-bit - ASUS mainboard (solved)

Discussion in 'AnyDVD HD (Blu-ray issues)' started by dickerhals, Oct 18, 2015.

  1. dickerhals

    dickerhals Member

    hello,

    i am new in this forum but i am using anydvd hd (with unlimited licence) for some years on win xp 32-bit without any problems.
    now i upgraded my system to an i5-6500 with ddr4 an ssd and win7 64-bit and got the following problem:

    when i load the drive with a bluray, anydvd is not checking the drive.
    it remains with "drive is empty" (of course the activation button in the bluray-setting is checked)
    and the program hangs up.
    when i start anydvd with a bluray in the drive (without anydvd in autostart), the bluray is checked.

    anydvd needs about 10 min to be stopped by using the rightclick menu of the systemtray icon. same when i end the task using the task manager and the same it rests when i shutdown the computer in this mode, perhaps waiting to end the anydvd program.

    starting and ending anydvd with an empty drive, without checking any discs is often no problem.
    ok, 4 times checked with no problems, now it stucks. :-(

    the user access control in my system is activated, so i have two ways to start the programm:
    just doubleclick the desktop icon and run in protected mode (although my account is the administrative account) or rightclick the icon and "run as administrator".
    is there a difference that effects the behavior of anydvd?

    im working on this since a week now, recovered a backup, that i made befor installation of anydvd, installed new, sometimes with my licence, sometimes using the testperiod.

    now, i am using the testperiod and when windows startes, i got the message of the 21 days testperion, when i confirm the message i get it another time, so is the driver running twice?
    this happens when starting with autorun and already without autorun by clicking the icon and "run as administrator".
    but only once when there is no disc in drive and i did not "run as administrator"
    confusing...

    more informations about my system:
    the ssd is plugged to port one to the silicon image main (because 6 ports) onboard controller.
    the liteon bluray drive is plugged on port two to the same controller.
    the 4 remaining ports of the silicon image controller and both ports of the asmedia controller are plugged to hdd devices.
    i also plugged in an pci express card from delock (2x power over esata 5v/12v),
    the delock controller ports are free (or plugged to hdd devices, makes no difference).
    so now there are 3 sata controller working (see attachement, 2 onboard and the pci express card)
    View attachment 27752

    i made a fresh instell of win7 64-bit on the ssd.
    beside the drivers for the mainboard, the pci express card and the windows updates (there was also an optional update for the siliconimage storage controller)
    the following softwareis installed:
    - samsung magician (for the ssd drive)
    - windows essentials
    - firefox
    - anydvd hd

    as you can see, the windows installation is nearly clean.
    i had no problems with the drives while installing and using installation cd or dvd.

    i searched the forum and this is what i found and changed, updated and checked:
    - changed the sata cable (the one to the bluray drive, now there is also one that "clicks" into place)
    - updated the firmware of the drive (liteon bluray drive: atapi ihos104 scsi cdrom drive)
    - checked the registry for the entry: in value "LowerFilters" should contain "AnyDVD" in string:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}

    please can you help me, i really have no idea left.

    thanks in advance

    dickerhals
     
    Last edited: Oct 19, 2015
  2. dickerhals

    dickerhals Member

    hello again,

    just watched the taskmanager while starting anydvd hd with a doubleclick ("not run as administrator") and a bluray in the drive:
    there are two programms started: "AnyDVDtray.exe" and "ADvdDiscHlp64.exe"
    when i start the program whithout a disc in drive there is only "AnyDVDtray.exe" in the manager.
    perhaps this is the reason for the second popup with the test period.
    but the main problem still remains the same...

    regards

    dickerhals
     
  3. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Could be related but on my win7 system both processes are active with no discs in the drive. It may be because that 2nd process isn't started when there's no disc in the drive that the problem occurs. Win 7 ultimate x64 here.
     
  4. dickerhals

    dickerhals Member

    hello ch3vr0n,

    thank you for your time.

    i just tested this with anydvd hd in autostart:
    restart with no disc in drive:
    - one times the trial message- both processes "AnyDVDtray.exe" and "ADvdDiscHlp64.exe" running.

    restart with bluray in drive:
    - two times the trial message- both processes "AnyDVDtray.exe" and "ADvdDiscHlp64.exe" running.
    the anydvd systray says: on 1 off 0 empty 0
    i took the disc out, the messeg in the tray gets to on 0 off 0 empty 1
    in windows file-explorer the drive is already shown with the name of the bluray (that is no longer in the drive)
    i inserted a normal cd and clicked the drive, waiting for about 3 mins, then i got the windows message:
    please insert a disc into drive, i canceled the window, the cd was read, the new name appears in the file-explorer and anydvd opens a new window for the test period, and the info at the systray says: on 1 off 0 empty 0.

    so for me the message appears one time while starting the programm and every time scanning a new disc.
    but this is not my main problem and wil be solved when i insert my licence code.
    i just hope this will help things to find out.

    ONE STEP CLOSER TO THE PROBLEM:
    watching the behavior of windows file-explorer and anydvd when i change discs bd, dvd, cd
    the problem seems to be the time it takes until the new disc is shown. this time it takes about 3 mins.
    to check if its only between different formats i tested it with two cds. the same, so it has nothing to do with cd, dvd and bd format.
    as soon as the disc is shown in windows file-explorer, anydvd comes with a testperiod message and the disc is scanned.
    (the advancement to use the "test version" for this)

    i stoped anydvd, inserted a cd in the drive and waited to be shown in the explorer.
    then i changed the cd and stoped the time for the other disc to be shown: 40 seconds
    i bet this was faster before i installed anydvd, but i will check this later, because i have to recover the backup for this.
    then i started anydvd with "run as administrator" and got the two messages about test period (two because there is the cd in the drive).
    after the scan ends, the drive shut down and everythin was ok. i changed the cd in the drive and stoped the time again: 248 seconds !
    6 times longer!
    in both versions (with and without anydvd running) the drive reads the disc only for seconds (led on), then the led is not active (and after some time i can hear the drive spinning down) until the new disc is detected and anydvd scans it.
    second test with anydvd on: 237 seconds
    second test with anydvd off: 34 seconds

    i think most of the problems in my first post have something to do with this behavior and that i did not wait long enough until the disc was known to the system and i tried to start or stop anydvd in this delay.

    so, has anybody a suggestion where this delay comes from? do system drivers not compare?

    regards

    dickerhals
     
  5. Crower

    Crower Well-Known Member

    I can't really address your problem at the software level, but I've been running AnyDVD HD on Windows 7 Pro 64 bit for quite a while now with no problems. I added AnyDVD HD to my new laptop which came with Windows 7 installed after changing out the DVD deck with a BD deck. I did need to set the region of the deck when I installed it.

    I'm not running a SSD (using a 1TB HD). Both DVDs and BDs are immediately recognized when I put them in the disc unit.

    Not much help, I know, but maybe something that would lead to a hint.
     
    Last edited: Oct 18, 2015
  6. dickerhals

    dickerhals Member

    I FOUND THE PROBLEM AND IT HAS NOTHING TO DO WITH ANYDVD !

    it was the asus driver installed from the mainboard driver dvd !
    asus hero maximus viii.

    the first backup i made was after installing win7 64-bit and the mainboard drivers, so i tested and tested, many times restoring the first backup...
    i thought it was the pci express card from delock (2x power over esata 5v/12v) whose driver was not directly for win 7 64-bit.
    as i was asked for a driver i just inserted the disc that was delivered with the card years ago and the driver was being installed.

    because of my problem with the optical drive, (although it was not connected to this card, but i supposed an incompatibility of sata drivers)
    i looked closer to the driver on the disc and there was none directly for win7 64-bit, so i searched in the internet, but with no success.
    so i deinstalled the driver and removed the pci express card from the mainboard, again with no success !

    in the end, i don't know how i got the inspiration, i deinstalled (and erased) the asus driver.
    after two or three reboots windows got the drives running with it's own driver (or the driver brougt with windows, let me call it "windows driver").
    now a disc in the optical drive is ready for use in about 10 seconds, that looks normal to me.
    i'm soooo lucky having the problem solved !


    here is the devicemanager with the delay-causing driver from asus:

    MIT delay mit asus-treiber.jpg
    here is the devicemanager with the "windows driver" without delay:

    OHNE delay mit windows-treiber.jpg

    and in the end i installed the pci express card from delock and installed also the drivers brougt with windows:

    OHNE delay mit win-treiber und mit delock pci express karte auch win-treiber.jpg



    of course i installed the sata driver from the asus mainboard dvd again to crosscheck the behavior:
    the delay was back. deinstalling (and deleting) the driver again and the delay was gone.
    so i can be very sure the asus driver causes the problem.

    thank you for your attention

    and thank :censored: :censored: :censored: :censored: I N G asus for wasting my lifetime !

    regards

    dickerhals
     
    Last edited: Oct 19, 2015
  7. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Pretty much knew it couldn't be anydvd to blame or windows directly. The main thing is your problem is solved. :)

    Verstuurd vanaf mijn Nexus 7 met Tapatalk
     
  8. Adbear

    Adbear Well-Known Member

    The Intel rapid storage driver shouldn't cause this kind of issue. You could try getting an updated version direct from the Intel website
     
  9. dickerhals

    dickerhals Member

    hello adbear,

    because nobody wants this behavior, NOTHING should cause this issue, no hardware, no driver, no software.
    but nevertheless the asus driver did!

    at intel website i did not found the driver to download.
    i just tested the latest version loaded from the asus homepage:
    Version 14.5.0.1081
    Beschreibung Intel(R) Rapid Storage Technology Driver Software V14.5.0.1081 for Windows 7 32bit & 64bit / 8.1 64bit / 10 64bit.
    Intel(R) AHCI/RAID Driver for Windows 7 32bit & 64bit / 8.1 64bit / 10 64bit.
    Dateigröße 25.98 MBytes 2015/08/03 Update

    same problem !

    i don't want to test anymore, i will not spend more time in this, for me it ends up right here.
    i am going on with installing software now and finally use the pc for what it's bought.

    thanks anyway

    dickerhals
     
  10. ErichV

    ErichV Well-Known Member

    You can also try the latest one (version 14.6.1.1030) from HERE.
     
  11. Adbear

    Adbear Well-Known Member