Cyberlink PowerDVD Ultra version 2911

Discussion in 'AnyDVD HD (Blu-ray issues)' started by roog, Jun 13, 2007.

  1. roog

    roog Well-Known Member

    Just to give everyone a heads up, I have discovered what might be a problem with PowerDVD Ultra version 2911.

    After backing up the HD DVD movie 'Breach', I tried playing it but PowerDVD would crash, without any error messages, every time it began to play the main feature.

    I tried another new HD DVD movie and it played ok.

    Next I tried playing the rip of 'Breach' on another computer and it played without problems, so then I uninstalled and reinstalled PowerDVD Ultra on the problem computer and then the problem went away.

    Of course it could be a problem with my computer, but because I was able to fix it so easily, I'm speculating that there may be a problem with PowerDVD Ultra that's causing the installation to get corrupted.

    Of course, since it hasn't happened on any of my other computers, I can't be sure.

    If anyone else has any experience with this kind of PowerDVD problem I'd like to know.
     
    Last edited: Jun 13, 2007
  2. Peer

    Peer Redfox Development Team Staff Member

    My experience: if you don't uninstall a previous version and also remove all remaining entries in the registry, you will end up with a partial update,
    I had a version 7.3 here, claiming to be 7.3 on the splash screen and 7.2 on the info window.
    Completely erased the thing and reinstalled from scratch - then it was a full 7.3.
     
  3. Adbear

    Adbear Well-Known Member

    Have to agree with Peer, always completely uninstall and remove all folders etc before installing a newer version
     
  4. bachuka

    bachuka Well-Known Member

    I had the same problem as roog and I played around with my audio settings and it fixed it. I enabled DTS sound under control panel sound and disabled 96 kbs.
     
  5. roog

    roog Well-Known Member

    I verified, under about, that the version is 7.3 not 7.2.

    I'm using PowerDVD Ultra 2911 standalone, not 2905b/2905n/2911, and not as much Cyberlink garbage seems to hang around when you uninstall it.

    I also run the 'Windows Install Clean Up' tool afterwards and remove PowerDVD from the list.
     
    Last edited: Jun 14, 2007
  6. sarah99

    sarah99 Well-Known Member

    I also have this problem with PowerDVD Ultra v7.3 and several movies.
    Christmas Vacation
    Lethal Weapon
    The Hulk (plays green in window but works perfectly full frame)

    It happens on 2 of my computers with XP and v7.3 2911 but v7.2 doesn't have this problem.
     
  7. sarah99

    sarah99 Well-Known Member

    I tried a reinstall, but it didn't work.
    I have gone back to 7.1 (couldn't find 7.2) and that seems to play everything OK.
     
  8. roog

    roog Well-Known Member

    To do so, it looks like you'll either have to delete the registry entries or perform a clean windows install.

    I prefer the latter.

    If you do a clean install make sure you only install the full PowerDVD Ultra 2911 version.
     
  9. Adbear

    Adbear Well-Known Member

    I'm assuming these are hd-dvd's rather than blu-ray as 7.1 is for HD-dvd and 7.2 for blu-ray only
     
  10. roog

    roog Well-Known Member

    Results from installing the new PowerDVD Ultra 2911 full file

    Ok, under Vista 32, I uninstalled my previous PowerDVD Ultra 2911 full version and installed the new file successfully and here are my results:

    Note: I did this on a PC that's never had any version less than the previous 2911 full file installed. I compared the two files and the new one is 7 bytes larger than the old one. Otherwise, I would have assumed that they were both the same and may not have gone to all this trouble.

    Anyway, I unstalled the previous version, then I tried performing the file and folder deletes that are in the Cyberlink instructions. Apparently, these are crap left around by previous versions because I was unable to find them.

    After that, I ran the Windows Install Clean Up tool but, to my surprise, I didn't find an entry for PowerDVD as I have previously found.

    Next, I restarted and began the install. This is where the second weird thing happened. It took five minutes for the InstallShield Wizard to be displayed. I am reasonably sure that this is not an anomally because I have since repeated it on another computer. This did not happen with the previous file so I suspect that some additional cleanup is being performed.

    I almost gave up because it took so long, but I could still see disc activity so I waited. After the wizard was finally displayed, the installation went normally.

    After installation, I have tried playing several movies, both HD DVD and Blu-ray, with no problems so far.
     
  11. sarah99

    sarah99 Well-Known Member

    I have a version that says 7.3 on the splash screen and 7.2 on the "about" screen. But plays all HD-DVDs perfectly (and at 10% less CPU than 7.3 2911)

    [​IMG]

    Then there is v7.1 that plays everything perfectly but starts them with subtitles turned on

    [​IMG]

    Found another HD that crashes PowerDVD v7.3 2911
    The Lake House

    No pauses on installing the latest PowerDVD v7.3 but it still crashes on the problem movies but I have found a fix
    Open PowerDVD, play a second of "Superman Returns", then the problem movie loads and plays OK.
    Have just found my original v7.2/7.3 install file and reverted all PCs back to that as it uses considerably less CPU than all other versions and plays all my HD-DVDs.
     
    Last edited: Jun 22, 2007
  12. RedFox 1

    RedFox 1 Super Moderator

    Please do not post links to any software on this forum. :policeman:
     
  13. Webslinger

    Webslinger Retired Moderator

    Username and passwords, serial keys, etc., that you don't have the legal right to post will definitely not be allowed. :policeman:

    Slysoft does not tolerate illegal postings of its keys, so expect equal respect given to other companies' software here.


    from http://forum.slysoft.com/showthread.php?p=35009#post35009
    "Posting of Cracks or illegal serial numbers for any program or application in this forum will not be tolerated, Slysoft reserves the right to ban you from posting on this forum for the first infraction."

    :policeman:

    We're not going to ban anyone this time, but we shouldn't be getting PMs from Cyberlink complaining to us.

    Thank you for your understanding in this matter.

    I know some of you just want to help out, but that username/password that was posted is obviously intended for paid, registered users only. Otherwise, moderators wouldn't be getting (complaints) PMed by a Cyberlink rep.
     
    Last edited: Jun 21, 2007
  14. roog

    roog Well-Known Member

    Sorry, won't do it again.
     
    Last edited by a moderator: Jun 21, 2007
  15. Webslinger

    Webslinger Retired Moderator

    No problem. I appreciate that you were probably just trying to help out other registered users.
     
  16. roog

    roog Well-Known Member

    Thanks! This is still a learning process for me.