Could not load playlist: SSL handshake failed

Discussion in 'AnyStream' started by zero269, Jan 10, 2021.

  1. zero269

    zero269 Well-Known Member

    I'm seeing this "Could not load playlist: SSL handshake failed" more than I would like.

    I've seen it on a few episodes, but I'm concerned with the movies at this time. Searching this error indicates that restarting AS may resolve itself, but that is not the case for me.

    I've tried the following steps:
    1. Restarted AS; NO GO.
    2. Restarted computer; NO GO.
    3. Tried on a different computer; NO GO.
    4. Tried an AS Trial on my kids laptop; NO GO.
    5. Upgraded from v1.0.6 to v1.0.7; NO GO.
    The Titles I'm consistently having issues with are:
    • American Pie Presents Beta House (2007) [R version]
    • Batman Forever (1995)
    • Best Offer (2013) [No longer available for me to test]
    • Letters To Juliet (2010)
    • Portrait of a Lady (1996)
    I just tried all of the titles - except one - just before posting this.
    See attached for log file...

    I am using a Lifetime license in the US, no VPNs or anything else for that matter.
    It's from the "P" Provider.

    Thanks,
     

    Attached Files:

  2. 0x0x0x0x0

    0x0x0x0x0 Well-Known Member

    I had that happen to me; tracked it to P's CDN (LL) not having a correctly configured host certificate (certificate's DN was set to CDN's true name and not the provider's aliases). I don't know if setting in the environment variable

    Code:
    QTWEBENGINE_CHROMIUM_FLAGS to -–ignore-certificate-errors -–ignore-ssl-errors
    
    fixed it, or I eventually hit a different CDN node, but it eventually went away...
     
    Prospere likes this.
  3. zero269

    zero269 Well-Known Member

    UPDATE 1:

    Although Batman Forever (1995) resolved itself, I've added Heavenly Kid (1985) to the list.


    My main question now is: Is anyone looking into this issue? Is this something we can resolve on our own, or must wait for the next update?

    My concern now are the episodes. I find these to be a hassle and take a great deal of time, but I decided to try a few and see what it was like. What a pain without the QUEUE feature. Not to mention your QUOTA can dry out very quickly on those 20 minute episodes.

    I find myself with a few incomplete seasons now:

    • 21 Jump Street (5 Seasons; 103 Episodes) | SSL handshake failed (x1): s04e22
    • 3rd Rock from the Sun (6 Seasons; 139 Episodes) | SSL handshake failed (x2): s05e08, s06e08
    • Mad About You (7 Seasons; 164 Episodes)| SSL handshake failed (x1): s06e20
    • Stargate SG-1 (10 Seasons; 213 Episodes)| SSL handshake failed (x2): s04e21, s06e14 (for now...)
    What are my options with resolving these SSL handshake failed issues?

    Thanks,
     
  4. zero269

    zero269 Well-Known Member

    Thanks for the recommendation, but I can't say I know what you're suggesting.
     
  5. 0x0x0x0x0

    0x0x0x0x0 Well-Known Member

    Basically it's P's content distribution issue (people think A owns its CDN, they don't), keep trying eventually the problem should go away.
     
    zero269 likes this.
  6. Prospere

    Prospere RedFox Development Team

    Of course. Even if a post describing a problem is left (accidentally) unanswered, we still take note of the issue.
    In this particular case, the error comes from something that we have very little control of. Although, of course, we are looking into it and trying to come with, if not a complete solution, then, at least, something that would give us a better description of the problem (extended logging, for example). At the moment it seems like something unrelated to AnyStream, but then again, we have to either confirm this or provide a solution.
     
  7. 0x0x0x0x0

    0x0x0x0x0 Well-Known Member

    Incidentally, if you go to File > Show log messages, the very last "[Debug] Playlist URL: ..." entry is the one that is failing, simply copy and paste the url into whatever browser you use, and see what error you get from the browser---chances are your regular browser will not let you download it unless you click through numerous "yes I know what I'm doing" and "I understand it could be a hacking attempt" blah blah blah blah warnings...
     
  8. zero269

    zero269 Well-Known Member

    Hello Prospere,

    Thanks for getting back to me. I suspected as much, but when I searched into this specific error, I only found what I believed to be a dead end. I didn't see anything that served as an official position from Redfox, so I figured I would raise my concerns along with the issues I reported.

    Considering this error message is likely to reoccur for many users of AS, perhaps Redfox may want to "pin a message" for others to find right away stating what you said?

    I'll retry my list every now and then. Hopefully they succeed before the titles expire from the Provider(s).

    If there's anything I can do to help with the extended logging, feel free to ping me. I can start with my list of SSL issues and go from there.
     
  9. zero269

    zero269 Well-Known Member

    I did what you suggested, but I'm not sure what I can do with that mpd file. However, I'm curious as to that snippet of code you provided earlier. Is that something I can use? What benefit does it offer?

    Thanks,
     
  10. 0x0x0x0x0

    0x0x0x0x0 Well-Known Member

    It's wasn't to see what you can do with the mpd file, it was to see if you can download it without and SSL/TLS warnings from the browser, because if AS is throwing that error, the browser should flag it as well. If the browser downloads that file without a beep, and AS throws that error, then there's an issue with AS. In my case, the browser complained too so I dug deeper, and it turned out to be a problem with P's CDN provider.



    It's a setting in the windows environment variables, you set variable

    Code:
    QTWEBENGINE_CHROMIUM_FLAGS
    
    to value

    Code:
    -–ignore-certificate-errors -–ignore-ssl-errors
    
    but I'm not sure how effective is for the AS's embedded QT engine
     
    Last edited: Jan 14, 2021
  11. Prospere

    Prospere RedFox Development Team

    It isn't. The chromium based browser has nothing to do with the download process itself.

    It may be, however, related to the SSL implementation, although, I am not quite sure about it. The error does not occur immediately upon download initiation, but somewhere later...
     
  12. 0x0x0x0x0

    0x0x0x0x0 Well-Known Member

    So I've encountered it again, and the attached pictures show how this is not AS's problem but one of the provider's CDN:- 1.jpg 2.jpg 4.jpg
     
    Last edited: Jan 14, 2021
  13. Prospere

    Prospere RedFox Development Team

    Indeed. Especially the browser's error message.

    Well, I've been planning dynamic CDN selection for a long time. Seems the time has come to actually get to it (I trust this may solve the problem).
     
    Aeneas72 likes this.
  14. zero269

    zero269 Well-Known Member

    Thanks for the clarification. I recall that the Edge browser did throw up a warning when I tried your recommendation, and your further comparison seems to have been helpful for what Propsere is recommending for a possible solution for future SSL handshake errors.

    This will please many AS users for sure... :)

    Now, only if they can get that QUEUE feature implemented soon, that I believe will be a huge hit; especially for those who really like TV series. They can be a real hassle and very time consuming which is why I avoid them even though I have a "wishlist" for when the time comes.