Could Not Generate Hash

Discussion in 'CloneBD' started by SkyLiner, Nov 2, 2017.

  1. SkyLiner

    SkyLiner Well-Known Member

    Every now and then when using CloneBD to compress an original BD ISO (that I created myself using CloneBD) to MKV or MP4, I get this error message and it won't load the ISO https://www.screencast.com/t/vWdImwhKN

    The ISO itself plays fine (on my HiMedia Q10Pro media player)...and shows no signs of having errors. Does anyone know the cause of this error?

    The other day after getting this error message I decided to re-rip the original BD, this time using my 2nd BD player (I have 2 in my computer to alternate them). The rip went fine and completed successfully (just as the first one did), but this time I didn't get the "Could not generate hash" error message and CloneBD was able to compress the file down to a small MKV.

    I'm still waiting for an answer from Elby on this, their first response asked me for a screenshot of the error message, which I thought was odd...that they wouldn't be aware of that error message.

    I have tried to use HandBrake to compress the ISOs I have that CloneBD won't load (because of the "hash" error message), but Handbrake seems to only get about 20 minutes into the title/movie and then stops...so I wonder if there is possibly an error with the ISOs...even though they don't report any errors and they play fine on media players.

    Furthermore, I will sometimes get this error message AFTER successfully completing a compression (to MKV) from an original BD ISO: https://www.screencast.com/t/pyZ1KymmmI3T and most of the time, when I get this error message, the newly created compressed file won't play till the end, but will stop playing somewhere along the way.

    So, the main reason for my confusion is that the ISOs that give me these errors actually seem to play fine through the media player, but when trying to compress them down to a small file, I sometimes get the "hash" error and the "scrambled" error and can't compress them. Handbrake doesn't seem to be able to work with these ISOs in question either.

    Any suggestions would be much appreciated.

    Thank you
     
  2. Pete

    Pete Forum Admin Staff Member

    Well, the only reason I can think of for CloneBD giving that message, are read errors (CloneBD scans around the middle of the largest clip for that, so if there are read errors there, you'd get that message).
    And I'm not surprised, their support is not aware of that message, I haven't ever heard of it myself, seems you're the exclusive addressee ;) ).
     
  3. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Nope, i've seen currently seen that message ONCE, nothing a disc cleaning didn't fix.
     
  4. SkyLiner

    SkyLiner Well-Known Member

    When I Google that error message (clonebd could not generate hash) there are others who have posted the same error, so it is a thing. The ISOs that give this error message play with no problems and report no errors when they are created...so the only way to know if you'll run into this error message down the road when-and-if you ever want to down-size to an MKV/MP4 is to load the ISO into CloneBD right after creating the ISO to see if you get that message. I don't see how cleaning the blu-ray disc would help fix this error, because wouldn't the ISO just not complete successfully if the disc has errors or is dirty?

    And...even if CloneBD does NOT give that error, there is still a chance you'll get this error message at the end of the (2+ hour process...if you compress to H265) https://www.screencast.com/t/pyZ1KymmmI3T and that's a bit of a bummer
     
  5. Pete

    Pete Forum Admin Staff Member

    I get 4 hits, 3 of them lead to the same post ("lost in space"), the other to yours, I wouldn't call that a "thing", rather something exceptionally rare ;)

    Can you please post your images inline here, not on an external hoster? It's much easier if the image is shown right away with the post.

    The "data corrupt" message says, that there are broken sectors. CloneBD does not lie about that, we've put a lot of investigation into this some time ago.
    It is a so far unresolved phenomenon, that AnyDVD sometimes, instead of reporting read errors, delivers either "mush" or all zeroes in place of sectors, that couldn't be read.
    Not CloneBD's fault, neither is "can't generate hash", which is for the same reason, CloneBD can't regenerate what's gone - it tries to skip it best it can but will warn about possible problems with the result.
    That is what happened in your example.
     
  6. SkyLiner

    SkyLiner Well-Known Member

    Thank you for the answer. One thing I forgot to mention is that the "hash" error is something that clone BD reports immediately once I click on the ISO file that I want to use. It takes less than one second for that "hash" error to pop up. Just in case that means anything, cloneBD does not spend a long time trying to read the iso, it is an instant error message as soon as I double click on the iso that I am trying to load into cloneBD.

    Kind regards

    Sent from my SM-N910T using Tapatalk
     
  7. SkyLiner

    SkyLiner Well-Known Member

    In other words, unlike the "Scrambled" error message which cloneBD reports at the end of the whole process of trying to compress a file, the "hash" error message doesn't take any time at all to detect.

    Sent from my SM-N910T using Tapatalk
     
  8. Pete

    Pete Forum Admin Staff Member

    Of course. Those bad sectors happen to be right within the portions, CloneBD uses to identify the disc.
    There's no reason why that would take longer than a split second. Read -> crap -> good bye.