Colin Mcray Rally 04 not running

Discussion in 'GameJackal' started by Daveheath, Mar 18, 2008.

  1. Daveheath

    Daveheath Member

    1. What version of Game Jackal are you running?
    v3.0.0.8 unregistered and 16 days left
    2. What is the title of the game you're trying to run?
    Colin Mcray Rally 04
    3. What is the version of the game?
    v1.1.0.0 (I think, but it is on the SoldOut label which I reckon is the problem)
    4. Is it cd or dvd version?
    DVD edit:eek:pps
    5. What region or country is the original disc from?
    UK
    6. What protection does your game use?
    SecuROM Detected - Version 5.03.04 acording to PiD
    7. What Operating system are you using? 64 bit? service pack?
    XP Pro with all updates (as of today, 18th March 08)
    8. What cpu are you using?
    AMD Athlon 64 4000+
    9. Provide the full error messages you received when attempting to run the game.
    No error message given, the problem I get is that when running the game (after activating the profile) the app runs (and is visible in taskman) but doesn't actually load the game.
    10. What brand and model optical disc drive did you use to read the disc? What firmware version did you use?
    LG GSA-4163B with A105 firmware

    I have even tried turning off my Virtual Sheep to see if this was the problem but it didn't help.

    I am going to go and see if I can get some other games to work, but if anyone has seen a problem like this before, please help!

    Dave
     
    Last edited: Mar 26, 2008
  2. Daveheath

    Daveheath Member

    Quick note, Command & Conquer: Tiberian Sun (also on the SoldOut label) and Medal of Honor:Allied Assault Warchest both work fine first time.

    Can anyone help?
     
  3. evlncrn8

    evlncrn8 Well-Known Member

    do the Command & Conquer: Tiberian Sun and Medal of Honor:Allied Assault Warchest have protection (never heard of the SoldOut label.. guessing it might be budget..) ?
     
  4. Daveheath

    Daveheath Member

    Here is a link to SoldOut Software. They seem to be a part of mastertronic
    link

    C&C:TS seems to have "Safedisc 1.11.000" on the disc but the install directory doesn't seem to have anything other than check disc.

    MoHAA crashes PiD when I try but it seems to only have cd check/serial key.

    I am gonna try FEAR which apparently has "SecuROM Detected - Version 07.24.0009" and Quake 4 which has "Safedisc 4.60.000 detected !"

    Will report back in a bit

    Edit (rather than post again): Quake 4 works fine, but if I remember correctly it doesn't always ask for the DVD anyway.
     
    Last edited: Mar 19, 2008
  5. Daveheath

    Daveheath Member

    I have just updated to to new version of GJ (v3.0.1.0)

    • Command & Conquer:TS works, it asks for the disc but then plays fine anyway if you click "OK"
    • FEAR still asks for the disc (I have v1.08)
    • Colin still runs the cmr4.exe but the game doesn't actually load
    Everything else works fine still. Any help? Only 8 days left of the trial...

    Code:
    ===============================================
    Filter Driver Load Order - ImgBurn v2.4.0.0
    ===============================================
    
    Upper Device Filter:  redbook
     Upper Class Filter:  maplom
     Upper Class Filter:  GEARAspiWDM
                 Device:  CD/DVD-ROM Device
     Lower Class Filter:  maploml
     Lower Class Filter:  ElbyDelay
     Lower Class Filter:  PxHelp20
     Lower Class Filter:  ElbyCDFL
     Lower Class Filter:  ASAPIW2k
    Lower Device Filter:  imapi
    
            Filter Name:  redbook
              File Name:  C:\WINDOWS\system32\DRIVERS\redbook.sys
           File Version:  5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)
       File Description:  Redbook Audio Filter Driver
           Product Name:  Microsoft® Windows® Operating System
        Product Version:  5.1.2600.2180
           Company Name:  Microsoft Corporation
              Copyright:  © Microsoft Corporation. All rights reserved.
    
            Filter Name:  maplom
              File Name:  C:\WINDOWS\system32\Drivers\maplom.sys
           File Version:  3, 0, 1, 0 [3.0.1.0]
       File Description:  Maplom.sys
           Product Name:  Game Jackal
        Product Version:  3, 0, 1, 0 [3.0.1.0]
           Company Name:  SlySoft Inc.
              Copyright:  Copyright © 2007, 2008 SlySoft Inc.
    
            Filter Name:  GEARAspiWDM
              File Name:  C:\WINDOWS\System32\Drivers\GEARAspiWDM.sys
           File Version:  2.0.6.1
       File Description:  CD/DVD Class Filter Driver
           Product Name:  GEAR.wrks
        Product Version:  8.xx [2.0.6.1]
           Company Name:  GEAR Software Inc.
              Copyright:  Copyright (c) GEAR Software Inc. 2006
    
            Filter Name:  maploml
              File Name:  C:\WINDOWS\system32\Drivers\maploml.sys
           File Version:  3, 0, 1, 0 [3.0.1.0]
       File Description:  Maplom.sys
           Product Name:  Game Jackal
        Product Version:  3, 0, 1, 0 [3.0.1.0]
           Company Name:  SlySoft Inc.
              Copyright:  Copyright © 2007, 2008 SlySoft Inc.
    
            Filter Name:  ElbyDelay
              File Name:  C:\WINDOWS\System32\Drivers\ElbyDelay.sys
           File Version:  5, 1, 0, 1 [5.1.0.1]
       File Description:  Elby Delay Lower Filter Driver
           Product Name:  CDRTools
        Product Version:  5, 1, 0, 1 [5.1.0.1]
           Company Name:  Elaborate Bytes AG
              Copyright:  Copyright (C) 2003 - 2006 Elaborate Bytes AG
    
            Filter Name:  PxHelp20
              File Name:  C:\WINDOWS\System32\Drivers\PxHelp20.sys
           File Version:  3.00.56a [3.0.56.0]
       File Description:  Px Engine Device Driver for Windows 2000/XP
           Product Name:  PxHelp20
        Product Version:  [2.0.0.0]
           Company Name:  Sonic Solutions
              Copyright:  Copyright © Sonic Solutions
    
            Filter Name:  ElbyCDFL
              File Name:  C:\WINDOWS\System32\Drivers\ElbyCDFL.sys
           File Version:  5, 2, 1, 3 [5.2.1.3]
       File Description:  ElbyCDIO Filter Driver
           Product Name:  CloneCD
        Product Version:  5, 2, 1, 3 [5.2.1.3]
           Company Name:  SlySoft, Inc.
              Copyright:  Copyright (C) 2003 - 2006 SlySoft, Inc.
    
            Filter Name:  ASAPIW2k
              File Name:  C:\WINDOWS\system32\drivers\ASAPIW2k.sys
           File Version:  6, 0, 2, 27 [6.0.2.27]
       File Description:  ASAPI
           Product Name:  asapi
        Product Version:  6, 0, 2, 0 [6.0.2.0]
           Company Name:  Pinnacle Systems GmbH
              Copyright:  (c) 1997-2003 by Pinnacle Systems GmbH
    
            Filter Name:  imapi
              File Name:  C:\WINDOWS\system32\DRIVERS\imapi.sys
           File Version:  5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)
       File Description:  IMAPI Kernel Driver
           Product Name:  Microsoft® Windows® Operating System
        Product Version:  5.1.2600.2180
           Company Name:  Microsoft Corporation
              Copyright:  © Microsoft Corporation. All rights reserved.
    
    
     
    Last edited: Mar 26, 2008
  6. Webslinger

    Webslinger Retired Moderator


    Asapiw2k.sys - Used by Pinnacle Studio 9 by Pinnacle systems or VOB Computersysteme GMBH

    1. i) Create a backup of your registry
    ii) Download imgburn. It's a free program: http://www.imgburn.com/index.php?act=download
    (it's also an excellent program imo)
    iii) Go to Tools > Filter Driver Load Order. Select "ASAPIW2k". Click "Remove Selected Filter". Click "ok".
    iv) Reboot

    Whatever program installed that filter will no longer work properly.

    2. a) Navigate to your Game Jackal folder (typically C:\Program Files\SlySoft\Game Jackal where "c:" is your hard drive if you use Windows XP)
    b) You will see a log file called "Summary.log"
    c) When replying or posting in the Slysoft forums, look for the icon that looks like [​IMG] (in other words, look for the paperclip after clicking "quote" or when creating a new thread)
    d) If you don't see that paperclip icon, click the "go advanced" button. You should see that icon now. Click the paperclip.
    e) A small pop-up screen should appear (if it doesn't please ensure your browser is enabled to allow pop-ups from the Slysoft forums)
    f) Click the "Browse" button, and locate and select the summary.log file
    g) click "upload"
    h) Close the window. When you submit reply, or submit a new thread, the .log file will be attached automatically for us to take a look at
     
  7. Daveheath

    Daveheath Member

    Here is a copy of my summary.log (i can't attach .log files so i have changed it to a txt file)

    This is after running the profile for colin mcrae (its called kkk cause I was lazy)



    Edit: Removing Asapiw2k.sys and rebooting didn't work, so I created another profile, this also didn't work and attached it the summary log
     

    Attached Files:

  8. Webslinger

    Webslinger Retired Moderator

    I forgot about about that. Sorry.

    Thanks. Hopefully matthew will take a look and get back to you.
     
  9. matthew

    matthew SlySoft Team Member

    When creating then profile, on Step 4 select "Advanced options" and then set "Game Management" to "Disabled".

    Give that a go.
     
  10. Daveheath

    Daveheath Member

    Hi Matthew,

    Thank you for your reply. I have tried re-creating a profile for Colin with "Game Management" set to "Disabled" but it doesn't make any difference. I still get the cmr4.exe loaded (if you look in taskmanager) and using 98% of processor, but nothing happens :(

    I have attached a new copy of summary.log for you if that helps.

    Dave
     

    Attached Files:

  11. matthew

    matthew SlySoft Team Member

    This happens when creating the profile?

    If so. Try unchecking "Auto start this game" and then manually start the game.
     
    Last edited: Mar 29, 2008
  12. Daveheath

    Daveheath Member

    Hmm, replying once I am back from the pub... do I have an internet addiction? maybe.... ;)

    Nah, It makes the profile fine (I think I have tried most configurations of image mode/auto start/auto run etc.)

    It happens once you activate the profile after creating it.
    I double click on my profile (Feature request: It would be really awesome if you could just hit enter on a selected profile to activate it...not a biggie though)
    And it does what it does with every other game I have profiled. It runs the appropriate exe file (cmr4.exe in this case)
    The problem is that the game doesn't seem to actually load. If you look in task manager it shows the cmr4.exe process running, but at about 98% usage and the game is definitely not running.
    I have tried leaving it for an hour to see if it just is being VERY slow but no joy.
    When I play the game with the CD in, it works like a charm straight away with little strain on the CPU.

    It is very strange.
    Are there any other files I can send/attach to here that might help you guys?

    Many thanks
    Dave
     
  13. Webslinger

    Webslinger Retired Moderator


    Wow, I have no idea what would cause that, unfortunately. Maybe matthew will have some more suggestions.

    Out of curiosity, what kind of antivirus and firewall programs are you using? Maybe your security software is blocking something/causing a conflict?

    I don't work for Slysoft and obviously I'm not the Game Jackal developer, so I'm just grasping at straws. I wish I could think of something else that might be causing that to happen.:(
     
  14. matthew

    matthew SlySoft Team Member

    Are you able to kill the game process (via task manager), or do you need to reboot?

    It does sound odd. Could you try the following.
    1) Edit the profile and note down the "Game Jackal Profile" value. Now head to the profile lib directory (i.e. C:\Program Files\SlySoft\Game Jackal\Profile Library) and delete profilename.srd (where profilename is the value noted). Then test the profile again. Let me know the results.
     
  15. Daveheath

    Daveheath Member

    Your efforts are still appreciated Webslinger! I am currently using F-Secure Internet Security Technology Preview 8.20 build 122
    I thought maybe because it is a beta version it might be the problem, but disabling it hasn't seemed to have changed it.

    I can just kill the process, it takes a second for task manager to load but that is understandable on a maxed out processor.

    Sadly no different. It just creates a new file of 0 bytes in size.
    Annoyingly I have been away from home on work for a few days and I think I left it rather late to bring this issue to the forums. (Curse my stubborn "I can make this work myself" attitude towards computers) and so, as I type my copy of Game Jackal says I only have 1 day left.
    So I thank you for all the help provided by Matthew and Webslinger, its nice to be supported by devs/users that care.

    I will add the games I have gotten working to the "list of working games" thread.