CloneDVD mobile Devices.ini (user-edited)

Discussion in 'CloneDVD mobile' started by lostinlodos, Dec 28, 2007.

  1. JimSa

    JimSa Well-Known Member

    Combined PSP and iPhone Profile

    I got really tired of encoding twice for my iPhone and PSP. I spent the weekend trying different settings and came up with the following profile that plays well on both. YMMV. (Note I have an audio delay set)

    [PSP (Works for iPhone)(bframe=0 nocabac)]
    PixelLimit=130560
    ScreenRatio=16:9
    Manufacturer=Sony Playstation Portable (PSP)
    Res1=364x272
    ResAna1=480x272
    ARate=48000
    ABRate=96
    Format=avi
    moac=faac
    movc=x264
    mopts=-delay 0.2 -faacopts br=%abrate%:mpeg=4:eek:bject=2 -x264encopts bitrate=%vbrate%:level_idc=21:bframes=0:threads=0:frameref=2:nocabac:nopsnr:nossim%PASS%
    FileType=mp4
    Quality=15
    useMencoder=1
    SubTitle=1
    MaxVBitrate=750
    ThumbNail=JPG
    AllowChapterFiles=0
    MVolume=20
    Remux=2642MP4
    QualityFactor=130
     
  2. profcolli

    profcolli Well-Known Member

    Please put your profile suggestions in code tags otherwise smilies and spaces may creep in ;)
    Code:
    [PSP (Works for iPhone)(bframe=0 nocabac)]
    PixelLimit=130560
    ScreenRatio=16:9
    Manufacturer=Sony Playstation Portable (PSP)
    Res1=364x272
    ResAna1=480x272
    ARate=48000
    ABRate=96
    Format=avi
    moac=faac
    movc=x264
    mopts=-delay 0.2 -faacopts br=%abrate%:mpeg=4:object=2 -x264encopts bitrate=%vbrate%:level_idc=21:bframes=0:threads=0:frameref=2:nocabac:nopsnr:nossim%PASS%
    FileType=mp4
    Quality=15
    useMencoder=1
    SubTitle=1
    MaxVBitrate=750
    ThumbNail=JPG
    AllowChapterFiles=0
    MVolume=20
    Remux=2642MP4
    QualityFactor=130
     
  3. slinky

    slinky Well-Known Member

    did you find that you needed the delay for the latest CloneDVDmobile beta sync issues, or was this just a requirement that you found was needed for this conversion extension with all versions ?
     
  4. JimSa

    JimSa Well-Known Member

    I haven't been able to get the beta to work. I get the infamous "Oh No..." with just about every PSP encoding. I haven't taken the time to send in the log yet.

    I ran two tests with version 1.2.0.1:

    My first test was DVD Hunt for Red October. I must have encoded it about 30 times... While -delay 0.2 wasn't perfectly dialed in, it was very close and I was starting to see things after a while. For instance, it seemed like -delay 0.0 gave a different result than removing -delay switch in the command line entirely. Anyway, I'd guess that perfect was something like .18 or .22 for this DVD. The DVD structure indicated that there was -66 ms delay in the streams. Still, -delay of 0.2 matched up better than than -delay .066. No idea why.

    I then took a BD version Hulk, converted to DVD with zero delay offset in the resulting streams. The result DVD was perfectly sync'd with 0ms stream offsetting. However, with this DVD structure CloneDVD Mobile still performed best with a -delay 0.2. I would have expected that .2 would have lead to lip sync issues but actually -delay 0.0 led to some minor lip sync issues. Strange...

    It doesn't really makes sense to me, but both roads came back to having -delay 0.2 as the right middle ground that was very very close to ideal. I think I'll stick with it until I see a problem.
     
  5. slinky

    slinky Well-Known Member

    ok, thanks for the explanation :)
     
  6. sej7278

    sej7278 Well-Known Member

    the only problem with these is that when slysoft switches from mencoder they will cease to work.

    i doubt they even work with 1.2.0.1 beta that uses ffmpeg, let alone clone-bd's chameleon engine.
     
  7. Maestro

    Maestro Member

    Is there a cipher to the code?

    Is there a breakdown anywhere here on the forum that explains what each one of the possible options, e.g., Res, ResAna, etc. in the Devices.ini file means? I have a new Blackberry Storm and if I knew what some of these codes were for exactly I might be able to adapt one of the other devices to produce a decent Storm video.

    Thanks!
     
  8. Sanherib

    Sanherib New Member

    Nokia N85?

    What is the best setting for the Nokia N85 with 640x480 and 320x240 Pixel?

    Sanherib
     
  9. scubasam

    scubasam Member

    generic divx extension error

    HI guys I tried the DIVX extension on the forum and got this erro when I tried to use it. I am using beta 1.5.0.4 and the generic divx extension for 5.1 surround and recieve this error.

    File 2 "C:\Program Files\SlySoft\CloneDVDmobile\apps\mencoder.exe" - -ffourcc DIVX -af volume=10 -of avi -noodml -oac copy -ovc lavc -lavcopts vcodec=mpeg4:threads=2:vbitrate=1366:abitrate=64:threads=2:vpass=1 -audio-preload 0.8 -delay 0.1 -lameopts cbr=64 -forcedsubsonly -vf scale=720:540,harddup -aspect 1.333333 -info name="FARSCAPE_S2_V4DA" -ofps 24000/1001 -o "J:\EP 36 Beware of dog.avi" -passlogfile "J:/mencmpass2660.log" 109 TCE

    Encoder output:

    ERROR: Invalid parameter 'cbr=64' for -lameopts..


    can any help me with what I need to do to fix this I would love to be able to rip my shows in 5.1 divx!

    Scuba sam
     
  10. profcolli

    profcolli Well-Known Member

    Have you tried using the following XviD profile?

    Code:
    [* Generic (XviD) DTS/DD+ Copy]
    Res1=320x240
    Res2=480x360
    Res3=640x480
    Res4=720x540
    ResAna1=320x180
    ResAna2=480x270
    ResAna3=640x360
    ResAna4=720x404
    ResAna5=852x480
    AllowNativeTVResolution=1
    Format=avi
    moac=copy
    movc=xvid
    mopts=-lameopts br=%abrate% -xvidencopts bitrate=%vbrate%%PASS%
    FileType=avi
    VTag=XVID
    Format=lavf
    lavfopts=format=avi
    FileType=avi
    Quality=23
    useMencoder=1
    SubTitle=1
    MaxVBitrate=3000
    Try cut-and-pasting from the above - it works fine for me on version 1.2.0.1 - try going back to that version if you still have an error.
     
  11. scubasam

    scubasam Member

    another error so frustrating

    HI guys I deleted the alternate divx that I tried and replaced it with the above one and recieved the below error :(

    I'm not sure what I am doing wrong but hopfully I can get some help below was the error.


    File 2 "C:\Program Files\SlySoft\CloneDVDmobile\apps\mencoder.exe" - -ffourcc XVID -af volume=10 -of avi -oac copy -ovc xvid -lameopts br=64 -xvidencopts bitrate=1518:pass=1 -vf pp=fd,scale=720:480,harddup -aspect 1.333333 -info name="FARSCAPE_S2_V5DA" -ofps 30000/1001 -o "J:\EP 40 A clockwork nebari.avi" -passlogfile "J:/mencmpass5592.log" 109 TCE

    Encoder output:

    ERROR: Unknown video codec 'xvid'. Only supporting 'lavc' (libavcodec), 'x264', 'mpeg1video' (MPEG-1), 'copy' (lossless transfer)..
     
  12. profcolli

    profcolli Well-Known Member

    Presumably you don't have the XviD codec installed on your system. You can download the codec pack from here:
    http://www.xvidmovies.com/codec/
    Then try again.
     
  13. scubasam

    scubasam Member

    still no juice

    This is frustrating no go didnt work and now clone dvd mobile only copies to 16% before it stalls! booooooooooooo
     
  14. profcolli

    profcolli Well-Known Member

    Can you get it to work with a standard profile? If not you may have a problem disk - some season disks especially have been known to cause problems.
     
  15. phibertron

    phibertron New Member

    PSP/iTouch config working for me without the delay

    Thank you JimSa for PSP/iPOD config, it works great, on my PSP v5.0.3 and my iTouch v2.2.1
    I have not run into the audio issue you did, but oly time will tell =)
     
  16. phibertron

    phibertron New Member

    Here is some more info on PSP/iPod compatable config's

    JimSa posted a config that enables a 480x272 AVC encode to work with both the PSP and the iTouch

    Which was something I had been hunting for, but there were a few things more that I wanted to play with, namely PSP 640x480 and PSP 720x480
    (not sure which PSP version introduces it, but it does play 640x480, ill post the configs after submit this post)

    So here are the major differences that I have found that make anything beyond 480x272 not possible when trying to encode a single file for both the PSP and iPhone or iTouch

    1. To enocode for a PSP at 640x480 or 720x480 a level_idc 3 must be used
    2. If encodeing for a PSP and level_idc is 3 then cabac must also be enabled
    3. you can NOT have level_idc 3 and nocabac
    4. The iphone/itouch does NOT support cabac
    5. So were basically stuck at 480x272, idc 21, nocabac if you want to encode for both the PSP and iPhone
     
  17. phibertron

    phibertron New Member

    PSP 640x480, 720x480 solution

    In my previous post i mentioned that i would post my configs for a PSP at 640x480 and 720x480
    I'm using CDM 1.2.0.1

    So after doing an insane amount of digging around.
    I kept reading the to get 720x480 to work with the PSP one had to use "global_header"
    And then the kicker was that if you did, at the end of the encode the file would just disappear.
    Well i found out why, or should i say i read why =)
    The version of MP4box being used is "MP4Box - GPAC version 0.4.1-DEV"
    So it appeared to me that I just needed to go get a newer version of it and check to see if the issue was fixed or not.

    If found ver 4.4 here
    Code:
    http://www.afterdawn.com/software/download_splash.cfm/mp4box
    
    i downloaded and replaced the one from slysoft in the folder with the one i download above
    Code:
    C:\Program Files\SlySoft\CloneDVDmobile\apps
    
    Well the first thing i did was to try the PSP 720x480 config
    Code:
    PSP 720x480 (AVC/H264, FW > 3.30)
    
    And what do you know it actually worked OMG!

    NOTE: the "global_header" still does NOT work, but is NOT needed, that I can tell, to get 720x480 or 640x480 to work

    Here are the configs I used in conjunction with MP4box version 4.4

    Code:
    [PSP 640x480 (AVC/H264, FW > 3.30)]
    PixelLimit=345600
    ScreenRatio=16:9
    Res1=640x480
    ResAna1=640x480
    ARate=48000
    ABRate=96
    Format=avi
    moac=faac
    movc=x264
    mopts=-faacopts br=%abrate%:mpeg=4:object=2 -x264encopts bitrate=%vbrate%:level_idc=30:bframes=3:threads=0:frameref=3:nopsnr:nossim%PASS%
    FileType=mp4
    Quality=15
    useMencoder=1
    SubTitle=1
    MaxVBitrate=768
    ThumbNail=JPG
    AllowChapterFiles=0
    MVolume=10
    Remux=2642MP4
    QualityFactor=130
    
    Code:
    [PSP 720x480 (AVC/H264, FW > 3.30)]
    PixelLimit=345600
    ScreenRatio=16:9
    Res1=720x480
    ResAna1=720x480
    ARate=48000
    ABRate=96
    Format=avi
    moac=faac
    movc=x264
    mopts=-faacopts br=%abrate%:mpeg=4:object=2 -x264encopts bitrate=%vbrate%:level_idc=30:bframes=3:threads=0:frameref=3:nopsnr:nossim%PASS%
    FileType=mp4
    Quality=15
    useMencoder=1
    SubTitle=1
    MaxVBitrate=768
    ThumbNail=JPG
    AllowChapterFiles=0
    MVolume=10
    Remux=2642MP4
    QualityFactor=130
    
    After two days of going nutz trying to get anything above 480x272 to work with both the PSP and iPhone or iTouch
    I have found that at this point in time it is not possible
    As from some of the reading on the PSP, it is the use of CABAC as some whack codeing that they are able to get it working, which is what it is

    I hope this info helps any of you trying to get 640x480 or 720x480 working on your PSP
     
    Last edited: Mar 16, 2009
  18. Bobbe

    Bobbe New Member

  19. Claws61821

    Claws61821 Member

    [Blackberry 8830]

    This Profile should result in a product optimally configured for playback on RiM's Blackberry 8830 WE and Blackberry Curve 8330 smartphones

    Code:
    [8830]
    Manufacturer=Blackberry
    useMencoder=1
    ScreenRatio=4:3
    Res1=320x240
    ResAna1=320x180
    Format=lavf
    lavfopts=format=mp4
    FileType=mp4
    lavcopts=vcodec=mpeg4:acodec=libfaac
    MaxVBitrate=768
    MVolume=10
    Framerate=24
    NTSCFrameRate1=24
    NTSCFrameRateDeinterlace1=24
    
    Note: Lower quality settings will incur a slight audio delay
     
    Last edited: Jun 17, 2009
  20. slinky

    slinky Well-Known Member

    is this still relevant ? .... as i dont have that app in the apps folder, could it be that SlySoft has updated and no longer uses MP4box ???