CloneBD and AMD 22.3.1

Discussion in 'CloneBD' started by DQ, Mar 17, 2022.

  1. DQ

    DQ Well-Known Member

    Just posting this as a heads up but it APPEARS that CloneBD will not work at all with an AMD GPU and 22.3.1 drivers. Previously it worked fine but since I upgraded it fails immediately.

    I already had decode acceleration turned off so this is just on the encode side that now it is failing.

    I will test a bit more and post again. Maybe I am doing something silly, I will re-verify my process.

    EDIT1- yes it is failing and I am doing just what I normally do.

    This is Win11 if it makes a difference.

    [00:10:03.229] - [ERROR ] [0x00000000006bff40] {AMD UVD/VCE-encoder}Encoder->SubmitInput() failed, 19

    [00:10:03.229] - [ERROR ] [0x00000000006bff40] transcoder stop error: 0x80004005

    [00:10:03.229] - [ERROR ] [0x00000000006bff40] last reported error: '{AMD UVD/VCE-encoder}Encoder->SubmitInput() failed, 19' (6)

    [00:10:03.229] - Error in processStreams
     
    Last edited: Mar 17, 2022
    George++ and DeepSpace like this.
  2. George++

    George++ Well-Known Member

    I have nVidia cards, so this doesn't effect me directly.

    Thanks for a heads-up, DQ, for the people who might be.
     
    DQ likes this.
  3. coopervid

    coopervid Moderator

    Thanks for the report. Did you roll-back the driver? Does it work again?

    The guys at Elby always complained in the past that AMD keeps changing the programming API in their drivers. Maybe this driver changed the API again.
     
  4. DQ

    DQ Well-Known Member

    I did not try a rollback unfortunately. I did not want to hose my system potentially. But this version I know DOES contain some big changes.
     
  5. coopervid

    coopervid Moderator

    Just create a restore point. Then do a clean install (not a quick install) of the older driver version. If it fails restore back to that created restore point.
     
  6. DQ

    DQ Well-Known Member

    I rather rebuild my whole system than rely on a restore point to be quite honest. That's not sarcasm, I can rebuild and restore data quickly and I hate that restore point system.

    However, that said, I am willing to change drivers and change back. It's worth doing. Give me a little bit and I will report back.
     
  7. DQ

    DQ Well-Known Member

    So I can confirm that when I rollback the driver just 1 version (22.2.3) CloneBD works. When I am running 22.3.1 I get the errors I posted.
     
    whatever_gong82 and RedFox 1 like this.
  8. RedFox 1

    RedFox 1 Super Moderator

    I never owned an AMD GPU, I own an AMD CPU, but I always buy Nvidia GPUs so I get the NVENC.dll which a better encoder than AMD puts out. I think this is the reason CloneBD always worked for me. Although I am really not sure anymore what works and what doesn't, I have not used the program for a few years.
     
  9. DQ

    DQ Well-Known Member

    I have been using it, well until this. I guess it's back to Handbrake for regular Blu-Rays.
     
    whatever_gong82 and RedFox 1 like this.
  10. RedFox 1

    RedFox 1 Super Moderator

    I have about 100 Bluray discs in my library, ones that I actually bought, not all new but I bought some new and others from thrift shops, they had them for 1USD a piece, and they were relatively good titles. Just not new.
     
    DQ likes this.
  11. DQ

    DQ Well-Known Member

    $1 ! That's a nice find. I buy them from Amazon from time to time when I can find a good title for less than $10. Sometimes I will get sets for under $30. Although I will do the same with DVD sets as well for older shows I like.
     
  12. RedFox 1

    RedFox 1 Super Moderator

    I got the whole Game of Thrones set at a wholesale ": Going out of business sale " for 25 dollars, I actually got it for my son, when I gave it to him, he was not interested, I sold it on eBay for 50. I think it still sells for more than that. not sure though.
     
    DQ likes this.