CloneBD 1.2.9.0 AMD support

Discussion in 'CloneBD' started by coopervid, May 8, 2020.

  1. coopervid

    coopervid Well-Known Member

    Congrats to the ElaborateBytes team!

    A real impressive list of fixes and improvements! However, it doesn't concern me personally but I didn't find anything regarding AMD GPU hardware support. Maybe somebody like @Reto can make some comments on the progress (or the issues to make progress) with AMD GPU support. The community with those GPUs will for sure appreciate this.
     
  2. TheEmpathicEar

    TheEmpathicEar Well-Known Member

    Yeh, see my post today. Still waiting, hoping...
     
  3. manik

    manik Well-Known Member

  4. Fabian

    Fabian Developer

    We are currently working with AMD on several issues in their media framework driver. The latest release has full AMD HEVC/AVC HW support.
     
    TheEmpathicEar likes this.
  5. manik

    manik Well-Known Member

    Thanks for the Feedback

    can you say how long it will take? 1 week? 1 month? 1 year?
     
  6. TheEmpathicEar

    TheEmpathicEar Well-Known Member

    What about HEVC -> HEVC support?
     
  7. tectpro

    tectpro Translator (ms_MY)

    @Fabian
    I am using a Radeon RX570 with Adrenalin 2020 Edition 20.4.2 and HEVC is all on software
     
  8. TheEmpathicEar

    TheEmpathicEar Well-Known Member

    I am not sure what you mean? I thought the idea was hardware support to do HEVC - > HEVC?
     
  9. tectpro

    tectpro Translator (ms_MY)

    I meant it shows that the RX570 can not use hardware for HEVC in latest CloneBD. Only software possible for decode and Encode in HEVC.
     
  10. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    that's because as fabian says they're still working with AMD to fix that and add hw support
     
    TheEmpathicEar likes this.
  11. tectpro

    tectpro Translator (ms_MY)

    Well he also mentioned:
    https://forum.redfox.bz/threads/amd-radeon-vii.76644/page-2
     
  12. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Disabled = greyed out, unavailable to select. As in the current status of hw acceleration). Thus it switched to software encoding.

    Software encoding =/= unavailable

    Sent from my Pixel 3 XL using Tapatalk
     
    TheEmpathicEar likes this.
  13. manik

    manik Well-Known Member

    unfortunately not even AVC works
     

    Attached Files:

  14. DarkQuark

    DarkQuark Well-Known Member

    I get something similar where when using AMD hardware, I top out at 5 FPS. I check each release hoping this is fixed because I love CloneBD but I am forced to use Handbrake which does work with AMD hardware. I know there is a ticket with AMD open and that their are statements that the AMD driver is a pain but if handbrake can get it right I don't understand why CloneDB (a superior piece of software) cannot. I have supported Redfox from the beginning and will continue too I just find this somewhat disappointing.
     
  15. manik

    manik Well-Known Member

    This also works, so the graphics card is OK.?

    upload_2020-5-15_17-16-54.png
     
  16. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Nobody said the graphics card was defective. The problem is with the AMD drivers, which BD-rebuilder doesn't use. It's a GUI for command-line tools, the tools themselves then offload the work directly to the video cores on the card without driver interaction.
     
  17. manik

    manik Well-Known Member

    what's the Status?
     
  18. Ch3vr0n

    Ch3vr0n Translator NL & Mod

  19. manik

    manik Well-Known Member

    Is there any new information on this topic?
     
  20. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    No, because there hasn't been an update to CLBD.

    Sent from my Pixel 3 XL using Tapatalk