Clone BD schließt sich

Discussion in 'CloneBD (de)' started by DaveO88, Jan 25, 2019.

  1. DaveO88

    DaveO88 Moderator DE

    @Pete or @Reto

    UHD BD :
    ich habe nun öfters das Problem das sich CBD einfach schliesst oder sogar den PC einfach herunter fährt ohne das solche Einstellungen getroffen sind , nach solchen Abbrüchen kann es sein das der der nächste Anschub des gleichen Films dann ohne Abbruch oder Fehler bis zum Ende geht. Jedoch geschieht es in letzter Zeit des öfteren das die Bearbeitung nicht mehr auf anhieb klappt, was sehr ärgerlich ist da ja auch so ein Duchgang bis zu einer dreiviertel Std. dauert (abhängig natürlich von der Größe der Disc)
    Die UHDs werden natürlich zuvor als ISO mit Any gespeichert


    UHD BD:I now often have the problem that CBD simply closes or even simply shuts down the PC without such settings are made, after such crashes it may be that the next start of the same movie then without abort or error goes to the end.However, it often happens lately that the processing is not working right away which is very annoying because so synonymous the passage takes up to three quarters of an hour (depending of course on the size of the disc)Of course, the UHDs are previously saved as ISO with Any
     

    Attached Files:

  2. kufo

    kufo Well-Known Member

    Das Problem hatte ich zum Glück noch nicht, aber seit dem letzten Relesse 1.2.4.0, hakelt das Programm öfters. Das Erfassen der Quelldaten (ISO) dauert dann etwa15 Sekunden. Fast als würden 2 Prozesse gleichzeitig auf die Platte zugreifen. Teilweise geht auch mittendrin die CUDA Unterstützung für einige Sekunden weg. Die Zieldatei war bisher aber immer ohne Fehler.
    Werde das jetzt mal genauer beobachten.
     
  3. Reto

    Reto Elaborate Bytes AG

    Wenn CloneBD sich "von selbst beendet" kann das allenfalls an einem Speicherproblem liegen - wenn z.B. ein Memory-Leak vorliegt, CloneBD also irgendwelche Daten nicht mehr freigibt, bis der verfügbare Speicher überläuft.
    Bitte einfach einmal im Taskmanager den Speicherverbrauch von CloneBD im Auge behalten. Es ist normal, dass der Speicherbedarf zu Beginn (die ersten 10-20s) nach und nach anwächst, dann sollte er aber weitgehend konstant bleiben.
    Ich kann mit der aktuellen Version keine solchen Probleme feststellen.

    Dass CloneBD einfach den PC herunterfährt, ist übrigens praktisch vollkommen ausgeschlossen - das Herunterfahren von Windows ist ein sehr "willentlicher" Akt, bei dem ein Programm sich ausdrücklich Berechtigungen holen und mehrere Schritte vorsätzlich unternehmen muss. Das kann nicht "aus Versehen" oder aufgrund eines Fehlers passieren.
    Das spräche eher für ein komplett anderes Szenario mit Hardwareproblemen.

    Die angehängte Dumpdatei hingegen zeigt weder den einen noch den anderen Effekt - da ist allerdinge ein Fehler zu sehen, der sich beheben lassen müsste, ich habe es an die Entwickler weitergegeben.

    Bitte auch einmal mit einer älteren Version gegentesten. Ich mag nicht recht glauben, dass es an dem letzten Release liegt, sondern eher dass das ein Zufall ist.
    Die betreffenden Code-Elemente (wie das Einlesen der ISO) wurden nicht verändert.

    Eventuell sind es einfach bestimmte discs, bei denen das, unabhängig von der Programmversion, länger dauert (sehr viele, kleine clips, z.B.).


    Das ist völlig normal. Bei bestimmten, alten Formaten, vornehmlich interlaced video, das von den DVDs übernommen wurde, wird vorübergehend CUDA deaktiviert, da einige Konvertierungen ohne Beschleunigung passieren (z.B. 3:2 pull down u.ä.).
    Für gewöhnlich sind das aber NTSC oder PAL Sequenzen die auch sehr schnell ohne hw Beschleunigung gehen.
     
    kufo likes this.
  4. kufo

    kufo Well-Known Member

    @Reto
    Danke für den Hinweis zur CUDA Unterstützung Das die Qualität des Quellmaterials Einfluss hat war mir nicht klar.
    Ich werde deinen Vorschlag aufgreifen und mal eine ältere Version testen. Parallel dazu halte ich dann auch mal den Task Manager im Auge
     
  5. DaveO88

    DaveO88 Moderator DE

    Nun , ich sitze ja nicht immer am Pc wenn er einen Film bearbeitet ich sehe zumeist entweder das sich der Vorgang von selbst beendet oder ich an den Pc zurückkehre und er ist AUS .
    Ich kenne es eigentlich so wenn etwas nicht passt das mir CBD den Hinweis gibt das die Bearbeitung nicht erfolgreich war mit einem Log und der Aufforderung diese per Email zu senden aber wie gesagt in letzter Zeit passiert dieses nicht mehr CBD schließt sich einfach ohne Hinweisfenster oder Log und der Pc wird ausgeschaltet. Warum diese dann ausgeht versteh ich ja auch nicht das kann zwar in CBD eingestellt werden aber diese Einstellung greift ja nur nach der Beendigung der Bearbeitung , ist wohl ein Fall für Scully und Mulder :whistle:.
    Wenn dies geschehen ist kann ich den Vorgang erneut anstoßen und er läuft dann erfolgreich durch .
    Jetzt hab ich erst einmal das OS neu aufgesetzt und werde Deinem Ratschlag folgen und mir bei der Bearbeitung den Taskmanager mit öffnen um zu sehen wie die jeweilige Auslastungen sind.
     
  6. kufo

    kufo Well-Known Member

    @DaveO88
    Zeigt dir Windows nichts auf der Protikollseite an? Unpanmäßiges runter fahren sollte doch erkannt werden. Zunindest kannst du als Zshlencode sehen welcher Prozess das ausgelöst hat.
     
  7. DaveO88

    DaveO88 Moderator DE

    sieht für mich alles normal aus

    Unbenannt.PNG
     
  8. kufo

    kufo Well-Known Member

    @DaveO88 Stimmt, das sieht normal aus (y)

    Hatte gestern auch ein unerwartetes herunter fahren des Rechners... Schau mal:
    Shutdown.jpg
    Im Netz hab ich dazu folgende Erläuterung gefunden:

    Von der Energieverwaltung des Kernels wurde ein Herunterfahrvorgang initiiert.

    - System

    - Provider

    [ Name] Microsoft-Windows-Kernel-Power
    [ Guid] {331C3B3A-2005-44C2-AC5E-77220C37D6B4}

    Hast du vielleicht auch so einen Eintrag? Hat bei mir da wohl nicht direkt mit CBD zu tun gehabt, aber der Fehler wird oft durch eine beschädigte DLL ausgelöst. KERNEL POWER
    Habe zuerst ein Problem mit dem Windows Update vermutet und auf die 1803 zurückgefahren. (April 2018) Mal sehen was jetzt passiert :rolleyes:
    Auf @Retos Rat hin,hatte ich eine ältere CBD Version installiert. Da war hinsichtlich der Erkennung von der Quelle kein Unterschied. Zeitlich völlig identisch. Scheint wohl wirklich nur mit der Quelldatei zusammen zu hängen.
     
  9. DaveO88

    DaveO88 Moderator DE

    Kann ich nicht mehr da das OS nun neu ist
     
  10. kufo

    kufo Well-Known Member

    Ok, dann sollten auch keine dll Fehler drin sein. War ja auch nur ein Gedanke :D
    LG