Clone BD fails with HW accelleration set

Discussion in 'CloneBD' started by Felix Wagner, Feb 11, 2021.

  1. Felix Wagner

    Felix Wagner New Member

    Hi All,

    Just recently when started Clone BD again to convert GoT UHD I relaized that Clone BD does not work anymore and immediatly exits with a drone.nvidia.exe error. I tried other "normal" blurays that i previously converted and it also fails here.
    I am running the process with a Ryzen TR1950x and 2x GTX 1080Ti. So I guess performance should not be the issue. I am using the recent released driver from Nvidia.
    As mentioned in the help I attached the 2 files.
    I still can rip the video by using the original format or by setting encoding to software. It does not work either for 264 or 265 setting if HW encoding is set to yes.

    Hope anyone can help
     

    Attached Files:

  2. Felix Wagner

    Felix Wagner New Member

    So after many attempts to get more details I tried to solve the topic on my own...
    I relized that I have 2 NVIDIA GPUs in my system configured via SLI. It appears that CloneBD does not work anymore if the settings are to cluster them.
    Solution that I found was to deactivate SLI :-(
    Would have been very happy if there is an error message telling you so.

    So if anyone has a better solution instead of disabling SLI in the NVIDIA GPU settings I am very greatful.
     
  3. Felix Wagner

    Felix Wagner New Member

    Found finally a way to fix this issue by adding an exception in the "NVIDIA control panel--> Manage 3D Settings" for C:\Program Files\Elaborate Bytes\CloneBD\drone.nvidia.x64.exe to use ONLY ONE graphics card for CUDA GPU. Please be aware that it matters which graphics card you are using. In my case I am using the GPU2 for display output an this is the GPU that you need to select that it will work.
    Hoping for a note or fix by the developers so that this can be either highlighted if set already or to create a routine that will call the drone with only 1 GPU CUDA array.
    I will check if there is any difference in converison speed if SLI is disabled or used with the setting described above.
     
  4. Felix Wagner

    Felix Wagner New Member

    So after 2 months processing some disks and checking out the differnt settings there were no differences in either of them.
    So my decision was to let it run as described above which makes it much more easy and no changes are necessary anymore.
     
  5. Steve55

    Steve55 Well-Known Member

    I don’t think the devs watch this site any more, so it might be an idea to send an email to support@elby.ch just to inform them about your solution