Clone BD creates invalid Media ISO File

Discussion in 'CloneBD' started by juntiedt, Nov 26, 2015.

  1. juntiedt

    juntiedt Member

    Hallo support team,

    when I try to import an ISO file which I have ripped with clone BD 1.0.6.9 into Mezzmo, it says that the Media File ist incorrect. Same case with AVS Video Converter which says the file format error. Please see attachment. Any idea what is wrong? With DVDFab it works! As a very long time user of Any DVD and Clone DVD I am a little disapointed with Cloone BD.

    Look forward to a fast resolution of the problem ....
    BD_1.jpg BD-2.jpg

    Johannes
     
  2. Pete

    Pete Forum Admin Staff Member

    Can you open the file with CloneBD itself?

    I installed Mezzmo and created an ISO with CloneBD 1.0.6.9, it opened fine. So it seems something went wrong with your specific ISO.
    Log files (AnyDVD + CloneBD) would be helpful.
     
  3. juntiedt

    juntiedt Member

    Hi Pete,

    interestingly I can open the file with CloneBD and Kodi but not with Mezzmo and AVS Video Converter.
    Unfortunately Mezzmo is mandatory for me, as I am using it as Videoserver for all my TVs, PCs and tablets etc.
    Hope you can fix the problem.

    Regards
    Johannes
     
  4. Pete

    Pete Forum Admin Staff Member

    Elaborate Byte will have to fix it, not me, but how? As I told you, I can't reproduce this - I tried. So they probably can't either.
    Which is why I said: "Log files (AnyDVD + CloneBD) would be helpful."

    Or alternatively, you could maybe create such an ISO with reduced content (only copy small clips or trimmed clips with partial copy) and then upload it, so they can have a look at the actual thing.
     
  5. juntiedt

    juntiedt Member

    Attached the Logfiles of CloneBD
     

    Attached Files:

  6. juntiedt

    juntiedt Member

    Hi Pete,

    on october 22 I ripped "Jurasic world" with an older version of CloneBD (2 or 3 versions earlier than 1.0.6.9) It worked with Mezzmo.
     
  7. Reto

    Reto Elaborate Bytes AG

    We tested the situation with the disc you mentioned above (Last Knights).
    AVS Video Converter doesn't open any ISO file at all, no matter what and where it came from. It also does not claim to be able to or offer *.iso as a valid extension. I don't believe, it is meant to handle ISO files.
    With Mezzmo, I can confirm that it didn't open the ISO file created by CloneBD. It did open a different one created by the same version of CloneBD.

    It's hard to tell what the problem is, as mezzmo doesn't offer any debug information that would help identify the cause.
    In light of the fact, that every other tool does handle the files perfectly fine, I'm inclined to believe, it's a bug in Mezzmo, not CloneBD.

    I opened the above-mentioned ISO file with the following tools:
    - Virtual Clone Drive
    - DVDFab virtual drive
    - Windows 10 virtual drive
    - CloneBD itself
    - ISO Buster - note, that this tool is actually meant to fix and modify broken ISO/UDF structures, it detected 0 problems.

    All were happy, it's just Mezzmo. Please contact their support.
    If it turns out, there is a valid bug in CloneBD and there is some useful information to go on, I'm happy to pick it back up from there.

    EDIT: add PowerDVD 15 to the list, it opens the file and plays the movie.
     
    Last edited: Nov 27, 2015
  8. juntiedt

    juntiedt Member

    Hi Reto,
    many thanks for all your efforts. I must agree that AVS Video Converter does not open ISO Files. Sorry for that.
    But I have doubts, that Mezzmo is the Problem as the software did not change more than a year and cloneBD changes very often during 2015. Actually I am quite sure, that I already loaded cloneBD ISO Files into Mezzmo with older versions.

    I order to proof my theory I did the folowing:
    As Mezzmo indicates an invalid media file, I first created a BD File structure (not an ISO-File) with Clone BD and than with DVD Fab 9 in seperate directories. Having done the ripping of Last Knights I created two ISO Files with Image Burn (especially with a third program to exclude differences in creating ISO with Clone BD or DVDFab) of the Clone BD and DVDFab File Structure. Now I loaded the Clone BD ISO into Mezzmo - same error as before. Then I loaded the DVDFab 9 ISO into Mezzmo. Guess what happend - it worked perfectly.

    In order to find out the problem with Mezzmo, you should compare the two File structures. There must be a difference.

    Hope this helps to fix the problem

    Regards
    Johannes
     
  9. juntiedt

    juntiedt Member

    Please find attached the result of a comparison between CloneBD and DVDFab File structure. There are a number of differencies.
     

    Attached Files:

  10. Pete

    Pete Forum Admin Staff Member

    That makes no sense - Mezzmo isn't happy with the ISO structure, not with the CONTENT (or if it is, then it's really not giving helpful error messages). And of course there are differences between the contents of CloneBD's vs. fabs results. Both programs do far more than just decrypt discs. And elements like removing region codes can be done in a variety of ways, JAR file handling varies, etc...
    CloneBD's recompression is done differently, stream PIDs assigned differently, .....
    So... yes of course the content differs.

    As long as we don't know exactly what Mezzmo doesn't like, there's no point in starting to guess around. Contact them.
    You can try to create folder output (with otherwise identical settings) and then create an ISO using ImgBurn. See if that makes a difference.
     
  11. Recycle

    Recycle Well-Known Member

    Those are not log files if you want help post AnyDVD HD and CloneBD log files otherwise this posting is going nowhere.
     
  12. RedFox 1

    RedFox 1 Super Moderator

    The log files are posted in Post 5, please read the whole thread before responding. Thank you.
     
  13. juntiedt

    juntiedt Member

    Hello Slysoft support,
    what have you changed in the recent releases since my first posting in this threat. I succeeded in ripping two BDs and loading them into Mezzmo! No changes in Mezzmo!
    Great job!
    BTW Mezzmo checked the ISO of "Last Knights" and told me that they found a possible issue that will be fixed in the next Mezzmo release. Hopefully this is not contra productive.
    Johannes