Clone BD 1.1.9.0 UHD disk copy to MKV video issue

Discussion in 'CloneBD' started by JohnHWman, Feb 11, 2018.

  1. JohnHWman

    JohnHWman Active Member

    Hello To all,

    Since I've got an LG bluray burner BH16NS55 for a while now (with a valid 1.02 firmware :sneaky:) and when I've recently discovered that AnyDVD HD is now able to decrypt UHD blurays, I've decided to start backuping my ten UHD blurays collection on HDD using last version of CloneBD (1.1.9.0).

    On CloneBD, I've only choosed main title (the all movie) and then simply keep US and FR soundtracks/subtitles but let all the rest untouched (video & Audio with no compression) to make a simple UHD MKV file that have the same quality of the original UHD bluray.

    Everything runs fine (but long) to make all the ten MKV files with no error reported by CloneBD: good!

    Then I tried to play some of the CloneBD generated MKV files on my Zappiti duo 4k hdr player that I'm using to play UHD HDR MKV from some time now : The player play it fine on the soundrack but the picture is all the time jerky (like there is dropped images in the movie file)...

    I tried several support (Sandisk Extreme PRO USB3 key, sevral 7200rpm SATA3 HDDs) with the same exact result : video is unwatchable !

    This is really strange because I also tried one the those UHD HEVC/HDR MKV files that we can find on the internet (UHD rip/Remux) and those files played fine on the player (both Audio and Video)...

    So, this looks like that Clone BD made this ten UHD copies to MKV with dropped images from the UHD disc source ...

    Could someone tell me if you've been faced the same issue and how to solve it ?

    I really want to backup my starting UHD movies collection on digital to keep the original disc in safe place.

    Thank you for your ideas about this issue.

    John
     
  2. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Lets start by you providing cloneBD logs for the conversions you say arent working properly. Otherwise the dev's have nothing to work with.
     
  3. goncal

    goncal Well-Known Member

    Those MKVs you found on the internet might be re encoded, lower bit rates
    Lossless tends to mean high bitrates. I have seen bit rates as high as 70 to 90 Mbps average on the video file
    Might be your playback chain can't handle the bandwidth requirements
    Also
    Try remuxing your CloneBD MKVs with MKVToolNix and see if that helps
     
  4. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Where or how he got the other MKV's shall NOT be discussed any further or support in this topic will be terminated effective immediately. Downloading copyrighted content is piracy and will not be tolerated.
     
  5. goncal

    goncal Well-Known Member

    Just pointing out it could be a bandwidth issue
    I don't condone downloading such stuff
     
  6. JohnHWman

    JohnHWman Active Member

    No problem Ch3vr0n,

    Here is the complete CloneBD process steps and Logs:

    Capture1.png
    Capture2.png
    Capture3.png
    Capture4.png
    Capture5.png

    Here is the LOGs :
    The_Martian_UHD_CloneBD_LOGs.cbdlog
    In Text format :
    SnapshotPlayer_LOG.txt
    Transcoder_LOG.txt

    FYI, I've compared the MKV file size generated by CloneBD on THE MARTIAN UHD bluray MKV copy to the size of what is available in the "internet darkside" and they are really close... So I don't think it's relevant to high bandwidth issue ;)

    However, in the last screen capture step of the process : it is strange that I've got:
    - Readed data : 48.83 GB,
    - Write data : 43.41 GB
    Why there is loss of datat between read and write process ???

    Thanks for any help, I'm puzzled :unsure:

    John
     
    Last edited: Feb 11, 2018
  7. JohnHWman

    JohnHWman Active Member

    FYI, I've also tested the above generated MKV playback from an Oppo UDP-203 player and I've got perfect soundtrack playback but only black picture!

    Go figure :whistle:...

    John
     
  8. testiles

    testiles Well-Known Member

    I'm following this closely because I got the same problem when I tried to create a UHD mkv with CloneBD.

    I readily admit I know nothing about it since I usually use CloneBD to create iso's. So there's the learning curve for mkv AND I guess for UHD.

    I created an mkv with the original resolution and original soundtrack and got audio but just black screen on playback.

    So I'm curious to see how you resolve this.


    The lower write data is because it read the entire UHD "disc" but only had to write the main movie and the audio and subtitles you selected.



    T
     
  9. JohnHWman

    JohnHWman Active Member

    Thanks for your report testiles,

    I'm not alone...
    This confirm that there seem's this is an issue with CloneBD when ripping UHD discs with original video and audio streams. Can someone else try these settings of UHD copy and test the generated MKV using another 4K HDR player (like Nvidia Shield for example) ?

    Thanks also about data Readed/Writed values delta : this makes sense, I should have think a bit more about it ;)

    Ending : since I've made the UHD copy of The Martian twice (with the exact same CloneBD's settings), I've checked the size of the generated MKVs and I found that there is a size difference of ~250MB between the two MKV files on the HDD: This sounds really strange, indeed !!

    John
     
    Last edited: Feb 13, 2018
  10. goncal

    goncal Well-Known Member

    Try running the CloneBD MKV through MKVToolNix and see if it works
     
  11. JohnHWman

    JohnHWman Active Member

    OK goncal, I'll give a try with mkvtoolnix-64-bit-20.0.0 but what tool to use (mkvmerge, mkvinfo, mkvextract, mkvpropedit and mmg) ?

    Also, this seem's to be a standalone program that takes existing MKV files to analyse/edit metadatas is there a viewer/checking video content/framerate integrity in there ?

    I'll try also CloneBD 1.1.9.1 beta to check if this beta solve the seen issue.

    John
     
  12. goncal

    goncal Well-Known Member

    Just use the multiplexer from the gui
    Don't add or delete tracks, just let it re mux the MKV file
     
  13. SamuriHL

    SamuriHL Retired Moderator

    I don't have a lot to add to this topic other than I re-ripped Guardians of the Galaxy Vol 2 as a test to see if I'd have any problems with it using CloneBD 1.1.9.1. I didn't get a chance to play it back on my Shield yet, but, playing it through J River MC using madvr to downscale it to 1080p for my plasma, it looked damn near flawless. That's doing an HDR->SDR conversion and color space conversion, of course. The MKV played just fine.
     
  14. goncal

    goncal Well-Known Member

    Of course but this would help to narrow down the cause
    MKV mux -- player -- etc
    Don't forget, down scaling and HDR > SDR involve some processing of the file
    Either way, if a re mux fixes problem then it is a mux issue, if not then it might be a player issue
    I'll redo one of my UHD movies and see what happens
     
  15. goncal

    goncal Well-Known Member

    Did a quick test
    UHD to MKV -- lossless video and lossless audio
    Players JRiver and for giggles, MPC-HC
    Plays back fine
    Issue might be specific to your media player
     
  16. SamuriHL

    SamuriHL Retired Moderator

    Yea I figured giving at least another data point might be helpful. So far my MKV rips have been awesome. I don't have a 4K screen to test on at this point.
     
  17. JohnHWman

    JohnHWman Active Member

    Thank for your test goncal,
    Yes, this seem's to be an issue with the player (Zappiti 4K HDR or Oppo UDP203). But what is really strange is when I play the same UHD MKV title retreived from the net (probably been done with MakeMKV tool) : it plays fine on my Zappity 4K HDR player...

    Had no time yet to test CloneBD 1.1.9.1 nor mkvtoolnix yet, I'll keep you updated once done.

    John
     
  18. TiVoMad

    TiVoMad Member

    I can confirm that I see the same issue on my OPPO-203 (Sound but black screen). I tried John Wick and King Arthur - Legend of the sword. I then tried ripping them with MakeMKV and it works fine. Having said that, the CloneBD output works fine via InFuse on the Apple 4K TV and MPC-HC. It must be a subtle difference.
     
  19. JohnHWman

    JohnHWman Active Member

    Good finding TiVoMad,
    Yes, the CloneBD issue on the remuxing UHD material should be subtle so hard to find for RedFox programmers. I wonder If we can use an MKV analysis tool to compare same UHD bluray remuxing from both CloneBD/MakeMKV and sort the differences...
    John
     
    Last edited: Feb 20, 2018
  20. JohnHWman

    JohnHWman Active Member

    Hello to all,

    This morning, I gave a try to MakeMKV tool (V1.12.0) on "the Martian" UHD. Here is the mains steps:
    - Use AnyDVD HD 8.2.2.0 to copy the UHD disc complete ISO to the SSD (almost 80min. of time),
    - Mount UHD iso image using Virtual Clone Drive
    - Use MakeMKV, to select mounted ISO image to strip all the languages and subtitles except English/french,
    - let the tool processing the MKV file on a separate HDD in USB3 (very fast process from SSD).

    Then, I've inserted the HDD Inside my Zappity 4K HDR duo mediaplayer and played the generated file : It play perfectly :) with no image drop as noticed when using CloneBD v1.1.9.0...

    So the seen issue is clearly due to CloneBD Tools, not my media player ;)

    Is there a chance that upcoming release of CloneBD will solve this current remux issue ? I found the MakeMKV tool's tracks/languages/subtitles unselect process a real pain --> CloneBD tool is much more easier to setup !

    Thx

    John