Can't upgrade from 1.1.2.0 to 1.1.3.1 or 1.1.3.2

Discussion in 'AnyStream' started by kzajac, May 16, 2021.

  1. kzajac

    kzajac Well-Known Member

    When I try to upgrade from 1.1.2.0 to 1.1.3.1 or 1.1.3.2 (32bit) I get an error message that only allows me to Abort. I've tried uninstalling 1.1.2.0 completely and installing 1.1.3.1 with same error message. I can go back and install 1.1.2.0 with no problem.
     
  2. DeepSpace

    DeepSpace Well-Known Member

    Why don't tell us what's inside this message? Maybe a screenshot?
     
  3. kzajac

    kzajac Well-Known Member

    Never mind. I identified the issue. Works now.
     
  4. kzajac

    kzajac Well-Known Member

    Sorry still have the issue. The error message states that there is Error in Opening file c:\\Program Files (x86)\Redfox\Anystream Options are to Abbort/Ignore Files/Retry
     
  5. RedFox 1

    RedFox 1 Super Moderator

    Your computer has issues
     
    zero269 likes this.
  6. cartman0208

    cartman0208 Well-Known Member

    Did you already re-download the file?
    Try to execute as administrator.
     
  7. testiles

    testiles Well-Known Member

    When I got this message I (mistakenly) had AnyStream open when trying to install a new release.

    Closing the app and hitting Retry allowed it to proceed...


    If you don't have AnyStream open, maybe there is another app running that has a lock on the file and won't let the installer modify it.



    T
     
    Last edited: May 16, 2021
    RedFox 1 likes this.
  8. RedFox 1

    RedFox 1 Super Moderator

    He should try to uninstall completely and then reboot turn off his firewall and try and install.
     
    zero269 likes this.
  9. DeepSpace

    DeepSpace Well-Known Member

     
  10. RedFox 1

    RedFox 1 Super Moderator

    I have reopened this thread at the request of a good member. Please keep it friendly and professional
    Why is there no screenshot of this error. I asked the OP to turn off his firewall to see if something is blocking the program. I have no idea if he tried it. In order to help we need information. Even though this is not an AnyStream issue, it may be related. But if the OP cannot help us help him with screenshots of the error or more information I find it almost impossible to guess what the issue is.
     
    whatever_gong82 and DeepSpace like this.
  11. RedFox 1

    RedFox 1 Super Moderator

    Usually, that message means that the program is still open and cannot be reinstalled. If I were him I would go into the task manager and turn it off completely. Then reboot and try and reinstall.
     
    DQ likes this.
  12. DQ

    DQ Well-Known Member

    Not that it solves the OP's problem but I for sure had this exact issue recently and it was because of what RF1 said. I had it running like a goof. I shut it down and then ran the upgrade and everything was fine.
     
  13. Ch3vr0n

    Ch3vr0n Translator NL

    Normally the installer should auto shutdown the application prior to actually trying to update the files, in the same way rubbing an update for Anydvd shuts down Anydvd and the tray icon vanishes.

    Sent from my Pixel 3 XL using Tapatalk
     
  14. testiles

    testiles Well-Known Member

    This is true for AnyDVD but definitely not the case for AnyStream.

    The "Error opening file... Abort, Retry, Cancel" message is what you get if you try to install while AnyStream is open. Every time.

    I pointed this out a while back and suggested maybe a message to close the app may be more informative - BUT I'm not sure if an open app during the install is the only time you get that message.

    Perhaps other scenarios might generate it too, so it has to be as generic as it is.


    But in the OP's case, he said he uninstalled and re-installed, so it shouldn't be possible to have the app open while doing the re-install...

    Which is why I thought maybe some other application on his computer is locking up the AnyStream folder.

    Best thing to do is as others suggested: re-boot, make sure AS is not open and try again.



    T
     
    Last edited: May 17, 2021
    whatever_gong82 likes this.
  15. zero269

    zero269 Well-Known Member

    Hello kzajac,

    After reviewing this thread, RedFox 1 was correct when he stated
    There are several fundamental troubleshooting steps you can perform to help narrow down the issue.

    This assumes you have already uninstalled AnyStream.

    Manually Remove AnyStream:
    Delete the AnyStream folder and all contents from %ProgramFiles%\RedFox
    Delete all AnyStream registry entries associated with the %ProgramFiles%\RedFox\AnyStream path; to include any that have an AnyStream.exe association. Most others can be ignored.

    Windows Updates:
    Install any pending Windows Updates and Restart. Rinse and repeat as needed.

    Disk Cleanup:
    Run Disk Clean up as an Administrator on your system drive and clean everything up. If you see the Downloads folder listed, you might want to uncheck that one. However, don't confuse that with the Downloaded Program Files; you want that one checked. Restart the computer.

    Hardware Diagnostics:
    You might want to rule out system/storage/memory corruption.
    Run the System File Checker as an Admin to check for and attempt a repair of any OS corruption. This one can take a very long time if any corruption is found. If that comes up clean, then run Check Disk on your system drive. If both come up clean, then you should check your memory. Hopefully you are comfortable with removing the memory modules one at a time and checking them with a Memory Scanner tool, such as the Windows Memory Diagnostic tool.

    Best of luck, but you may need to visit a Windows forum for help on this topic.
     
  16. Wowfunhappy

    Wowfunhappy Active Member

    ^ Also, consider just doing a clean reinstall of Windows. It's often easier and more effective to just start fresh than trying to fix an install that has gone haywire.
     
  17. zero269

    zero269 Well-Known Member

    There's definitely nothing wrong with that approach. I deploy Windows often in my Home Lab, and so this is an easy feat for me. However, this really should be a last resort for anyone not comfortable with that approach.

    With that said, if Windows turns out to be corrupt, and the repairs are not successful after two attempts, then a clean Windows install is a must.(y)
     
    whatever_gong82 and RedFox 1 like this.
  18. 0x0x0x0x0

    0x0x0x0x0 Well-Known Member

    Incidentally, Windows 10, for a long time, had a feature called "Reset this PC" [1] that installs a fresh copy of itself over the existing one while preserving all your docs, etc, if you want.

    Code:
    1. https://support.microsoft.com/en-us/windows/recovery-options-in-windows-10-31ce2444-7de3-818c-d626-e3b5a3024da5#bkmk_section2
    
     
    Last edited: May 20, 2021
    zero269 likes this.
  19. James

    James Redfox Development Team Staff Member

    No, it does not.
     
  20. Ch3vr0n

    Ch3vr0n Translator NL

    Well I mean the tray icon vanishes and reappears I think

    Sent from my Pixel 3 XL using Tapatalk