can't get BF2 working since updating

Discussion in 'GameJackal' started by Juventas, Mar 15, 2008.

  1. Juventas

    Juventas Member

    I updated from 2.9-something to 3.0.0.8 and my Battlefield 2 profile now asks to insert the disc. I deleted the profile and created a new one, still same problem. The game works fine if I don't use the profile and use the disc. My other profiles seem to be fine too. Should I try to find a 2.9 installer?
     
    Last edited: Mar 16, 2008
  2. Webslinger

    Webslinger Retired Moderator

  3. Juventas

    Juventas Member

    Didn't help (not that it should judging by the changelog). I emailed Slysoft support and they were surprised I had it working in 2.x, which is strange because there's lots of posts on here from bf2/gamejackal users back then. They told me to remove the profile and recreate, which I had already done.

    Anyway, there is a point to this post. I tried the image mode profile creation, which took over an hour, but now it works, nice and quick. Yeah!
     
  4. Webslinger

    Webslinger Retired Moderator

    I'm glad it's working for you. You may want to try Game Jackal 3.0.1.0 as well.
     
  5. matthew

    matthew SlySoft Team Member

    BF2 should work without using image mode. Is this a newly patched version of BF2?