Blu-ray needs to be in the drive at boot

Discussion in 'AnyDVD HD (Blu-ray issues)' started by anydvdproblems, Oct 17, 2015.

Tags:
  1. Hello Team

    I haven't purchased AnyDVD HD yet, just running the latest version in trial mode.
    If I can get this problem fixed, happy days and will likely proceed with purchase.

    The problem I am having Is the Blu-ray needs to be in the Drive at boot for AnyDvd to decrypt it properly.
    I am not even trying to burn or copy the disc.

    I have built a media centre PC with Kodi installed and am only trying to watch the Blu-Rays.
    If I have the Blu-ray in the drive when the computer boots then I don't have a problem, the movie plays fine I can even take the blu-ray out and put it back it and it continues to work.

    If I boot with no Blu-ray in the drive wait for windows to load - and or Kodi then put the blu-ray in Anydvd in the status window claims it has removed the protection ect but it hasn't or something has gone wrong because I cant see the contents in Windows explorer and it wont play either.

    I have a feeling its the dodgy DVD drive I am using it seems to be a weird oem model that has no firmware support for it.

    DVD drive is a Pioneer BDC-207DBK - although my computer seems to only detect it as a BDC-207D (which I don't even think exists.)

    I appreciate your time looking into this for me.
     
  2. Adbear

    Adbear Well-Known Member

    Definitely an issue with your system as I've run AnyDVD HD on many systems over the years and never had to have the Blu-ray disc in the drive at boot up to make it work.

    What version of Windows are you using?
     
  3. I am currently running Windows 8.1 64bit,

    It's a very strange issue, I don't know what the drive would be doing *differently* for it to only work when a blu-ray is in the drive at boot up as apposed to inserting a disc after boot up.

    I have done a fair bit of googling and coming up blank - not sure if I am googling the wrong phrases to help me sort it out, but I am trying...

    Hopefully I can fix it without replacing the drive.

    thanks
     
  4. Adbear

    Adbear Well-Known Member

    Have you installed all the motherboard drivers after installing Windows?
     
  5. Yes, installed all the latest drivers for the Motherboard from the manufacturer website using ASRock H81M
     
  6. ddjmagic

    ddjmagic Well-Known Member

    If you turn off/exit AnyDVD, does Windows explorer then see the contents of the Blu-ray drive? (when the disc isn't in the drive on boot)
     
  7. Hmmm ok your onto something - it has nothing to do with Anydvd - If I dis-able anydvd and disable autostart then restart with the blu-ray not in the drive windows wont see it properly - If I restart again with the disc in the drive windows then sees it.

    google seems to be showing up some different answers now I will try a few out, none are for my specific drive but might help....
    Hopefully its not a dud drive.....

    Any ideas keep throwing them at me.

    cheers.
     
  8. ddjmagic

    ddjmagic Well-Known Member

    Have you tried it without running Kodi at all? I had some problems a while back not seeing the contents of my BD drive (though this was because I was using XBMC as the Shell)
     
  9. I am using Kodi as the Shell but I turned that off while I was troubleshooting.

    HOWEVER, that being said I have fixed the problem, and thought I would let you know what steps I took in-case others run into the issue.

    When I realised this wasn't a AnyDvd problem and more of a windows/hardware problem I tried a few different google searches and came upon this answer.

    http://blogs.technet.com/b/asiasupp...dvd-drive-is-not-recognized-in-windows-8.aspx

    Resolution:

    1. Run Command Prompt as an Administrator. Type cmd in Windows 8 Metro UI and press cltr+shift+enter

    2. Type following and say enter

    reg.exe add "HKLM\System\CurrentControlSet\Services\atapi\Controller0" /f /v EnumDevice1 /t REG_DWORD /d 0x00000001

    3. Reboot the system

    4. Verify if the problem has been resolved.

    In between adding this key to the registry I also uninstalled the DVD drive from device manager - turned the computer off disconnected the DVD drive from the board - both sata and power - Turned the PC back on - Then switched off again - connected the power and sata but this time connected to a different Sata point on the board.

    powered on and everything is working, I did have to re-install AnyDVD again but I am assuming that's because I changed the Sata point on the board.

    Thanks to everyone who helped nut this one out.

    cheers.
     
    ddjmagic likes this.