Avengers Infinity War UHD audio out of sync for MKV

Discussion in 'CloneBD' started by PSUHammer, Feb 15, 2019.

  1. PSUHammer

    PSUHammer Member

    I am ripping my discs to my NAS to make them easily accessible on my Plex server. As a videophile, I am looking for lossless containers (MKV) and stripping out everything but the movie, audio track and english subtitles.

    I am first ripping the Blu Ray disk to the server and then using CloneBD to mux to the MKV container. It appears to work properly and I am able to successfully play the film. The only issue is the audio is just a millisecond or two off where the audio starts just a split second late. This is really only noticeable when people are speaking to each other.

    I use tsmuxer for my 1080p Blu Rays with no issue.

    I am not sure if this audio sync issue is a limitation of CloneBD or if it it is something I am doing wrong. Here is my log.
     

    Attached Files:

  2. Fabian

    Fabian Developer

    I have a look at it.
     
  3. PSUHammer

    PSUHammer Member

    Coincidentally, The Last Jedi went better but is still slightly off.
     
  4. PSUHammer

    PSUHammer Member

    Just an update on this as I have continued to play around with settings to try to narrow things down. I have noticed that they sync issue only seems to be happening when I choose the Copy original (lossless) audio option. If I choose DTS, for instance, or AC3, the audio plays fine and is perfectly synced.
    I feel this may be related to the lossless HD audio stream.

    I am also noticing an issue with DVD subtitles. I am avoiding the BluRay versions as I know it disables HDR on playback. But choosing DVD titles causes the movie to fail. I am using a Plex server on my local LAN and viewing the MKV through a Roku TV using the Plex app. Standard Blu Rays play flawlessly, even with HD audio.

    My network is wired and uses gigabit grade bandwidth throughout.
     
  5. SamuriHL

    SamuriHL Moderator

    It's a Disney ATMOS issue on the audio sync. All of my Disney movies with ATMOS have the same problem. I re-ripped one with the latest 64 bit beta but haven't had time to check if it's still an issue or not.
     
  6. coopervid

    coopervid Well-Known Member

    BTW-never had sync issues with ATMOS and Disney releases. But I only compress to burn to optical discs. BluRay to 25Gb. UHD to 50Gb.

    Are you doing something different that could cause the issue?
     
  7. SamuriHL

    SamuriHL Moderator

    Yea....not touching the streams at all. Simply outputting lossless video and audio to an MKV container.
     
  8. coopervid

    coopervid Well-Known Member

    there's the difference...
     
  9. Pete

    Pete Forum Admin Staff Member

    Really? Why that?
     
  10. PSUHammer

    PSUHammer Member

    Whenever I enable Blu Ray style subtitles, HDR disables when watching on Plex. I have to use DVD style subtitles. I read online that this was a thing, as well.
     
  11. PSUHammer

    PSUHammer Member

    This is all I am doing.
     
  12. SamuriHL

    SamuriHL Moderator

    I've not had that issue with Plex. I've ripped a bunch of UHD's with blu-ray subtitles and no issues. If I get some time tomorrow I'll take a look.
     
  13. Pete

    Pete Forum Admin Staff Member

    I never heard of this before. I also can't imagine why that would be the case. There's no technical reason for this.
     
  14. PSUHammer

    PSUHammer Member

    It is indeed a thing with Plex (maybe some Plex apps). I can verify it is indeed a thing with me. There is an easy way around it in that you just download the SRT text subtitle track you want and add them that way. The BluRay PGS subtitles are image files and some Plex apps (Roku, etc.) have issues playing them and HDR content at the same time. Regardless, not a big deal for me but something to be aware of is you are using UHD/HDR and a Plex server.

    I am way more concerned about the HD audio sync issue which does appear to be resulting from the CloneBD transcode/mux of UHD and lossless audio tracks. DTS/AC3/ACC all work properly.

    Reading on the subtitle thing if interested: https://www.reddit.com/r/PleX/comments/8zzq4h/how_to_hardcode_subs_plex_removes_hdr_with_subs/

    https://forums.plex.tv/t/why-plex-hates-subtitles/322799
     
  15. PSUHammer

    PSUHammer Member

    I can confirm it is not just Disney films with ATMOS audio tracks. It happens with Saving Private Ryan as well as Braveheart. This is definitely related to lossless audio. Even for these films, if I switch to standard AC3 or DTS, the audio is synced properly.
     
  16. MartyMcNuts

    MartyMcNuts Well-Known Member

    My Infinity War UHD was fine. Ripped and shrunk to about 30GB. Watched it a couple of months ago and was perfectly in sync. Geez, ATMOS is wonderful isn't it..
     
  17. SamuriHL

    SamuriHL Moderator

    You shrunk it. That's the difference.
     
  18. MartyMcNuts

    MartyMcNuts Well-Known Member

    True, but that shouldn't make a difference. It's the audio that plays havoc for people, not the video.

    I just played the decrypted m2ts file and it is also in sync throughout.
     
  19. SamuriHL

    SamuriHL Moderator

    No, I'm telling you if you encode it in any way there are no problems. It's only when you RIP the streams that this issue happens. It's an issue with how the segments are ripped IMO.
     
  20. MartyMcNuts

    MartyMcNuts Well-Known Member

    OK. The only UHD that I have ever had an audio sync issue with (so far) was Independence Day.

    I first created my mkv my usual way. (decrypt disc to folder, extract audio and subtitles using HD-DVD/Blu-ray streams extractor, used CloneBD to shrink video to 25Mb/s, use MKVtoolnix to put it all together.) I then watched it but had sync issues after around the first 5 mins or so (when it changed to the next segment).

    I resolved this by extracting each segment individually in CloneBD, noting the segment order from the playlist, then using MKVtoolnix to put it all together. Watched it and was in perfect sync all the way through.