Avengers Engame, hang at 99% complete

Discussion in 'CloneBD' started by Ch3vr0n, Sep 1, 2019.

  1. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    First time in a log time i'm having an issue. CLBD keeps hanging at clip 241 (98%) on a title it sais "current video being copied without being transcoded". Elapsed time at that point is 15:06min, remaining has been 0:00sec for about a minute (since it was copying over multiple such files) and current conversion rate 209fps

    aborting doesn't work, so can't create a full logfile. Attached are debug files

    I have to use taskmanager to shut it down.

    Semi-Partial copy (aka full disc copy through manually enabling all streams, but minus unwanted audio/subtitles). The thing is, on the title preview page, i'm not seeing a #241. However i AM seeing

    Title 249/still image #1/6 frames/AVC 1920x1080@24fps, lvl 4.1 high/corresponding to clip #00007
    title 7/intro #193/6 frames/same specs/also corresponding to clip #00007
    title 3/still image #2/6 frames/same specs/clip #00003
    title 1541/still image #3/6 frames/same specs/clip #00241

    Disabling title 1541(clip 00241) allows cloneBD to complete succesfully. That logfile is attached
     

    Attached Files:

  2. Ch3vr0n

    Ch3vr0n Translator NL & Mod

  3. Fabian

    Fabian Developer

    I can't see any issue from the log. Should have the disc tomorrow, then we'll see.
     
  4. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    I know it's weird, it's the exact same 'config' as those other 6 frame clips yet those don't hang. Exclude that single title and the backup works fine. Haven't burned to disc yet, just to be sure.

    For the sake of completeness, mine's a 2disc version (with lots of bonus stuff on 2nd disc)

    Sent from my Pixel 3 XL using Tapatalk
     
  5. Pete

    Pete Forum Admin Staff Member

    Trying to reproduce this, question:

    Firstly, so we're literally on the same page: what is the "title preview page"? I was assuming "Selection page"?
    Secondly: I can't make any sense of this. You say, you're not seeing 241 and a few lines later, that you are seeing 241.
    So: how do you mean that?
     
  6. Pete

    Pete Forum Admin Staff Member

    So far I reran the copy process two times - third is running just now.
    It's the exact same disc and I can't see any problem.

    My settings in detail:
    • partial copy, selected all titles (including 1541)
    • Audio and subtitles: all "eng" and all "nld" languages, no others
    • shrink to 25GB, destination HDD
    • Audio lossless copy
    • Using nVidia GTX 1060, high quality setting
    Goes through without a hiccup in 15 minutes or so.

    I also wonder: the cbdlog you posted above. You said that was achieved, by deselecting playlist 1541. But the log says otherwise, the clip #241 got copied successfully (see time mark 00:15:28.892), as has the playlist 1541.

    Even so - I should point out, that clip #241 is the last one being processed. And it's tiny and it goes through a very simple process, that doesn't do anything complicated, there's hardly a reason for it to fail or even get hung up.
    What is much more likely, is that something CloneBD is doing right after transcoding, which would be creating and rewriting mpls files, is going bad.

    But again: for me it's going OK.
    I don't know what settings you have in your AnyDVD, that also modify disc content - which would, of course, also influence CloneBD.
    Like remove short trailers or so.

    If it happens again, I suggest, when CloneBD hangs, just open task manager, right click on the stalled CloneBD process (best not even try to click abort), select "create dump file" and let Reto and the Swissboys analyze it.
     
  7. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    I just checked the encode where i deselected that #241, the clip is indeed there. That's just weird

    First, indeed title selection screen.
    Second: What i meant by "not seeing clip 241" is that on the left side with all the title numbers (Title xxx, intro xxx, etc) is that there i didn't see any 241 which was problematic. So i manually checked the stream names it was "copying without transcoding" and then found tit"Title 1541, still image corresponding to clip #00241 when hovering the mouse over the title"

    Rerunning test 1 (partial copy, all titles [none deselected] including 1541).

    AnyDVD settings: none of those "remove clip..." settings as i know they can be problematic. There's only 2 BD settings enabled, namely blu-ray support and remove UOP's. That's it.
     
  8. Pete

    Pete Forum Admin Staff Member

    OK, that's normal - titles (actually playlists) are not the same thing as clips, so clip #241 is entirely unrelated to playlist #241.

    Playlists 440 and 1541 are the only ones referencing clip 241.
    And that's likely the reason why deselecting playlist 1541 didn't prevent clip 241 from being copied, since another playlist also references it.
     
  9. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Well, i swear i tried it last week multiple times and it would do a "full-partial" 3x in a row, guess what just happened. Worked first time. Maybe a caching problem, or some temporary issue, i don't know. All i know is that it just finished without hanging. I'll see over the weekend if everything plays ok, but for the moment it's solved.
     
  10. Pete

    Pete Forum Admin Staff Member

    OK, next time do the dump file thing with the task manager. It's still possibly a bug.