Audio Sync Problems

Discussion in 'CloneDVD mobile' started by slimf, Jan 30, 2007.

  1. johnny_pockets

    johnny_pockets New Member

    Had same issue - seems to be ok now

    I uninstalled the Combined Comunity Codec Pack and Haali Media Splitter - tried again and things were synced up.
     
  2. mightypile

    mightypile Member

    From the mplayer documentation

    This is pulled from the mplayer website.

    I don't know if this affects the CCCP or Haali codecs that people talk about fixing the problem. Perhaps the Slysoft developers all have certain video cards or drivers that are different from those on some of our cheaper laptops. Just an idea. Could the slysoft folks please see if the 'autosync' flag slows down the process on your machines or causes any other problems? I'll play with adding it to my own setup (which consistently has audio sync problems) and report back my results.
     
  3. gkinca

    gkinca New Member

    What I've tried

    To start, I'm running a Panasonic CF-30 with XP pro and I think about 1.66 Ghz process and 1GB of ram. My files are pre-ripped. I'm in Iraq and buy the movies from locals on base. Playing them in VOB and IFO..? format is no problem off my external hard drive. When I would convert to MP4 under "Microsoft Zune" with full settings (highest quality and screen size) I would have audio sync problems using Windows Media Play and Zune media player.

    If I converted to WMV files, no audio sync problems.

    Then friend gave me VLC Media player. Looks pretty simple, not as fancy as the others, but seems to not have the audio sync problem.

    I'm considering buying a portable dvd player with USB ports to run from my external. I hope it will play with no audio problems.

    Good luck
     
  4. Mr_Slugger

    Mr_Slugger New Member

    It's November and the Sync issue is still alive - HELP

    hi all, well I just spent the last hour going through these forums and this thread...a little disapointed that there is no clear answer to the audio sync issue.

    I am a happy user of both AnyDVD and DVDClone2, got the DVDClone Mobile a while ago but have never used it until now. I just got my kid a PSP for xmas, so was trying a few DVD conversions to see how it would work for her.

    I selected PSP from the first screen and the first choice which is PSP AVC/H264. Click next and select a movie that I have ripped to my harddrive, this is ripped with AnyDVD/DVDClone full size, no compression.

    I select leave the default audio stream English dolby AC-3/6 and disabled subtitles, click next..

    Leave everything default which is 368x208, highest video quality, 1 pass, deinterlaced checked.

    I have tried this on 2 films now, soon as the first finished I went to the folder on the harddrive where I created it and double clicked, it open in windows media player and the first thing i notice was lip sync was out....very odd. the second film was the same, ended up here!

    My PC is a beast, I am running off Vista Ultimate 32bit (which I hate!) on a nForce 790i MB with Intel Extreme quad X6700 cpu, 2 Gig of 1333MHz ram, 10k main disk where the software is installed and a 6TB raid array where the files are created and read from.

    The encoding is taking approximately 25 minutes per film, this outputs a 500-600meg file.

    I am using the lastest version of the software and the films I tried are NTSC R1 (USA) Alvin and the chipmunks and Garfield 2, my dvd drive is set to R1

    PLEASE can some one help me get this working for the PSP before Xmas!!

    I have not tested play back on the PSP as its rapped up for my kid already!!

    Many thanks..
     
  5. JeffB

    JeffB Active Member

    I just updated to the beta and it solved the audio sync issues in iTunes with my AC/DC Live at Donington DVD. However, I cannot get the iPod version to load on my iPod Touch or on my 80 GB Classic. But that's a topic for a different thread.

    -Jeff
     
  6. Mr_Slugger

    Mr_Slugger New Member

    So I tried a thrid movie, dodgeball and also changed to the highest quality, the first was not on max I guess as the size of the output file is much smaller than the last 2 I tried (300meg) and the sync issue in not there. The first one was the worse, I'll try it again will high settings.

    Anyone using this software for PSP and has any tips?

    Also is there somethign I can set in the config file to use more cores?

    Thanks!

     
  7. Spanky

    Spanky Well-Known Member

    Hello Mr_Slugger and welcome to the forum. I've been making PSP movies all afternoon and having really good luck with the latest beta version 1.5.0.4. It has solved the A/V sync issues as far as I can tell. Download it here: http://forum.slysoft.com/showthread.php?t=21748 . I will also include a pdf file I made for a friend and have posted here before, hope it helps.
     
    Last edited: Nov 16, 2008
  8. Spanky

    Spanky Well-Known Member

    I see the pdf did not attach, they have cut the allowable size down so I'll try that again as a zip!
     

    Attached Files:

  9. KnoWei

    KnoWei Well-Known Member

    I have not had problems with a/v sync on PSP or iPods. Just with DivX profile.

    For movies you should not use the DeInterlace parm. That should only be checked if you are converting something that was made for TV like a series or made-for-TV movie.

    Try the conversion w/out DeInterlace and post back.

    Also can you clarify if the out of sync gets progressively worse or is it consistent through the movie?

    ~KnoWei
     
  10. KnoWei

    KnoWei Well-Known Member

    Please see the early postings by Prof Colli and others in this thread for a Dual Core discussion and settings.

    http://forum.slysoft.com/showthread.php?t=11381

    ~KnoWei
     
  11. profcolli

    profcolli Well-Known Member

    I believe the latest device.ini defaults to multi-core where possible - see postings by the developers on beta versions. There may be problems with some of the profiles using multi-core, though.
     
  12. dhl

    dhl New Member

    device.ini change for mopts delay for PSP 480x272 (AVC/H264)

    Newbee to forum and indeed Slysoft software. Very impressed with look and feel of software. But have had same audio synch problems as listed in this thread when creating PSP movies from my Region 1, Region 2, Region 4 and All Region DVDs, therefore, I conclude it is hardware related. I have a good machine with Pentium D, i.e. dual threads (maybe the issue!).

    I have read elsewhere that CloneDVD Mobile update is coming soon to correct the problem. I have tried the beta but this just errors out when I use it.

    Earlier in this thread there was mention of changing the mopts line in the devices.ini to include a delay. I would like to play around with this in my devices.ini but having added it to the [PSP 480x272 (AVC/H264, FW > 3.30)] section I just get an error. Previously tasbert said he got this change working for PSP - can anyone explain where I should put the delay logic in the mopts line for the [PSP 480x272 (AVC/H264, FW > 3.30)]:

    Current mopts line in devices.ini for [PSP 480x272 (AVC/H264, FW > 3.30)] is:
    mopts=-faacopts br=%abrate%:mpeg=4:eek:bject=2 -x264encopts bitrate=%vbrate%:level_idc=21:bframes=3:threads=0:frameref=2:nopsnr:nossim%PASS%

    Any help appreciated.

    DHL
     
  13. dhl

    dhl New Member

    Dear all - please ignore my last reply, I really should have attempted more permutations before requesting answers from you guys. It really was very easy.
    For those of you interested, I update my devices.ini to include the following line:

    mopts=-delay 0.2 -faacopts br=%abrate%:mpeg=4:eek:bject=2 -x264encopts bitrate=%vbrate%:level_idc=21:bframes=3:threads=0:frameref=2:nopsnr:nossim%PASS%

    My machine needs a 0.2 delay. I am chuffed to bits because my movies now look AND SOUND fantastic on the PSP.

    Happy New Year and thank you Slysoft for a great piece of software (even with the small tweaks I have had to make myself).
     
  14. profcolli

    profcolli Well-Known Member

    mopts line in your post should be
    Code:
    mopts=-delay 0.2 -faacopts br=%abrate%:mpeg=4:object=2 -x264encopts bitrate=%vbrate%:level_idc=21:bframes=3:threads=0:frameref=2:nopsnr:nossim%PASS%
    Audio delay setting included from your next post
    An update to CDM which will solve audio sync problems has been promised by Fernando in other threads - perhaps waiting a few days will save you tearing your hair out...
     
    Last edited: Jan 3, 2009
  15. hobbes80

    hobbes80 Member

    Had this problem too with the PS3. Was quite frustrated until I found this thread. Read the entire thing... the following setting worked perfectly for SinCity_Recut... I can now watch it on the PS3, hosted by my Twonky Media Manager Server with no audio delay. Before, I had it regardless of the quality, now I can watch it in great quality, and matching sound.

    Here is my edited line.
    Code:
    mopts=-audio-preload 0.8 -delay 0.1 -faacopts br=%abrate%:mpeg=4:object=2 -x264encopts
     
  16. Rex 218

    Rex 218 Member

    Having read all the pages a post that is so relevant to my set up that it is just about perfect. I am using a QNAP NAS and streaming onto the PS3 with Twonky Media Server. When I play back no matter wether deinterlaces or set on different quality settings then there is a slight delay in the sound.
    I have tried to change the settings in the Device.ini file but my computer tells me that I do not have permission to save into this file.

    Any help would be appreciated.

    Thanks
     
  17. Danger

    Danger Well-Known Member

    The file is read-only, which is why it's telling you that you don't have permission.

    select devices.ini --> right click --> select properties --> uncheck read only --> apply this folder/file only

    Saving should now be no problem.

    Those are the steps for Vista, XP should be pretty much the same.
     
  18. Rex 218

    Rex 218 Member

    Thanks for the reply. I have managed to be able to save the file by changing permissions and have copied and pasted the line above but keep getting an error when trying to process the file.

    I have checked and rechecked but to no avail. Is it possible for someone to post the complete PS3 section of the devices ini file so I can check how it reads for a 0.2 second delay.

    As a side note I have done some conversions to the Epson P2000 and the audio sync is perfect.
     
  19. Rex 218

    Rex 218 Member

    Here is my adjusted devices ini file

    [PS3 16:9 (AVC/H264 FW >= 1.60)]
    AllowNativeTVResolution=1
    Manufacturer=Sony Playstation 3
    ScreenRatio=16:9
    Res1=320x240
    Res2=640x480
    ResAna1=320x180
    ResAna2=640x360
    ARate=48000
    ABRate=128
    Format=avi
    moac=faac
    movc=x264
    mopts=-audio-preload 0.8 -delay 0.1 -faacopts br=%abrate%:mpeg=4:eek:bject=2 - 264encopts
    vbrate%:level_idc=31:bframes=3:threads=0:frameref=2:nopsnr:nossim%PASS%
    FileType=mp4
    Quality=15
    useMencoder=1
    SubTitle=1
    MaxVBitrate=2500
    AllowChapterFiles=0
    MVolume=10
    Remux=2642MP4
    QualityFactor=130

    and here is the resulting error

    File 2 "C:\Program Files\SlySoft\CloneDVDmobile\apps\mencoder.exe" - -af volume=10 -aspect 16:9 -of avi -oac faac -ovc x264 -audio-preload 0.8 -delay 0.1 -faacopts br=128:mpeg=4:eek:bject=2 - 264encopts -vf scale=720:576,crop=720:576:0:0,harddup -info name="XMEN2_DISC1" -ofps 25 -o "C:\Users\Stephen\Desktop\Converted\New Install and hacked 720 no deinterlace.mp4" 109 TCE

    Encoder output:

    Cannot get Console handle of stdout
    WARNING: OUTPUT FILE FORMAT IS _AVI_. See -of help.
    Try appending the scale filter to your filter list,
    e.g. -vf spp,scale instead of -vf spp.
    x264 [error]: no ratecontrol method specified
    x264_encoder_open failed.
    FATAL: Cannot initialize video driver.

    Any help on delaying the audio would be appreciated as I am pulling my hair out here. I feel very close to a solution but is just out of reach.

    Thanks

    Rex
     
  20. profcolli

    profcolli Well-Known Member

    Your error is simply the result of cut and pasting without using code tags, which introduces erroneous spaces or smilies (check your post). Use this instead:
    Code:
    [PS3 16:9 (AVC/H264 FW >= 1.60)]
    AllowNativeTVResolution=1
    Manufacturer=Sony Playstation 3
    ScreenRatio=16:9
    Res1=320x240
    Res2=640x480
    ResAna1=320x180
    ResAna2=640x360
    ARate=48000
    ABRate=128
    Format=avi
    moac=faac
    movc=x264
    mopts=-audio-preload 0.8 -delay 0.1 -faacopts br=%abrate%:mpeg=4:object=2 -x264encopts bitrate=%vbrate%:level_idc=31:bframes=3:threads=0:frameref=2:nopsnr:nossim%PASS%
    FileType=mp4
    Quality=15
    useMencoder=1
    SubTitle=1
    MaxVBitrate=2500
    AllowChapterFiles=0
    MVolume=10
    Remux=2642MP4
    QualityFactor=130
    You can change the delay (e.g. from 0.1 to 0.2) but you must NOT cut and paste from anything which is not in code tags.
     
    Last edited: Feb 14, 2009