• AnyStream is having some DRM issues currently, Netflix is not available in HD for the time being.
    Situations like this will always happen with AnyStream: streaming providers are continuously improving their countermeasures while we try to catch up, it's an ongoing cat-and-mouse game. Please be patient and don't flood our support or forum with requests, we are working on it 24/7 to get it resolved. Thank you.

ATI driver problems


Well-Known Member
Thread Starter
Jan 28, 2007
I ran into problems using the latest ATI driver, version 7-5_vista32_dd_ccc_enu_46757.exe, with my Sapphire X1950 Pro video card.

At first it seemed to install ok, but then I noticed that that my Samsung 940MW monitor didn't look right. Upon further investigation, I discovered that the resolution had been reduced to below the 1440X900 that I was expecting.

After that, I tried changing the resolution to 1440X900 but all I got was a black screen. I kept trying but eventually I wasn't able to change back from the black screen at all.

Luckily, my motherboard has onboard graphics so I was able to remove the X1950 video card, connect my monitor to the onboard vga, and boot into Vista to remove the ATI driver.

After shutting down, I reinstalled the X1950 and reconnected my monitor to it, then I booted back into Vista and installed the version 7-4_vista32_dd_ccc_enu_44985.exe driver.

Finally, after restart, everything was working again.

It's a difficult problem to fix if you don't have onboard video like I do. For now, I'm sticking to driver version 7-4_vista32_dd_ccc_enu_44985.exe.
I think, it 's due to an bug on catalyst 7.5.

Try to contact ati/amd support.
I think, it 's due to an bug on catalyst 7.5.

Try to contact ati/amd support.

Merci que je jugerai. (I used an online translator so my French may suck)

I contacted them, but no reply as of yet.
Last edited: