AS crashing when selecting to download in AMZ

Discussion in 'AnyStream' started by Shoozleboy, Mar 14, 2021.

  1. Shoozleboy

    Shoozleboy Member

    I tried d/l a rented video from my AMZ account and AS has been crashing between the time I select the green lettered downloadable videos button and bringing up the screen to select the resolution and audio.

    Attached are the three log files generated for these crashes.

    I have been able to d/l rented videos previously just fine. This started after I upgraded to the .3 version just this week. The new provider tab works and does not crash AS. I tried a file from NF and it d/l fine as well. Just seems to happen with AMZ now.

    I did try a different file as well on AMZ and got the same results - crash before selecting the resolution/audio boxes. I attached that log file as well.

    I hope this is enough info and thank you very much for the help!
     

    Attached Files:

  2. walstib

    walstib Well-Known Member

    Somewhat similar - I can consistently crash 1.0.9.3 if I attempt to download a file I have already downloaded, AS alerts me to this, I select “Cancel”, and AS crashes. Will provide log later (not in a place to do so at the moment).
     
  3. Prospere

    Prospere RedFox Development Team

    Thanks for the dump files - looking into it
     
  4. Shoozleboy

    Shoozleboy Member

    I tried logging out and back in today and I still get the crash just after selecting the download button and before the resolution/audio selection pop up.

    I know you guys and gals are extremely busy, just checking to see if any ideas on what it is? Am I doing something wrong or is something I have interfering with it?

    I tried to get the log file like you say in other threads but AS crashes and gives me a dump file. If I restart AS, will the log file still be accessible and any help in your research?

    Thanks again for the assistance.
     
  5. Prospere

    Prospere RedFox Development Team

    We're reworking certain parts of AnyStream at the moment. Those changes/fixes should eliminate a few problems on the way.
     
    Shoozleboy and whatever_gong82 like this.
  6. Shoozleboy

    Shoozleboy Member

    Thanks for the update, Prospere! Appreciate all the hard work!
     
  7. 0x0x0x0x0

    0x0x0x0x0 Well-Known Member

    I'm, too, getting intermittent core dumps on A (about 1 every 8-14 downloads) but not with flix
     

    Attached Files:

  8. Pete

    Pete Forum Admin Staff Member

    Could you please monitor the memory usage of AnyStream during Amazon downloads?
    In case there is a memory leak.

    The crash was - apparently - due to a request for a block of 18MB memory, that failed. And 18MB is not out-of-the-world huge.
     
  9. 0x0x0x0x0

    0x0x0x0x0 Well-Known Member

    Ta, I'll keep a watch and revert back. One thing I noticed (because I've got a 200GB RAM disc SMB-mounted) is that in post-processing network activity happens one way, is AS memory mapping the output file, the lappy that is downloading from A has 8GB RAM (max X240 can cope with) and about 10GB free on the boot volume for swap... The lappy what I use for 'flix has 64GB RAM...
     
  10. 0x0x0x0x0

    0x0x0x0x0 Well-Known Member

    So I've launched the performance monitor... On launch, AS started off with Private Bytes: ~252MB, Working Set: ~246MB, Working Set Private: ~211MB, and Handle Count: 1331.
    After getting 17 episodes of the same season 2.5-3GiB each, (all 'Last') Private Bytes: ~596MB, Working Set: ~564MB, Working Set Private: ~397MB, Handle Count: 1374.

    So while the numbers do accumulate, it doesn't look like it's a haemorrhage that's bleeding out memory, overall system RAM utilisation never went above 4.2GiB...

    Of course, now that I'm pausing to write the values down after every download, and measuring, core dumps are not happening! :ROFLMAO: