anystream muxing glitchy playback w/plex+apple tv4k

Discussion in 'AnyStream' started by Argo F Yourself, May 31, 2021.

  1. every 1080 file I have tried from Amazon going back many versions when direct played to Plex gets part of the way through (70% often) and then starts slowing down.

    setup is a plex server played over wired gigabit to an Apple TV 4K (not the one that just came out this week). No problems direct playing UHD rips at 8x the bitrate on that setup.

    the Netflix and Disney files are fine.

    I've been passing anything that comes out of anystream's amazon provider through a clean up script to re-mux with mkvmerge as a workaround. But during the outage I was using a different tool and found the absence of that step to be beneficial.

    I've seen assorted patch notes about "improved muxing". Is this still an area of active work?
     
  2. DQ

    DQ Well-Known Member

    I play AP titles gotten through AS all the time on Plex. I have one playing now. I don't have issues.

    I would think it's your post process causing this maybe?

    That or maybe Plex is transcoding the titles and maybe crapping out? This might be the case especially if your Plex server is something low powered like a NAS or something to that effect.

    Just some ideas.
     
  3. cartman0208

    cartman0208 Well-Known Member

    I think "direct played" was mentioned ;)

    Do you use embedded subtitles? If so could you try a download without subtitles?
    I just want to con firm my own findings with Plex and AS downloads ...
     
  4. DQ

    DQ Well-Known Member

    Yes, I saw the bit about Direct Play. However, by default that is on "Auto" so transcoding is still possible unless you set it to "Force".
     
  5. Busaman

    Busaman Member

    I have had this issue too where it will play fine and then have problem about 75% into the movie. It seems to be from versions either before or after 1.1.2.0. I have redownloaded them on version 1.1.2.0 and tested them and they are working fine now. If you don't want to redownload them, try turning off Direct Play so it Direct streams and then it plays the movie fine. If you skip around the movie it just takes a moment to buffer when it Direct Streams before it starts where as Direct Play will start immediately. I've been using the Plex or Plex Media Player to test movies to identify if I need to redownload them. If they stutter after 75% into the movie, I know it has this issue.
     
  6. RedFox 1

    RedFox 1 Super Moderator

    Seems to be a Plex issue.
     
    zero269 likes this.
  7. sycor

    sycor Well-Known Member

    I had issues with Plex and mp4 with external srt files from AS for some reason. Just used MKVtoolnix to combine and change to a mkv and have no issues.
     
  8. StevenIvan

    StevenIvan Well-Known Member

    Not that this is a plex forum, but my 2 cents :

    I would check your dashboard when those files are playing and check to see if either your video or audio is transcoding without you knowing.
    I run plex off my Synology unit, and never have playback problems unless i've got 2-3 streams going that are trying to transcode.

    AP files can come through at high MB rates .. so your home network can be in play too, if you are streaming plex over wireless, and your signal degrades - plex will attempt to downsample to preserve your stream (unless you tell it not to.)
     
    zero269 likes this.
  9. coopervid

    coopervid Moderator

    Just my 2 cents: Check if the file plays fine with VLC or MPC. If so the problem is further down the software chain and is not a problem of AnyStream per se.
     
    whatever_gong82, RedFox 1 and zero269 like this.
  10. it isn't transcoding. And it isn't a low powered server. The problems I have are with the file produced by AS, the post-process fixes it. I can confirm this is with embedded subtitles. I'll see what I have that isn't subtitled. Putting this on the anystream forum because anystream does its own muxing and the files it is producing seem to not work well with another popular tool. I have a workaround but I'd prefer a fix.

    For what its worth, the remux I do does also convert the subtitles to SRT (ffmpeg -vcodec:copy -acodec:copy -scodec:srt) so it is possible the problem is with the subtitle track.
     
  11. frejp

    frejp Member

    I had the same problem with an old Sony TV. (SMB connection)
    If I use TMPGEnc MPEG Smart Renderer5 from PAGASYS (Japan) to output the file, the problem does not occur.


    -----------
    In TMPGEnc MPEG Smart Renderer , the "Smart Rendering" function outputs with as little degradation as possible except for the edited portions, minimizing the encoding area and achieving ultra-fast and quick output.
     
    Last edited: Jun 1, 2021
  12. cartman0208

    cartman0208 Well-Known Member

    Thanks, that matches my observations ... and the way I work around it
    Although the AS subtitle format TTXT (tx3g) is supported with MP4, Plex and some other devices seem to have issues with it.
    I'm not sure if there is a supported way of muxing SRT (Subrip or WebVTT) subtitles into MP4, but that is something, the developers have to decide.
    And since it was already stated, that there will be no MKV Output from AS, I will stick with my postprocessing... I need it anyway to insert the second audio stream :)
     
  13. BALLOFIRON

    BALLOFIRON Well-Known Member

    im sorry it is not a plex issue but i do confirm 1.1.2.0 is better at this stage with plex and samsung tv's playback
     
  14. DQ

    DQ Well-Known Member

    As I mentioned earlier I have no such issues. HOWEVER, I DO NOT use subtitles either because they are always a pain when I try.

    So my situation does not compare to yours in that regard.
     
    BALLOFIRON likes this.
  15. BALLOFIRON

    BALLOFIRON Well-Known Member

    sub or none same thing but like you said not everyone is affected. vlc and other player are great. but other like samsung tv and plex payback is uncontrollable but users preferences sadly
     
  16. DQ

    DQ Well-Known Member

    So I am not using subtitles and I use Plex on Roku for playback. One TV is TCL the other is a Samsung. I have not had any such issues.

    I have Direct Play set to "Auto" and not force. And I have watched Plex do it's thing many times for the heck of it. I notice that it very often transcodes the MP4 files but not always. That last part I am not sure how that compares to anyone else as I have only watched my own setup of course.

    My point to saying all that is with Plex there is a lot more going on in the background than we typically realize because it normally handles it so well we never have to bother with it. Keyword there is "normally". ;)

    Not saying this is a Plex or an AS issue. It might not be anything more than just how one is handling the other and a simple tweak could fix that. I have had a number of "issues" with my setup where something would have too be dinked with so it all functions as I want it to in my particular situation.
     
  17. jbrisbin

    jbrisbin Well-Known Member

    I, too, found that downloaded streams from AS do not play reliably on any Plex clients (except, possibly the computer based, Windows/Mac ones). I saw stalling, particularly when played remotely (direct) and usually at about the 40 minute point, in my case.
    Similar problems have also occurred with MakeMKV output, so there is little question that whatever issue trips up Plex it is a Plex sensitivity that not all decoders share. That doesn't really place the blame nor does it need to be placed.
    Remuxing with MKV Toolnix always addresses the problem.
    Since I re-encode into HEVC, with Handbrake, the problem is also resolved.
    Plex clients don't seem to support ASS subs well, if at all. Once the files are re-encoded I convert the subs to SRT form using a BASH/Cygwin script.
    This sub conversion also includes a remux (with MKV Toolnix), so it should resolve both issues, even without the re-encode. Edit: The script accepts only .mkv files, so my speculation above about a single pass solution was over-optimistic. mp4 input file handling might be added, but the output will be .mkv

    The script is 'works great for me' quality (which means it will probably fail for anyone else), but I will try to make it available to the daring later today (US time) in a separate post. The script handles all files from the current directory downward, makes backups before making changes final and performs well on a computer with fast access to the video storage, since it is always I/O bound.
     
    Last edited: Jun 1, 2021
  18. Ch3vr0n

    Ch3vr0n Translator NL

    They play just fine streaming from my PC in the upstairs office, to my TV on chromecast with android TV, and they did just as well on my chromecast ultra.
     
  19. Steve55

    Steve55 Well-Known Member

    I'm not an expert on Plex, but this type of thing might be caused by the Plex server rendering the subs into video, instead of as a separate text stream for the client to interpret
     
  20. RedFox 1

    RedFox 1 Super Moderator

    I think you may be right, but I do not know anything about Plex, so its just a guess.