AnyStream 1.1.0.2 Incomplete Netflix subtitles

Discussion in 'AnyStream' started by 4lfred, Apr 9, 2021.

  1. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Well anystream only downloads what the provider sends it. There's nothing it can do about that. I've encountered this a few times myself, but the specific subtitle lines were missing in the prime video app for that title as well. Meaning they were already missing from the start, anystream didn't remove them. That said, as already stated, if you have a problem provide logfiles from the most recent version. In your case your OP has logs from 1102 but not from any of the subsequent versions.
     
  2. Wowfunhappy

    Wowfunhappy Member

    Hi, I'm also having issues with Anystream only downloading a portion of subtitles, with many lines missing. I'm in the latest version so I've attached a log.

    Thanks!
     

    Attached Files:

  3. DeepSpace

    DeepSpace Well-Known Member

  4. Wowfunhappy

    Wowfunhappy Member

    Nope, I mean it downloads the language, and some lines of dialog even appear, but others (a majority) are missing! Just as in the OP.

    And they appear when I stream the video on Netflix.
     
    4lfred likes this.
  5. Gummigutta

    Gummigutta Translator (sv)

    1. You might be downloading the forced version of the subs if you miss some strings.
    2. How do you play the files?
     
  6. Wowfunhappy

    Wowfunhappy Member

    I'm playing in QuickTime, which I'm well aware often has problems with subtitles, (more specifically, it's extremely picky about the format), but that's not the problem here! I actually extracted the subtitle files with ffmpeg and opened them in a text editor, and the lines are clearly missing. I checked both the forced and non-forced streams.
     
  7. Gummigutta

    Gummigutta Translator (sv)

  8. Gummigutta

    Gummigutta Translator (sv)

    Downloaded Great Pretender season 1 episode 1 with your selected subs and played it in MPC-BE and no problems.

    From Your log:

    00:04:14.254 - [Debug] [download config netflix] Selected subtitle: en, "English (forced)"
    00:04:14.254 - [Debug] [download config netflix] Selected subtitle: en, "English"
    00:04:14.290 - [Notice] [Mux] Available disk space check ... OK.
    00:04:14.294 - [Notice] [Mux] Selected subtitles format: embedded

    The English (forced) subs are working well if You download the English sound stream. The episode is a mix of japaneese and english and is kicking in when they speak Japaneese and is not showing up when they speak English.

    The "English" sub stream is showing up as it should for every part of the episode - even if they speak English at the time.

    :)
     
    RedFox 1 likes this.
  9. SAF

    SAF Well-Known Member

    MPC-BE is a great player. Maybe time to switch.. Just saying..:cautious:
     
    Gummigutta likes this.
  10. yrgnd

    yrgnd Well-Known Member

    No, I've never had issues of any sort with subs on any version of AS.

    I would suggest setting AS to download the subtitles as external and see if those have the same problem. The only issue I might guess is during muxing in post processing. Or perhaps as mentioned above, you're seeing the forced English subtitles which only appear on the screen when a non-English language is being spoken. If this is the case, simply deselect the forced subtitles option and you should get complete subtitles. If you were selecting both the forced and [CC] subtitles, they will both be included in the download, but you would need to select the second subtitle option in the player.

    I use Plex media server to watch videos which also gives you the ability to search for and apply subtitles while watching the movie. No external searching and downloading required.
     
    Last edited: May 1, 2021 at 11:57 PM
  11. 4lfred

    4lfred Active Member

    @Gummigutta not a player problem my friend, i download some movies with AS and subtitle have 700 lines, download with "shit" programs or direct from web browser and have 900 lines like example, not a region problem or player problem AS some times lose many lines, my bad i dont save any logs, not sure if the problem appear in the logs because i have this problem from months ago, send logs and problem continue, i have complaints with missing lines in subtitles from AMZ NF and D+ all

    AS not download what the provider sends it or my problem must be same in web browser and other program
     
  12. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    There's also a known issue that's being worked on that for some languages the subtitles arent being sent as a text based stream, but that the subtitles are image based (like they are for blu-ray titles). AnyStream is currently not capable of properly handling those and this might be the case here. Perhaps @Prospere can confirm this. I do know a fix is in the works to properly handle image based subtitle streams.
     
    DeepSpace likes this.
  13. Gummigutta

    Gummigutta Translator (sv)

    Tried to play the downloaded .mp4 file for Great Pretender season 1 episode 1 in QuickTime and it gave me error 1002. :(
     
  14. RedFox 1

    RedFox 1 Super Moderator

    Not sure but error 1002 is usually a Permissions error.
     
    Gummigutta likes this.
  15. yrgnd

    yrgnd Well-Known Member

    Not to be a pain, but IIRC Quicktime hasn't been supported nor developed by Apple in several years now. It was never a good player to begin with, IMO.
     
    Gummigutta and whatever_gong82 like this.
  16. RedFox 1

    RedFox 1 Super Moderator

    I agree wholeheartedly. Not that me agreeing with means much, but I do.:whistle:
     
  17. 4lfred

    4lfred Active Member

    well i discover the problem with missing subtitles or not :ROFLMAO: when download with AS all good subtitle are complete, but for personal use i allways change the file to ANSI no problem huntill here, when i open the .srt with subtitle workshop, alot of lines dissapear, if open with subtitle edit all lines are ok, make some changes and save give and strange warning, press ok and no problem subtitle work perfect now, can open with subtitle workshop and no lines dissapear... it seems that certain lines are not encoded correctly.

    Check, open the subtitle with note pad 1371 lines and next with subtitle workshop 1150 lines alot dissapear, open with subtitle edit and only save dont make any change, next open with subtitle workshop not lines dissapear fucking strange hope you can discover the problem :thankyou:
     

    Attached Files:

    • 2.rar
      File size:
      34.8 KB
      Views:
      0
    • sss.png
      sss.png
      File size:
      63.1 KB
      Views:
      6
  18. zanetti

    zanetti Active Member

    lol. was just thinking of opening a thread about weird subtitle issues with prime. ive noticed that sometimes lines are missing, and thats the only problem ive had. i thought at first that subtitle workshop on win10 is all messed up and deleting lines which it shouldnt when using fix errors option. am still not sure if thats the case. ive just downloaded sth from amazon and ran the sub through sw, saved the sub, opened the movie and stumbled upon a missing line. then ive tried downloading subtitles in my browser using the greasemonkey script and that file was like 20kb larger. then i remembered that ive already ran sub that i got via AS through sw and it has deleted a bunch of HI lines so that might be the real reason sub from AS is 20kb smaller. now i see this thread and starting to think that its not sw's fault. will try compare things later on, as im still not sure whether its an AS problem or sw's problem. btw, latest version of AS.
     
  19. RedFox 1

    RedFox 1 Super Moderator

    Everyone understands the developers have seen your posts, they are trying to resolve your issues, maybe, and I say maybe in the next version it will be done. I can't promise anything, but continually posting about it is not going to get it fixed any faster.
     
    whatever_gong82 likes this.