AnyDVD, VLC, UniConverter and The Da Vinci Code DVD

Discussion in 'AnyDVD HD (DVD issues)' started by Paddy Coleman, Feb 20, 2021.

  1. Paddy Coleman

    Paddy Coleman New Member

    Hi Folks,

    I have working on creating a NAS media server and copying/converting my DVD/Blu-Ray collection to mp4 files. In the main, this has worked fine using primarily Wondershare UniConverter and VLC.

    However, I have hit problems with a few DVDs where I assume they have copy protection. One such DVD is The Da Vinci Code. After doing some research, it seemed a number of people were recommending AnyDVD so I have just downloaded a trial version to give it a go.

    When I place The Da Vinci Code DVD in to my drive, after a while AnyDVD reports:

    Summary for drive D: (AnyDVD HD 8.5.2.0, BDPHash.bin 20-03-11)
    ASUS BC-12D2HT 3.01
    Drive (Hardware) Region: 2
    Current profile: DVD-ROM
    Media is a DVD.
    Booktype: dvd-rom (version 1), Layers: 2 (opposite)
    Size of first Layer: 2084960 sectors (4072 MBytes)
    Total size: 4169920 sectors (8144 MBytes)

    Video DVD (or CD) label: DAVINCI_CODE
    Media is CSS protected!
    Media is locked to region(s): 2 4 5!
    Video Standard: PAL

    Using local database!
    Found & removed structural copy protection!
    Found & removed invalid cell pieces!
    Found & removed invalid VOBUs!
    RCE protection not found.
    UDF filesystem patched!
    Autorun not found on Video DVD.
    Removed CSS copy protection!
    Found & removed 20 potential bad sector protections!
    Emulating RPC-2 drive with region 2!

    However, when I load UniConverter and try to add the DVD so I can convert it the program just crashes and closes down. VLC allows me to play the DVD (as it did before) but if I attempt to convert the main feature to mp4 then the language and subtitle options are ignored.

    In short, I do no seem to be any further forward by having AnyDVD?

    Hopefully I am missing something and not using AnyDVD correctly - can someone please advise?

    My setup is:

    Intel based (quad core) HP laptop
    16GB RAM
    512GB SSD
    Windows 10 64Bit - fully updated
    VLC, UniConverter are fully updated
    AnyDVD version is 8.5.2.0

    Thank you for your help.

    Kind regards

    Paddy
    UK
     
  2. whatever_gong82

    whatever_gong82 Well-Known Member

    Did you check to see if you set up your DVD drive before using AnyDVD? It's recommended to set your DVD drive after you turn off AnyDVD. Once you do that, you can then turn black on AnyDVD and then do whatever you want.

    I'd right click the AnyDVD icon and rip your DVD to the hard drive, and then use whatever software you have to convert your DVD.

    The instructions on how to do that is to right click the AnyDVD icon, and go to the Help section.

    :)
     
    Paddy Coleman likes this.
  3. James

    James Redfox Development Team Staff Member

    He did: Drive (Hardware) Region: 2
     
  4. James

    James Redfox Development Team Staff Member

    Posting an AnyDVD logfile is always a good idea for troubleshooting. But "rip to folder" first is a good idea with heavily protected discs like this.
     
  5. Paddy Coleman

    Paddy Coleman New Member

    Hi @whatever_gong82 and @James

    Thank you both for your replies. I have indeed set the region of my drive to 2 as you have indicated.

    I have also run AnyDVD Ripper and copied the DVD to my hard disk. I then tried to convert this version of the DVD using UniConverter but game the same result?

    Happy to post an AnyDVD logfile - can you point me in the right direction on how to generate/find one?

    Many thanks

    Paddy
    UK
     
    whatever_gong82 likes this.
  6. mmdavis

    mmdavis Well-Known Member

    If you were able to rip the disc to your hard drive, then the disc is fine and the rip is fine. Can you play the rip and does it play correctly? If so, then the problem lies in your conversion software. That being said:

    From the Please read this before you post Sticky, #5:
     
  7. Paddy Coleman

    Paddy Coleman New Member

    Hi @James , @whatever_gong82 and @mmdavis

    Thank you for all your help on this one so far. I have attached a LOG file from The Da Vinci Code DVD.

    The copied DVD creates a folder on my hard drive that contains:

    DAVINCI_CODE
    VIDEO_TS
    DAVINCI_CODE.dvdid.xml


    Within the VIDEO_TS folder there are:

    VIDEO_TS.BUP
    VTS_01_0.BUP
    to VTS_16_0.BUP
    VIDEO_TS.IFO
    VTS_01_0.IFO
    to VTS_16_0.IFO
    VTS_01_0.VOB to VTS_16_0.VOB

    UniConverter simply crashes when it tries to read the DAVINCI_CODE folder.

    Any ideas?

    Many thanks

    Paddy
    UK
     

    Attached Files:

    whatever_gong82 likes this.
  8. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Try CloneDVD Mobile (although outdated and sometimes crashes too) it may work.
     
    Paddy Coleman likes this.
  9. mmdavis

    mmdavis Well-Known Member

    You never said whether you could play the rip. Point MPC-HD or something similar to the VIDEO_TS.IFO file in the VIDEO_TS folder and see if the movie plays correctly. If so, then the issue is with your conversion software that just doesn't like the file. You might try CloneDVDmobile and see if it works with it, or possibly Handbrake.
     
    Paddy Coleman likes this.
  10. Paddy Coleman

    Paddy Coleman New Member

    Hi Folks,

    Thank you for all your help. I purchased a copy of Leawo DVD Ripper and this worked perfectly so it looks like it is VLC and UniConverter.

    Kind regards

    Paddy
    UK
     
    marlowe likes this.