AnyDVD causing disc recognition & autoplay to stop working in Windows Vista

Discussion in 'AnyDVD HD (DVD issues)' started by d.chatten, Feb 11, 2007.

  1. d.chatten

    d.chatten Well-Known Member

    When AnyDVD 6.1.1.4 is disabled i get the below in "Computer" (Windows Vista HP Retail), movie and data CDs/DVDs both get recognized, play and autorun without any problems.

    [​IMG]

    When AnyDVD 6.1.1.4 is enabled, instead of the above i get the below in "Computer" (Windows Vista HP Retail), movie and data CDs/DVDs don't get recognized and won't play or autorun at all.

    [​IMG]

    This happens with my SONY DVD-RW DRU-800A (FW KY06) and also with my Plextor DVD-ROM PX-130A (FW 1.03).

    I have tested this in all ways possible, eg: unistalled/reinstalled AnyDVD, uninstalled/reinstalled both drives, done a clean install of Windows Vista and only installed AnyDVD 6.1.1.4, but, the issue still persists.

    This issue must be a bug with AnyDVD because as i said, this also happens on a clean install of Vista with only AnyDVD installed.

    Thanks!
     
  2. James

    James Redfox Development Team Staff Member

    Weird - again. I am not able to reproduce this, at least not with NEC & Plextor drives. I will try to dig out a SONY DVD-RW DRU-800A and try it.
     
  3. d.chatten

    d.chatten Well-Known Member

    Thanks James for the quick response, the southbridge chipset on the motherboard is the Intel ICH7, if this is of any use.
     
  4. James

    James Redfox Development Team Staff Member

    Standard Vista drivers?
     
  5. rsundstrom

    rsundstrom New Member

    Same problem - with Windows XP Pro

    I have the same symptoms with a Sony DRU800A - KY06 under Windows XP Pro SP2. Autoplay and disc recognition are erratic. Often 1 disc will be recognized, then subsequent discs will not. The non-recognition will then persist through reboots.

    The only way to resolve this seems to be to uninstall AnyDVD and reboot.

    Any solution to this?
     
  6. d.chatten

    d.chatten Well-Known Member

    Yes, i'm using standard Vista drivers, i have also tested with the intel inf drivers for the ICH7 southbridge.
     
  7. calcu007

    calcu007 Well-Known Member

    Sometime this AUTOPLAY problem is caused because the entry in te registry associated os removed or corrupted. There is a tool for XP to resolve this. I dont have a llink to download it, but I can send you t your email
     
  8. James

    James Redfox Development Team Staff Member

    Are you sure this is a Vista related problem?
    I checked, I don't have DRU-800 in the storage, only a DRU-820A. The Plextor DVD-ROM, is this the Pioneer OEM'ed DVD drive? If yes, it is a very broken device. It reads garbage at the layer break position and has severe diskchange recognition problems (implementation of TestUnitReady command was broken).

    EDIT: Regarding TestUnitReady, maybe I confuse this with the Pioneer Slot-In drive, it has been a while... But I am sure about the layer break problem.

    I believe we have this drive somewhere (there is a special workaround in CloneDVD because of the layer break problem), I'll check.
     
  9. d.chatten

    d.chatten Well-Known Member

    I'm not shure about the Plextor drive being an OEM'ed Pioneer, as for it being a Vista issue, i think it is a Vista issue because everything seemed ok under XP Pro, but, the thing is on the machine in question i never tested the DRU-800A in XP Pro with version 6.1.1.4, on my second machine with XP Pro and two Plextor PX-716A's everthing runs as it should with AnyDVD 6.1.1.4 and this motherboard has the same intel ICH7 chipset.
     
    Last edited: Feb 12, 2007
  10. rsundstrom

    rsundstrom New Member

    Maybe a DRU800a problem?

    I did a bit more digging, removing AnyDVD from my XP Pro system and retrying a sequence of disks that gave me problems before. In this case I still ran into a disk change problem, even with AnyDVD uninstalled.

    I swapped out the DRU800a for a DRU710a and ran the same disks again. This time the system read every disk without problem.

    Next, I reinstalled AnyDVD, and re-read each disk - no problem.

    Finally, the DRU800a was reconnected, and the disk change problem resurfaced.

    I tried some of the downlevel firmware versions (KY05, KY03) with the same results.

    By the way the LiteON SOHW-1693S is the drive behind the DRU-800A. I tried a couple of the patched versions of the LiteON firmware (e.g.: KC4B) with no improvement.

    I'm chalking this up to a problem with the DRU800a.
     
  11. d.chatten

    d.chatten Well-Known Member

    @James, i seem to have found what was causing my problem, i said before that i had tried this on a fresh install of Vista, i did, but, i had installed two gadgets into the sidebar and i found that if i disable the side bar and stoped it from starting with Windows everything seemed worked again, anyway i uninstalled the gadgets that i had installed, "which had nothing at all to do with the reading and writing af disc's" (strange), i then used CCleaner to clean out the crap that was left over from the removed gadgets, i then enabled the sidebar to start with Windows, restarted my system and this time everything was ok.

    My SONY DRU-800A still isn't happy with Vista but at least now i know what the problem was.

    There was another strange problem that i found with all of the disc writing software that i have and the gadgets that i had installed, i found that if i tried to read a disc with any of the writing software with the sidebar enabled i would get an error aying that it can't get exclusive access to the drive, or, it would simply just sit there doing nothing, as soon as i had performed the above, removed the gadgets and cleaned the system, everything was fine.

    Thanks for your help and i'm happy to say that this issue has nothing what so ever to do with SlySoft products.
     
  12. James

    James Redfox Development Team Staff Member

    Just dump that stupid DRM-laden Vista and use XP instead. :D
    http://www.forbes.com/security/2007/02/10/microsoft-vista-drm-tech-security-cz_bs_0212vista.html

    BTW, I still cannot reproduce the autostart problem with CloneCD & AnyDVD. And the keycode problems some users are having. :(
     
  13. Charlie

    Charlie Well-Known Member

    I'm doing allot of work on vista at school and you might need to check the security settings on allowed and disallowed programs. There is some other sections that need this setting as well but just started on vista yesterday.
     
  14. d.chatten

    d.chatten Well-Known Member

    The autostart issue was resolved after i had performed the above :), but the SONY drive still has issues reading disc's with Vista.

    I don't have any problems with my keycodes but then again i allways use the registration tool supplied within the product, eg: Register AnyDVD in the AnyDVD directory, if people are double clicking the registration key or using regedit to import the keycode they may not have these issues, they should use the recomended tool supplied, allways works for me :)