AnyDVD Beta & PowerDVD Ultra 7.3 3319a

Discussion in 'AnyDVD HD (Blu-ray issues)' started by RazorWing, Oct 28, 2007.

  1. RazorWing

    RazorWing Member

    I have just bought AnyDVD HD, after previously using the trial to test if Ice Age 2 Blu-Ray worked, it worked well. At the time, i used both an older version of AnyDVD HD and PowerDVD Ultra.

    I am now currently using the latest version of both AnyDVD HD and PowerDVD Ultra due to the fact that a new blu-ray movie turned up today which has the BD+ on it, the movie is called "Meet the Robinsons" by Disney.

    Now i know that AnyDVD HD works with it but PowerDVD Ultra doesnt seem to understand the new region encoding. Currently there is not update which i can see for PowerDVD.

    AnyDVD HD
    Summary for drive G: (AnyDVD
    PIONEER BD-ROMBDC-202 1.01 07/05/15PIONEER
    Drive (Hardware) Region: 0 (not set!)
    Media is a Blu-Ray disc.
    Total size: 20440064 sectors (39922 MBytes)
    Video Blu-Ray label: MEET_ROBINSONS
    Media is AACS protected!
    Removed AACS copy protection!
    Blu-ray disc appears to be locked to Region A!
    Blu-Ray disc adjusted to Region A!
    PowerDVD Ultra
    Player Information:
      Player Region Code: Not Specified
      Current Drive: G:
      Title Region Code: Not Available
    Audio Attributes: Not Available
    Hardware Information:
      Processor: AMD Athlon(tm) 64 X2 Dual Core Processor 4800+ running at 2403 MHz
      3DNow! Technology:  In Use
      Enhanced 3DNow! Technology:  In Use
      3DNow! Professional Technology:  In Use
      IA MMX Technology:  In Use
      IA Streaming SIMD Extensions:  In Use
      IA SSE 2:  In Use
      Video Accelerator:  DirectX VA (not in use)
      Multispeaker Audio Device:  SoundMAX HD Audio (not in use)
      SPDIF Output Device:  SoundMAX HD Audio (not in use)
    Now i have tested AnyDVD HD with WinDVD BD version and it works although there is alot of jurking on video and audio.

    When i attempt to play my new blu-ray movie on PowerDVD Ultra its prompts me to update saying "A critical componet of the player requires periodic updates. New movies could fail to play if the critical update is not updated promptly. Would you like to update now?"

    You click yes, says update is successful and when you click play again, its crashes and goes into not responding.

    Just wondered if anyone has the same issue with the latest versions of these software and with BD+ movies.
  2. kdssrugby

    kdssrugby Well-Known Member

    I an assure you that the problem is not Powerdvd. I just watched it and it works fine without Anydvd hd enabled so I would assume it is skysoft hasn t cracked the encryption yet. Is your system fully HDCP? Any I do not believe that Meet the Robinsons is BD+, so far only FOX movies have that.
  3. RazorWing

    RazorWing Member

    I dont understand it then, my drive is non-region encoded, so the software like powerdvd and windvd determine the region, I have then both set to region A. I got a HDCP gfx card monitor is not, so i use AnyDVD in order to remove that. It plays on WinDVD but not on powerdvd, not sure why. It keeps wanting me to update, i say yes, its says it has updated successful and i go to play the movie again and it crashes.
  4. Adbear

    Adbear Well-Known Member

    Meet the Robinsons doesn't use BD+. Have you tried playing it in Powerdvd without Anydvd running? Mine works fine as long as Anydvd is switched off, or if I play it from the rip to the harddrive
  5. RazorWing

    RazorWing Member

    With AnyDVD disabled, it plays the movie for a few seconds then the HDCP error appears as my monitor doesnt support it. Is there any way to solve this?
  6. kdssrugby

    kdssrugby Well-Known Member

    Unfortunately you will have to wait until slysoft gets around to cracking the encryption on the disc. That or you can just spend a small fortune upgrading your system to HDCP compatibility. It s hard to say when Slysoft will get around to cracking this movie, it s likely they will devote most of their energy to cracking BD+ for the near future.
  7. RazorWing

    RazorWing Member

    Well it seems weird that i have a Samsung 1080P LCD 40" TV, i have a Nvidia 7950 X2 both with HDCP but the only thing which seems to be the problem is the cable maybe, i got a DVI to HDMI, not sure if that is why its failing with HDCP.
  8. James

    James Redfox Development Team Staff Member

    No, the encryption is cracked if AnyDVD says so. I suspect PowerDVD to be the problem. Try to rip the files and play from Harddisk (play from folder).
  9. RazorWing

    RazorWing Member

    Thank you james and everyone else, i thought PowerDVD might off been the problem, i guess i will have to wait until PowerDVD releases a new patch to fix the problem, for the time being i guess i just have to rip it to my Hard Drive. BTW, i think the problem i had with WinDVD jittering while playing the movie is related to AnyDVD, with AnyDVD turned on to get rid of the HDCP, the Hard Drive seems to go mental which i presume is a process used to stream and decode the content to the hard drive, just thought i throw that out there too, just something i noticed :)
  10. James

    James Redfox Development Team Staff Member

    Hmm, maybe latest version of PowerDVD checks, if the disc inserted is a (re)writable.
    Remember: One of the many reasons *not* to buy into Blu-ray: AACS is mandatory on BD-ROM discs!

    I can only repeat myself again and again: DO NOT BUY BLU-RAY! Do not invest in technology which throws your fair use rights out of the window! Watch HD DVDs instead! :D

    Anyway, I'll investigate, and I am confident to offer a solution. But it'll take a little time....
  11. James

    James Redfox Development Team Staff Member

    The current solution is either to

    1.) Use PowerDVD 3104
    2.) rip to hd first - what a waste of time & space
    3.) Try to install PowerDVD 3104 & 3319 simultaneously (yes, this should be possible), by installing 3104, making a copy of the PowerDVD directory, then install the 3319 update.
  12. UK.MarkyMark

    UK.MarkyMark Member

    James is correct. The problem is definitely with later versions than 3104 of PowerDVD. I have tested this a lot. I found that I needed to uninstall PowerDVD including deleting all left over files in Application Data in XP or Program Data in Vista and also both cyberlink reg entries under local_machine\software and current_user\software. I can now watch blu-ray from disc on a non-HDCP display again with 3104 installed.
  13. RazorWing

    RazorWing Member

    Works perfect, that you James and UK.MarkyMark :)

    Just installed an older version of PowerDVD Ultra, i think its 7.2 and i am able to play the movie without any problems even with AnyDVD running :)

    Thank you very, very much :)
  14. FTX

    FTX Active Member

    Or use something thatn doesn't give problems. DigitalTheater is working good for me.

  15. Stormlord

    Stormlord Well-Known Member


    the problem has nothing to do with the discs being writeable or rewriteable IMHO, since I have the problem too and I'm not working with copies at all. I can't play any of my original blu ray movies with powerdvd 3319a (full version) and they played just fine with the 3104a release (and still do when I revert back to that). Of note is that: HD DVDs will work fine and so will the blu ray discs once they are played from harddisc.

    Of note:
    - I have two screens connected, one is 2560x1600 screen resolution (30" Dell), the other is an HD Ready plasma. Both are connected via DVI (the plasma with a DVI to HDMI cable) of my 8800gtx card
    - my default desktop resolution is 2560x1600, i.o.w. powerdvd will not work with high def content if anyDVD HD is disabeled since that is dual link and HDCP does not support dual link (they should kill the stupid **** who invented the HDCP protocol and made it to only support single link).
    - both my player and drive as well as any dvd are currently set to region A for playback of bluray (I only have region A blu ray titles, while I actually live in region B)
    Last edited by a moderator: Oct 29, 2007
  16. 2mellow

    2mellow Member

    Problem is not with PowerDVD but with AnyDVD

    I also have updated my PowerDVD to 3119a, and I can no longer play blu-ray discs with anydvd running. This is for both older and new Blu-ray discs. If I close anydvd, my Blu-ray discs play fine. Going to an older version of PowerDVD is not really an option, because I want to play my BD+ discs(Day After Tomorrow). All the HD-DVD's still work great with anydvd and PowerDVD 3119a, even the latest ones (Transformers).

    Slysoft, could you fix this please??
    Reply With Quote
  17. RazorWing

    RazorWing Member

    Thats sort of the problem i am having, the older version of powerdvd works fine, the newer version doesnt. I also have a HDTV, i use my Nvidia 7950GTX X2 which has HDCP to connect to my TV which is also HDCP, the problem lies within the lead, it seems the HDTV is not kept through the lead as i also have a DVI to HDMI. Seems strange that it doesnt keep HDCP.
  18. 2mellow

    2mellow Member

    Iso's from HD

    I play from the hard drive by mounting an iso image, and it plays back fine with 3119a. What it will not do is play any Blu-ray disc if anydvd is running. I don't know the why, but it definitely doesn't seem to be a PowerDVD problem.
  19. UK.MarkyMark

    UK.MarkyMark Member

    Hi StormLord.
    I think the idea that James is trying to put across is that the new revisions of PowerDVD maybe checking the disc for AACS as it would have to be present as per BD specs. As AnyDVD gets around the AACS then maybe PowerDVD is seeing the disc as a BD-R/RE so does not playback the content because AACS is not present. If the content is played back from a hard drive then the BD spec is not relevant so PowerDVD does not check for AACS. Does that sound right James?
  20. James

    James Redfox Development Team Staff Member

    Almost. Haven't verified it yet, but PowerDVD may see the disc as a BD-ROM (*not* a BD-R/RE). As the bastards at the BDA have decided to make AACS mandatory with BD-ROM, a BD-ROM without AACS cannot exist per definition.

    But I haven't verified this yet. If my theory is right, there are some possible solutions...