Any Support For Sandisk Sansa View Players?

Discussion in 'CloneDVD mobile' started by bannontj, Dec 6, 2007.

  1. bannontj

    bannontj New Member

    Anyone have sucess with which file format to use that after converted using the Sansa media converter will play a movie properly? It would be nice if Clone DVD Mobile would simply output to the Sansa format... Anyone got anything on this? thanks,
     
  2. Geoff1968

    Geoff1968 New Member

    I converted to DivX, then converted again using the sansa media converter but when playing; the playback was poor; jerky and out of sync with audio.
    I've given up trying.
     
  3. tomparker

    tomparker New Member

    I've targeted just about every mobile player selection that produces an MP4 file. None of them work. Unfortunately I paid for the software and still have to use the Sansa Media Converter.

    Another piece of software that does work is "Any Video Converter", a free download.

    I hope that SlySoft reads this thread and adds support for the Sansa View.
     
  4. rrempel

    rrempel New Member

    In the folder that you installed CloneDVDmobile (C:\Program Files\SlySoft\CloneDVDmobile perhaps) there is a file Devices.ini.
    Make a backup copy of it, then open the original and add the following entry.
    It likely isn't optimal, but it represents settings that work for my son's 8GB View.

    Save the changes, start CloneDVDmobile, and look down to "Sandisk" on the list of devices, select "Sansa View" and give it a shot.

    If anyone has better settings, please post!

    [Sansa View]
    Manufacturer=Sandisk
    ScreenRatio=15:11
    Res1=320x240
    ResAna1=320x180
    ARate=11025
    ABRate=128
    Format=lavf
    lavfopts=format=mp4
    FileType=mp4
    NTSCFrameRate1=29.97
    NTSCFrameRateDeinterlace1=29.97
    Quality=23
    lavcopts=aglobal=1:vglobal=1:vcodec=mpeg4:acodec=libfaac
    MVolume=10
    useMencoder=1
    SubTitle=1
    MaxVBitrate=512
     
  5. Whoodie

    Whoodie New Member

    rrempel, The setting you have provided generated an error. I am using the trial version of the software as I have not found an encoder that works to my liking yet for my 16GB View. I have purchased other slysoft products and have been very pleased, but until I know this works with the View, my money stays with me.
     
  6. gwolfman

    gwolfman Well-Known Member

    Have you tested this? I have a friend that's been looking for a good converter for his sansa, I'll try this out.
     
  7. Whoodie

    Whoodie New Member

    Yeah I tried it and I got an error

    "File 2 "C:\Program Files\SlySoft\CloneDVDmobile\apps\mencoder.exe" - -srate 11025 -af volume=10 -aspect 16:9 -of lavf -lavfopts format=mp4 -oac lavc -ovc lavc -lavcopts aglobal=1:vglobal=1:vcodec=mpeg4:acodec=l ibfaac:vbitrate=388:abitrate=128 -vf pp=fd,scale=320:180,harddup -info name="DusttoGlory" -ofps 30000/1001 -o "C:\Documents and Settings\Whoodie.WHOODIEXP32\Desktop\DusttoGlory.mp4" 109 TCE

    Encoder output:

    Try appending the scale filter to your filter list,
    e.g. -vf spp,scale instead of -vf spp.
    Audio LAVC, couldn't find encoder for codec l."

    Whatever all that means :confused:
     
  8. profcolli

    profcolli Well-Known Member

    Problem solved

    Your problem is that a space has been inserted into one of the options posted by rrempel which has caused CloneDVDMobile to give the error (the space in the word "l ibfaac" should not be there, so it thinks the codec name is "l" instead of libfaac).

    Change the line in the devices.ini file from
    lavcopts=aglobal=1:vglobal=1:vcodec=mpeg4:acodec=l ibfaac
    to remove the space in "l ibfaac"

    The problem is caused by the way that the forum displays the message - the wraparound text in the reply box makes a space appear when it was not there originally. I tried to post the correct line but it does the same thing (makes a space appear - see example below - there is NO space but one appears)
    lavcopts=aglobal=1:vglobal=1:vcodec=mpeg4:acodec=libfaac

    The correct file is ATTACHED to this post.
     

    Attached Files:

    Last edited: Dec 29, 2007
  9. Whoodie

    Whoodie New Member

    Ok I tried the attached settings and I did not get an error, however the files when transferred did not play, "unsupported...." it says. I hope that I am just doing something wrong. Any ideas?
     
  10. MrTimmy

    MrTimmy New Member

    I tried it too and then had to use Sandisk Media Converter to get things to work. Double conversion I guess.

    The player that I used is the Sansa e250 and it seems to want MOV files. When I converted from MP4 (CloneDVDMobile) to MOV via the Sansa Media Converter everything worked just fine.

    What a hassle. It would be nice to go directly from DVD to MOV via CloneDVDMobile.

    Maybe someone else has figured this out?