All of a sudden Game Jackal causing BSOD's

Discussion in 'GameJackal' started by mtimerding, Mar 31, 2008.

  1. mtimerding

    mtimerding Member

    Hello all,

    I am not a very big gamer, but I've been using Game Jackal for a few years now,
    for the couple of games I do have (Far Cry and UT2004) ..... I do this only cause I have MS, and thus handling cd's, putting dvd's in the drive usually isn't a good thing for me to do. .....

    I've never had a problem with either of these games running from game jackal, at present I have v. 3.0.0.5 on. I had been putting on every single update till then, all with no problems. That is, until the other day when the update for 3.0.1.0 came out. Once installed, I got some kind of crash. (I can't remember what it was)

    No biggie I thought, and just rolled back to my last drive image, so now I am back to 3.0.0.5. However, now UT2004 will only launch successfully from Game Jackal about 50 pct of the time, and Far Cry will fail about 99 pct of the time. (Soon as I click on Far Cry from my Game Jackal menu, I get a BSOD, Stop Error, with Bad_Pooler_Call... then it begins (the long) process of dumping memory. (I say long, cause I have 4gb ram)

    I have tried uninstalling/Reinstalling Game Jackal, with no success, I've tried uninstalling/reinstalling the individual games, same results. In short, no matter what I do, I get the Bad_Pooler_Call BSOD. I've even tried a repair install of windows.

    I am running Windows XP Pro, with sp2 .... 4 gb ram, 5 internal harddrives, 2 dvdrw's, and an ATI Radeon X1800 video card ... all on an ASUS A8N Deluxe motherboard.

    Both these games WILL run from their cd's, or even by clicking it's .exe icon, just NOT from Game Jackal. And yes, I do have a ton of stuff running in the background, but nothing that hasn't always been there and running with no problems.

    Thank you for you patience in reading thing longwinded thing.
     
  2. Webslinger

    Webslinger Retired Moderator

    It would probably be best to kill all unnecessary junk running in the background and try again.

    Also click http://forum.slysoft.com/showthread.php?t=4824 and answer the questions fully (especially 14 and 15)
     
  3. mtimerding

    mtimerding Member

    I did not mention, in my previous post, unfortunately I did try disableling everything running in the background ... even as far as going into task manager and ending process, for any uncessarry stuff that didnt show an icon in the systray to hit close on. It made no difference, still got the Bad_Pooler_Call BSOD ..... even tried using "Enditall" to close out any uncessary stuff, still BSOD.

    Yet, as both those games are on my D: drive, I can still go to the drive, click on the particular games .exe, and it runs fine.

    I just can't launch em from Game Jackal.

    :confused:
     
  4. Webslinger

    Webslinger Retired Moderator

    please click http://forum.slysoft.com/showthread.php?t=4824 and answer the questions fully (especially 14 and 15) so that others will be better able to assist you

    At least doing so will provide matthew with a little more troubleshooting information.
     
    Last edited: Mar 31, 2008
  5. matthew

    matthew SlySoft Team Member

    Can you please post the entire stop code.
    It will look something like this

    *** STOP: 0x00000000 (0x000000000000, 0x000000000000, 0x000000000000, 0x000000000000)

    DriverName.sys
     
  6. mtimerding

    mtimerding Member

    In answer to the questions:

    1 ... version 3.0.0.5
    2. ... Windows XP Pro 32 bit, with sp2
    3. ... I have a VSO driver on, and AnyDVD (both were shut down during the numerous install attempts).. All I know about the VSO thing is it appears in my Device Manager as "Pattin Coufin Engine" or something like that.
    4. No Packet writing software (I do use Nero, but did not ever install INCD)
    5. For the Protection ID, it list several lines, like 16, all saying:

    "16:19:04 | D:\Games\Far Cry\Bin32\CryAnimation.dll | Possible CD/DVD-Key or Serial Check " all say Far Cry, none mentioned for Ut2004.

    6. Games are Far Cry and UT2004
    7. Game versions are Far Cry 1.33 and 1.4, and UT2004 I can't see a version nr. for, all I can make out is "Special Edition" (DVD)
    8 Far CRY is cd, and Unreal Tournament 2004 is DVD.
    9. Discs are from USA.
    10. CPU is an AMD Athlon 64 bit 4200+ (dual core)
    11. My two dvdrw's are a Pioneer 108 firmware 1.20 and a Pioneer 109 firmware 1.58
    12. Kaspersky Internet Security v. 7.0.1.325
    13. When right clicking on the Game Jackal icon, and selecting a game to play out of the profiles list, almost 100 pct of the time with Far Cry I immediately get a BSOD, saying something about Bad_Pooler_Call, then it goes into a memory dump. If I select UT2004, it happens about 50 pct of the time (same error tho)
    14. There is NO "Summary.log" in my Game Jackal folder. There's a Launcher.log and a couple profile.log, but no Summary.log
     
  7. mtimerding

    mtimerding Member


    Ahhhh geeee, Matthew, do you really need the entire code? I also didn't mention earlier, (because of my MS I am unable to WRITE, and a print screen won't work from a blue screen does it? :)

    But, if you really must have it, I can generate the error, and try to get my daughter up here to write it down for me just let me know.


    Thank you so much
     
  8. matthew

    matthew SlySoft Team Member

    Sorry about that... it's just that this code tell us quite a lot about the error.
     
  9. mtimerding

    mtimerding Member

    That's allright, I'll receate the error and get my daughter to pen it down for me.. will take me a bit, this is exactly how it will go:

    I had to remove the profile .... so I will have to create another for it. It will play perfectly fine the first (and only) time I run it after creating the profile.
    Then, every single time I select it after running it that first time, it will cause the Stop error. So, it will take me a bit to get it re created. I'll post the results, soon as I get em .....
     
  10. mtimerding

    mtimerding Member

    Okay, Matthew ... that didnt take as long as I figured.
    Here's the exact message:

    " BAD_POOL_HEADER


    (the usual windows has been shut down to protect BS)


    STOP: 0X00000019 (0X000000020, 0X804F4A18, 0X804F5078, 0XCCCCC35E)
     
  11. Webslinger

    Webslinger Retired Moderator

    Update to Game Jackal 3.0.1.0: click http://forum.slysoft.com/showpost.php?p=98726&postcount=1


    That's because you need to update Game Jackal.

    And you should also answer question #15.
     
  12. mtimerding

    mtimerding Member

    Okay, now I think I finally managed to get both answered.

    14 ... I ran UT2004 once, maybe twice, it worked .... I tried Far Cry, and got the BSOD ...... so, UT2004 appears in the summary.log, but not Far Cry cause of the crash I guess ... at either rate, the summary is attached.

    15 .... I finally got this one attached as well.
     

    Attached Files:

  13. Webslinger

    Webslinger Retired Moderator

    Those are the filters that *might* be causing issues. Typically, I haven't found PXhelp20 to cause conflicts, but it's possible.

    1.
    i) Create a backup of your registry
    ii) Download imgburn. It's a free program: http://www.imgburn.com/index.php?act=download
    (it's also an excellent program imo)
    iii) Go to Tools > Filter Driver Load Order.Select "cdrbsdrv". Click "remove selected filter". Select "PxHelp20". click "remove selected filter". select "pfc". click "remove selected filter". Click "ok". Reboot

    Keep in mind the programs that installed those filters will no longer function properly.

    2.
    This is unrelated, but it's time to update Anydvd. click http://sandbox.slysoft.com/beta/SetupAnyDVD6407.exe

    and you may want to update Clonedvd as well: click http://sandbox.slysoft.com/beta/SetupCloneDVD2916.exe

    3. After doing step 1, try creating new profiles.
     
    Last edited: Apr 7, 2008
  14. mtimerding

    mtimerding Member

    More on the BSOD's in Farcy

    Now I'm even more confused than ever ..............

    I've discovered, that IF I change my game options/video display
    to Low or Medium quality ........ it runs fine, no errors.

    But, the strange part is, that is only if run from Game Jackal, if I run it off the dvd, or even from the installed directory, it always ran fine even if using the HIGHEST possible display settings and would only crash if run from game jackal, untill I lowered my graphics settings.

    While this machine is no longer absolute top of the line/state of the art, it's not a commodore 64 either, and I really dont relish the thought of using it like one.

    Any suggestions?
     
  15. matthew

    matthew SlySoft Team Member

    That is very odd indeed :confused:

    Try creating a new profile. However at step 4, under advanced options, set "Game management" to disabled.
     
    Last edited: Apr 7, 2008