Resolved All Amazon Prime attempts fail

Discussion in 'AnyStream' started by Benjamin Ellis, Jan 21, 2023.

Thread Status:
Not open for further replies.
  1. Benjamin Ellis

    Benjamin Ellis New Member

    Yes, I have a prime account. I have successfully used prime for some time. Recently, all prime download attempts instantly fail.

    The error in the GUI is: "Error. Could not fetch the server certificate. Amazon responded with "error". Possible cause: incorrect region..."

    Region is set to: United States and this is the correct region/setting and it has worked in the past. This same error occurs on content successfully downloaded in the past as well as a wide range of content.

    I have the latest version of Anystream. The content does work in other browsers. No issues with other providers.

    I have created a log file and attached it.

    Thank you all in advance.
     

    Attached Files:

    DeepSpace likes this.
  2. cartman0208

    cartman0208 Well-Known Member

    Please try using the latest Beta available at the first thread in this forum
     
    DeepSpace likes this.
  3. DQ

    DQ Well-Known Member

    Just shooting from the hip, if you are using a VPN that would be a possible issue. Another possible problem could be something like pi-hole or another filtering appliance blocking access to an AP CDN.
     
    DeepSpace likes this.
  4. Benjamin Ellis

    Benjamin Ellis New Member

    Will try out the Beta. Thanks.

    Good suggestion. No VPN, do have an enterprise grade firewall blocking things....but it does work with Chrome and Firefox from that same PC and from the same network.

    Other suggestions welcome!
     
    DeepSpace likes this.
  5. DQ

    DQ Well-Known Member

    Just because it works in the browser does not mean it will work in AS. Sometimes it can be the CDN you are hitting. If the browser is hitting one CDN and AS another but the AS one is blocked that would do it. All it takes is a signature update on your firewall to falsely mark a site or a CDN as malicious. Just check your logs or come straight off your modem as a test.

    My gut tells me your error is your firewall intercepting the call from AS and using its own cert instead of the AP cert and since it is untrusted its not working.
     
    DeepSpace likes this.
  6. RedFox 1

    RedFox 1 Super Moderator

    Your logfile is from an older version please use 1.4.9.7, so I can read it properly. You have to use the green downloadables button, no other. Look at the top of the page.
     
    Last edited: Jan 22, 2023
    whatever_gong82 and DeepSpace like this.
  7. Benjamin Ellis

    Benjamin Ellis New Member

    Always use the green button.

    Just upgraded to 1.4.9.7 BETA....

    testing that and looking at firewall rules / wiring around to test that as well. Will let everyone know.

    I did get a provider setup failed Error as soon as I opened the BETA. This may have been a different provider.
     
  8. RedFox 1

    RedFox 1 Super Moderator



    Downloadables.jpg
     
    whatever_gong82 and dtsig like this.
  9. Benjamin Ellis

    Benjamin Ellis New Member

    I upgraded to the BETA....and it is working. I went ahead and skipped scanning on the content filter....too many steps at once...I may peel the last one back and test....

    If the upgrade to the beta version resolved, then it could have been a RedFox issue....

    Will do some further testing and let you know.

    @RedFox1 I see the green downloadable button...I have always used that....and had no issues....
     
  10. RedFox 1

    RedFox 1 Super Moderator

    This thread is resolved.
     
Thread Status:
Not open for further replies.