A bit Lost with RPC2 and RCE (newbie in it)

Discussion in 'AnyDVD HD (DVD issues)' started by Log A3, Aug 18, 2007.

  1. Log A3

    Log A3 Member

    Hi! :),

    First of all, I would like to apologize if this thread has already been discussed before but, so far, I haven't found it yet.

    I'm in a trouble with Vista and this is quite new (maybe following an update or so).
    Every time I try to rip a DVD to a folder usind AnyDVD + CloneDVD (so I can use it directly in MCE), I get the following error from either MCE or Media Player :
    "This file cannot be read because it does not match your region." (sounds like)

    I don't know what to do because I've always used AnyDVD with the default settings just selecting my default DVD region and I've never encountered this problem before.
    So far I've tried to disable all "region removal tools" and it doesn't make the difference.
    And it only happens using Vista. When I try to read these files using XP, every thing's fine.

    Does anybody know how to manage this issue?

    Many thanks,

    Log
     
  2. Webslinger

    Webslinger Retired Moderator

  3. Log A3

    Log A3 Member

    Hi Webslinger :),

    This is what I get using "Status" function with one of the DVDs I'm not able to convert to files (usable under Vista):

    "Summary for drive D: (AnyDVD 6.1.7.0)
    HL-DT-ST DVDRWGSA-S10N AP09 000420070076PF4406
    Drive (Hardware) Region: 2

    Media is a DVD.
    Booktype: dvd-rom (version 1), Layers: 2 (opposite)
    Size of first Layer: 2084960 sectors (4072 MBytes)
    Total size: 4169920 sectors (8144 MBytes)

    Video DVD (or CD) label: Casino Royale
    Media is CSS protected!
    Video Standard: PAL
    Media is locked to region(s): 2!

    DVD structure appears to be correct.
    Found & removed structural copy protection (Arccos, Puppetlock)!
    Found & removed bogus title set!
    Autorun not found on Video DVD.
    Found & removed 11 bad sector protections!
    Emulating RPC-2 drive with region 2!"

    So far, as I told you before, I'm not using .iso files but I just copy the content of the DVD in a folder on my Media Center Computer.
    Just for information When I use .iso files, every thing is fine. But once again, using .iso files is not my aim as MCE does not "natively" supports .iso files.

    thx :bowdown:

    Log

    PS : About your last question : The original Disc does play in both situations.
     
  4. DetroitBaseball

    DetroitBaseball Well-Known Member

    Just don't use Windows Media Player/Center.
     
  5. Webslinger

    Webslinger Retired Moderator

    This is a Sony Arcoss protected disc. Use Anydvd ripper.

    right-click on the fox icon on your toolbar and select "Rip video-dvd to Hard Disk"
     
  6. Log A3

    Log A3 Member

    Thx,

    I'll try to do this :).
    For information, while looking for the origin of this issue, I've found that, even if I disable the DVD region removal tools (3 first options under "settings"), the .iso file I create is always "region free" :(...

    Is it normal?

    Log
     
  7. Log A3

    Log A3 Member

    Unfortunately, my whole system is based on a Media Center solution (automation,..). And so far, I've never had this problem.

    Log ;)
     
  8. Log A3

    Log A3 Member

    OK, done.

    Same problem. I'm still unale to read the files. (Same behaviour with 5 other DVDs I tried tonight : Flushed Away, Babel, Blood Diamond and Pan).

    :(

    I'm going to try an old version of AnyDVD to see (Still have the 6.1.5.4 Setup file).
     
    Last edited: Aug 18, 2007
  9. Log A3

    Log A3 Member

    OK,

    Finally I get rid of this. I don't know why but it seems that something happened during a recent update of Vista. The consequence of this is that, if I want to copy the content of a DVD in a folder and use it under Vista's MCE I've to use AnyDVD under Vista and not under XP as I previously did.
    I still do not understand why or how, but it works.
    So, I've transfered AnyDVD on my MCE computer and, now, every thing is fine!

    Thx for all,

    Log
     
  10. Webslinger

    Webslinger Retired Moderator

    :confused:

    I'm not sure I understand your explanation (nor do I understand how you ripped the files on your Vista system if Anydvd wasn't on it . . .), but I'm glad things are working for you.
     
  11. Log A3

    Log A3 Member

    Ok, sorry, I assume this is a little bit confused :eek:.

    I use to centralise a copy of all my DVDs on a Vista Media Center Computer that's in the living room. This computer is only connected to the TV Screen (only HDMI output). That makes it not very easy to use for copying the DVDs because it means I should monopolize the TV screen for about 30 min each time I would like to copy a DVD...

    To avoid this annoying situation I used to copy the DVDs on an external hard drive, using another computer, and to transfert them at the end of the session. AnyDVD and CloneDVD were set on this computer. But this second computer is a XP computer.

    As I told you yesteday, MCE is not compatible with .iso files. So the only way to have a usable copy of a DVD under MCE is to have all the files of the DVD copied in a dedicated folder.

    Copying DVDs using the XP computer and transfering the result to the Vista MCE computer was "routine" till a few days ago. It had then become impossible to use the copied DVD files with Vista because of a mysterious RCE reason. I guess something happened to XP or to Vista (updates).

    What I found yesterday, trying all possible configuration and testing the behaviour of some original DVDs on the Vista MCE computer - with or without AnyDVD (as you "told me" to do in your first reply) -, is that when I use AnyDVD to copy the DVD files using the Vista MCE computer, the resulting files can be red under Vista. So I decided to move AnyDVD from my XP computer to the Vista MCE computer.

    For informaion, what I also found yesterday, still when trying all possible configurations (even creating .iso files...) is that even if I disable the RPC2/RCE removing functions of AnyDVD (under XP, didn't try under Vista), the resulting .iso files will ALWAYS be Region Free. Amazing isn't it?

    Well, so far I still have to investigate the possibility to install Vista on my second computer and to try to copy DVD files on the external HDD (just like I used to do) to see if the Vista MCE computer will accept them.

    Hope it's a little more clear

    Yours,

    Log :)
     
  12. DetroitBaseball

    DetroitBaseball Well-Known Member

    FAT32 will not accept any file bigger than 4GB that's why it wasn't working.
     
  13. Log A3

    Log A3 Member

    Hi,

    Both my XP and my Vista computer are using NTFS. And so is the External HDD too (it's a NTFS compliant device). But it isn't the problem here as I copy the files that are on the DVD and I do not use a full image of the DVD : none of the VOB files are greater than 1 or 2 Gb.

    Thx for the idea,

    Log :)
     
  14. Log A3

    Log A3 Member

    One Step Further

    Hi,

    Back again.

    As I said, I installed Vista on my second computer and I tried to use AnyDVD on this computer to copy DVD files on an external HDD and to use them on my Vista MCE computer.

    Well, nothing to do... and more : I'm even not able to read the copied files with the computer used for copying the DVD files :confused:...
    This time I'm hopeless for a "remote" solution for copying DVD files and I'm also wondering how long I'll be able to copy DVD files using AnyDVD on the Vista MCE computer... :(

    What happened with Vista???

    Help if ever...

    Log :(
     
  15. mad_fr34k

    mad_fr34k Well-Known Member

    They tried to make a new operating system! thats what happened.

    Stick with XP Media Center Edition till at least Service pack 1 for vista comes out!
     
  16. Log A3

    Log A3 Member

    Hi again... and for the last time about this issue (at least I hope so...) :D

    This is what I finally found :

    Since Microsoft has implemented his very last version of "Microsoft Update" in Vista, something has changed with the "User Account Control" (UAC) system. (I'v reinstalled Vista 3 times and followed what happened with Windows Media Player after each update... fortunately, this update has been set by MS to be the very fisrt one :D).

    UAC has to be set to "Enabeled" to allow MCE or Windows Media Player to play "region free" multimedia files... and I always had set it "off" because I don't understand why I should confirm about 3 times that I would like to use a file or to change a parameter... :mad:

    Well, now I've set the UAC to "Enabeled" and I can work just like I worked before : copying my DVDs on my laptop and transfering them on my Vista MCE computer using an external HDD.

    thx for all,

    Log :)
     
    Last edited: Aug 22, 2007
  17. DetroitBaseball

    DetroitBaseball Well-Known Member

    This is why UAC should always be disabled.
     
  18. Log A3

    Log A3 Member

    :D... read it gain :D

    For playing "Region Free" Mutlimedia Files, UAC (this awfull little thing that makes you believe you're working for a high level security bank) must be enabeled ;)

    Log :agree:
     
  19. DetroitBaseball

    DetroitBaseball Well-Known Member

    Wow, that is flippin' crazy.