8.4.8.0 installer "breaks" Windows Installer service?

Discussion in 'AnyDVD HD (DVD issues)' started by dbminter, Mar 26, 2020.

  1. dbminter

    dbminter Well-Known Member

    This really isn't a DVD issue, but I saw nowhere in particular to put installation issues. So, anyone can move this to where it should belong should that be necessary.


    There may be some kind of problem with the installer with 8.4.8.0. After installing 8.4.8.0, I tried altering the installation of another application, Macrium Reflect, but it fails to alter the installation with the error "The Windows Installer service could not be accessed. This can occur if you are running in Safe Mode, or if the Windows Installer is not correctly installed. Contact your support personnel for assistance." Reflect can be uninstalled, but it cannot be installed again. Trying to reinstall it returns the same error.


    Reflect seems to be the only application this happens on, so I'm thinking about posting this over on the Reflect forum, too. Both Reflect and AnyDVD were updated yesterday.


    I restored my system back to before AnyDVD 8.4.8.0 was installed but after the latest Reflect update occurred. This issue isn't present. But, installing AnyDVD 8.4.8.0 afterwards causes this behavior to appear. It is repeatable.


    I'm going to try restoring back Reflect to before the update and installing AnyDVD 8.4.8.0 on the pre-Reflect update. See if it's a problem with Reflect's latest update.


    Thanks!


    EDIT: What I discovered is it apparently was "caused" by updating to 8.4.8.0. I uninstalled AnyDVD altogether and tried to alter my Reflect installation. That worked. So, I reinstalled AnyDVD 8.4.8.0 and tried altering my Reflect installation. That worked again, too. So, the apparent fix was to uninstall AnyDVD 8.4.8.0 and reinstall it.
     
    Last edited: Mar 26, 2020
  2. James

    James Redfox Development Team Staff Member

    Just a coincidence. AnyDVD doesn't use the "Windows Installer Service".
     
  3. dbminter

    dbminter Well-Known Member

    It's repeatable, though, so it's not a coincidence. It only happens when AnyDVD 8.4.8.0 is installed. I can't explain it only relate the results. :) Though it may not be AnyDVD's fault since it doesn't use Windows Installer Service and may be a problem with Reflect, because, as I said, that's the only app that behaves that way. As far as I tested, anyway.
     
  4. dbminter

    dbminter Well-Known Member

    I had to restore an older image of my system to fix a different issue, but, at ever step of the way, I tested the Windows Installer Service error with Reflect after installing AnyDVD. It never surfaced again over the course of 3 days, so it was some kind of problem that sneaked its way in there somewhere at sometime since January.