5.5.0.0 Images permenantly locked by System after ejecting

Discussion in 'Virtual CloneDrive' started by EchoReaper, Aug 20, 2017.

  1. EchoReaper

    EchoReaper New Member

    My operating system is Windows 10 64-bit (latest version). If I try to move/rename/delete an iso/etc file that I had previously mounted with Virtual CloneDrive and ejected, I get the Windows error:

    "The action can't be completed because the file is open in System"

    I've tried various programs that unlock files, but none of them work, and the only way to unlock the file is to reboot -- this is pretty annoying. This has happened for all iso files I've ever mounted.
     
  2. EchoReaper

    EchoReaper New Member

  3. DrinkLyeAndDie

    DrinkLyeAndDie Retired Moderator

    There is an option "Eject unmounts image file" in the VCD settings. It's always worked for me. I don't recall it being enabled by default, however.
     
    EchoReaper likes this.
  4. EchoReaper

    EchoReaper New Member

    IMO Eject is a much more intuitive workflow than searching through the context menu for a name that always changes, so this is perfect. I've enabled the setting -- thanks!
     
  5. DrinkLyeAndDie

    DrinkLyeAndDie Retired Moderator

    Glad to help and I agree that it's more intuitive. If my memory is correct the post you linked to was a reply James gave before the option was added to VCD.
     
    EchoReaper likes this.
  6. Spirit Wolfe

    Spirit Wolfe Well-Known Member

    I have used that "Eject to Unmount" option ... since forever and I never had a locked ISO, ever. ;)
    Yes. I do not use version 5.5.0.0 of VCD I use v5.4.7.0. I never found a real reason to update from way back when I was using Windows XP and 7. However, I did update my ElbyCDIO.sys file to patch the security issue, BTW...