1.1.7.1 feedback

Discussion in 'CloneBD' started by Clarity3, Nov 28, 2017.

  1. Clarity3

    Clarity3 Well-Known Member

    The greatest difference I see with version 1.1.7.1 is the increased transcoding time.

    Using ‘King Arthur-Legend of the Sword’ as the donor ISO and making a ‘Partial’ copy to 25GB, no subtitles, directly play main title, original audio;

    Version 1.1.7.1 took 79 minutes to transcode with the processing message continually saying it could operate between 118% and 157% faster. The CPU usage was 40-47% and CPU idle 59%.

    In comparison version 1.1.7.0 took 36 minutes, with only the occasional ‘could operate faster’ message. The CPU usage was 96% and CPU idle 2%

    Log files attached.
     

    Attached Files:

  2. Pete

    Pete Forum Admin Staff Member

    That is interesting - so far I can't reproduce this.
    I tried to match your setting:
    • no hardware acceleration
    • reading directly from decrypted ISO
    • source is AVC video
    I get the exact same transcoding speed and CPU usage with 1.1.7.0 and 1.1.7.1.

    During transcoding with 1.1.7.1 - there are these bars to the bottom-right. What are they showing?
    Normally you'd see the first 3 at 100% and the last one at zero most of the time.
    That would indicate, that the video encoder is the bottleneck, which is normal.
     
  3. Clarity3

    Clarity3 Well-Known Member

    The graphical bars difference between 1.1.7.0 and 1.1.7.1 are shown below. Encoder input is the significant difference.
    Additionally, the graph itself shows an almost flat line for 'Frames per second'

    Graphical bars:

    1.1.7.0
    Video decoder input 100%
    Convertor input 100%
    Encoder input 100%
    Encoder output 0%

    CPU usage CloneBD 94%
    CPU usage by other apps 3%
    CPU idle 3%

    1.1.7.1
    Video decoder input 100%
    Convertor input 100%
    Encoder input 0%
    Encoder output 0%

    CPU usage CloneBD 46%
    CPU usage by other apps 2%
    CPU idle 55%
     
  4. Clarity3

    Clarity3 Well-Known Member

    Hello Pete

    I should have also said the conversions with 1.1.7.1, while giving the indications above the result is unplayable. I have now tried another three BD's and get the same symptons and outcome.

    I notice a couple more similar (if not the same) threads and wondered if this an issue with 1.1.7.1 or do I have a system problem?
     
  5. Pete

    Pete Forum Admin Staff Member

    Unplayable with what player? And in what way? "Unplayable" can mean so many things. Error message? Black screen?

    I can reproduce your slow transcoding now.
    It happens when
    • you don't have any hardware acceleration
    • have a CloneBD license (ironically)
    A single CPU core clogs up, then.
    This only affects processing speed, not the outcome and certainly will be fixed in the upcoming beta.

    I really can't confirm any unplayability. Tested with PowerDVD 16, even with "King Arthur" and your settings closely mimicked.

    Can you please point me to some? I don't recall seeing similar threads.
     
  6. Clarity3

    Clarity3 Well-Known Member

    Playing with PowerDVD15; pick converted title from hdd - player gives the impression it is about to play then jumps back to the PowerDVD home screen. Tried with three titles converted with 1.1.7.1, all behave the same.

    I was referring to the 'CloneBD Internal Transcoder Error' thread, although it is indicating a different type of symptom and my 'similar' was the reference to transcoding.

    Edit:
    I have noticed a difference in the transcoded output sub folders. With 1.1.7.1 the sub folders META, JAR, BDJO and AUXDATA are not present in the BDMV folder albeit apart from META they are empty in 1.1.7.0.
     
    Last edited: Nov 30, 2017
  7. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    You don't play Blu-ray in file mode like you're doing (dragging title into pdvd). Bluray is meant to be played in DISC MODE only. Drag the entire conversion folder and I'm willing to bet it'll work just fine.

    Sent from my Nexus 6P with Tapatalk
     
  8. Pete

    Pete Forum Admin Staff Member

    Are you sure, that's not from a manually aborted transcode? In that case, yes, not everything is written.

    But from your log file for King Arthur, v.1.1.7.1:
    M:/CloneBD Files/King Arthur - Legend of the Sword/BDMV/META/DL/bdmt_eng.xml
    ...

    Empty folders don't get listed there, but at least the META folder is evidently there.
     
  9. Clarity3

    Clarity3 Well-Known Member

    I'm not playing in file mode. I have selected the title from the PowerDVD BD folder option in disc mode.
     
  10. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    That's still file mode because you're manually selecting the mpls / m2ts. The only way I can recommend is to drag the entire folder for proper full disc playback.

    Sent from my Nexus 6P with Tapatalk
     
  11. Pete

    Pete Forum Admin Staff Member

    PowerDVD normally plays individual m2ts files just fine. With older versions, there used to be audio problems because of licensing limitations, but I believe, even those are history.
     
  12. Clarity3

    Clarity3 Well-Known Member


    Extract from PowerDVD User Guide:

    Playing Movie Files In PowerDVD
    upload_2017-12-1_7-33-11.png

    This is the same method as used with other applications such as ImgBurn where the folder can be selected and the program extracts the BDMV structure.
     
  13. Pete

    Pete Forum Admin Staff Member

    OK, now I'm starting to wonder: did you try playing back an individual m2ts file or did you play back the entire folder?
    It makes a world of difference, because if you tried to play an m2ts file (which is what I thought you said in your posts from yesterday), it would mean, that this file and only this file is broken.
    If you played back the entire folder (which I believe you were saying in your last post), that would mean any file from the entire BDMV subfolder structure can be broken or missing.

    If it's the latter, I'd concentrate on what you mentioned before - that entire folders seem to be missing, but then again, your log file said otherwise.

    These are all a lot of mix ups, that make it really, really difficult to get to the cause.
    So we need to know from a copy, that doesn't work:
    • does playing the main movie m2ts file individually in PowerDVD work or not?
    • Are folders missing?
    • CloneBD log file from that exact transcoding process
     
  14. Clarity3

    Clarity3 Well-Known Member

    Apologies if I have been unclear.

    From our emails I have explained the current difficulty in repeating the playback failures I saw originally and do not have a failing example to try.

    As said in the post above. "I have noticed a difference in the transcoded output sub folders. With 1.1.7.1 the sub folders META, JAR, BDJO and AUXDATA are not present in the BDMV folder albeit apart from META they are empty in 1.1.7.0."

    The only log file currently for a failing playback is the 'King Arthur_1171.cbdlog in my first post above.
     
  15. Pete

    Pete Forum Admin Staff Member

    Yes, I read that, but as I said: the log file from King Arthur in your first post, indicates, that these folders are not missing.
    That's why I think - with all those tests you did, you may have noticed missing folders after an attempt, that you manually aborted, in which case missing folders would be expected.
     
  16. Clarity3

    Clarity3 Well-Known Member

    I have sent you an email, but just to say, you could be right but the reference to the missing sub folders was sent straight after after the first conversion with 1.1.7.1 and then the comparison with 1.1.7.0
     
  17. Clarity3

    Clarity3 Well-Known Member

    Pete, just to say, 1.1.7.2 has fixed this issue.

    I am interested to know which of the fixes in the changelog has overcome the problem.
     
  18. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    this one

     
  19. Pete

    Pete Forum Admin Staff Member

    :unsure: what made you think that?
    Neither does he have Intel acceleration, nor is he processing multiple discs in a row.

    Anyway - as for the speed issue mentioned at first, it would be this:
    The other thing - unplayability... I have no idea.
     
  20. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    My bad. Sounded the most logical one to me sorry

    Sent from my Nexus 6P with Tapatalk