1.0.9.3 - Could not load play list

Discussion in 'AnyStream' started by SomeRandoDude, Mar 14, 2021.

  1. SomeRandoDude

    SomeRandoDude Member

    I've been getting this error A LOT on Amazon since updating to 1.0.9.3. It's been an intermittent issue in various previous versions, but it's a very consistent problem in the latest version. In the past it was cleared by simply reloading the series page or the season page. Whichever I was having the problem with.

    But the issue has been more difficult to clear in 1.0.9.3. Some times, like now, it won't clear with a series/season reload. And hasn't cleared even after closing AS and re-launching.

    Service: Amazon Prime (Starz)
    Series: Black Sails
    Season/Episode: s2e1

    Log attached
     

    Attached Files:

  2. Prospere

    Prospere RedFox Development Team

    As it may be seen in the log messages (you may go to the "File" menu and select "Show log messages"), there appears to be a network problem, meaning that AnyStream cannot access the remote server hosting the playlist.

    The next time you encounter this problem, could you please open the "show log messages" box, copy the URL listed as "Playlist URL" and try to access it via a browser?
     
  3. SomeRandoDude

    SomeRandoDude Member

    Loading the play list URL directly in a browser causes it to down load a *.mpd file which I can open in notepad. So I appear to be able to retrieve the file from a browser. However, just tried again to record Blacksails s2e1 and I continue to get the same "could not load play list" error from AS.
     
  4. Prospere

    Prospere RedFox Development Team

    Is there any firewall or a VPN in the middle? There's clearly something blocking AnyStream from finding the CDN server.
     
  5. SomeRandoDude

    SomeRandoDude Member

    I'm not using a VPN or FW. I do run pihole on my network, but that's fairly defined and shouldn't be affecting it. Pihole would block access entirely, regardless of the end point attempting to access the URL.

    Interestingly though, as I mentioned in my first post, I would see this error occasionally in previous versions of AS and were easily cleared by reloading the series/season. But since updating to 1.0.9.3 I see the error very regularly. Most of the time I can clear the problem by reloading the series/season, but I do note that it can take several attempts now whereas it was a very simple single reload previously. This is what lead me to believe it was an AS problem, but you believe its an external one?

    Is there anything else I should look at to help narrow this down?
     
    Last edited: Mar 15, 2021
  6. RedFox 1

    RedFox 1 Super Moderator

    Have you tried disabling Pi-hole and see if the issue persists?
     
  7. DQ

    DQ Well-Known Member

    Redfox 1 is 100% correct. If you cannot disable it easily (in my network that's the case) you might try just waiting until you have the issue and then checking your log for recent blocks and see if anything CDN related is in there. Again to Redfox 1's point, pihole has caused me a little heartache with AS previously so it is entirely possible.
     
  8. SomeRandoDude

    SomeRandoDude Member

    Yes, and it did end up being a pihole issue. When I searched through my logs previously I had a typo. Correcting the type immediately showed me I needed to add a single whitelisting. Problem solved. thanks!